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About This Guide 
This guide is the primary documentation for people doing amateur radio contesting using an 
Apple Computer running macOS 10.15 (Catalina) or later and the SkookumLogger application. 
SkookumLogger is available without cost on the Apple Mac App Store. It is frequently updated to 
include new features such as support for additional contest events, and to fix bugs. 

Documentation Styles 
Most images apply for SkookumLogger running on macOS 13 (Ventura) in Dark mode. Earlier 
macOS versions may have somewhat different appearances. Ventura replaced “Preferences” with 
“Settings”, and that terminology is adopted here as well. 

File > New Log… is a reference to a menu item. Confirm Quit (YES) in Logging settings is a 
reference to a setting a item with that name in the Logging panel of SkookumLogger > Settings; 
when the setting is being described, the default value will appear in parentheses. 

Keyboard Notation 

In this guide, ‘⌘A’ means press the Command key (⌘) together with the A key. Similarly ⌥⌘D 
means press the Option and Command (⌘) keys plus the D key. Option may be marked as Alt on 
some keyboards. Ctrl refers to the Ctrl key. Fn refers to the Fn key. The symbol for the option key is 
⌥ on some keyboards. The symbol for the return key is ⏎ on some keyboards. Text in this style 
refers to SkookumLogger menus, menu items and labels. Also see this list of symbols. 

Document Organization 
A table of contents follows the title page, listing the document sections and the chapters within 
those sections. A more detailed table of contents is located at the beginning of each section, listing 
the chapters within the section and the subheadings within each chapter. A PDF viewer with 
searching facilities, like Preview, can help you find terms when you can’t guess where a topic might 
be discussed in a table of contents. 

The Introduction section begins with a brief, umm, introduction to amateur radio contests in 
general and and an overview of the desirable features of good contest loggers, followed by 
somewhat obscure information about using macOS tables and instructions for installing 
SkookumLogger. 

The Setup section covers one-time settings configuration and the general steps for preparing for a 
new contest. 

Basic Operating walks you through the fundamental steps for entering a contest and submitting 
your results to the contest sponsor..  

The lengthy Advanced Operating section looks at how to use additional features in 
SkookumLogger to improve your performance as a contest operator and techniques for optimizing 
contest logging. 
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External Devices and Networking documents the details of the various kinds of hardware that 
SkookumLogger can communicate with, along with how SkookumLogger can interact with other 
applications, including itself via SkookumNet. 

The h section has chapters contributed by SkookumLogger describing how they set up and use 
SkookumLogger with their station equipment and operating style. 

The Reference section has an annotated diagram of the elements in the main window, many in-
depth discussions of features, and several FAQs. 

Acknowledgements 
Jonathan, GØDVJ, created many previous versions of this guide. 

New content has been added from the now-obsolete Help Book, authored by me, and from articles 
previously presented on the web site Hints page, authored by me, Bud, W2RU, Bob, WA1Z, and 
John, K1JSM. 
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Radio Contesting 
Amateur Radio contests are one of the more competitive aspects of the Ham Radio hobby. There 
are many contests organized by sponsors in different countries around the world. They cover the 
HF bands, VHF/UHF bands and modes such as phone (SSB — Single Sideband, FM — Frequency 
Modulation), Morse code (CW — Continuous Wave) and data modes (FSK RTTY — Radio Teletype, 
PSK — Phase Shift Keying, and others.)  

Contests range in duration from an hour or so through to 48 hours, and some are arranged in 
regular repeating championships or series. Each contest has specific objectives for the participants 
to achieve. For example these can be as simple as just working as many stations as possible in the 
time period allowed (sometimes known as “rate contests”), but are often augmented with 
additional aims, such as attempting to work as many countries, zones, regions, islands, grid 
squares, kilometers or other groups (perhaps members of particular clubs or societies for instance) 
as possible for either bonus points or a multiplication factor for the individual contact points score. 
All events however require the operator to not only make contacts efficiently but also copy the 
required information accurately. This minimum information required to be passed between 
contacts is known as the exchange. The exchange may or may not be the same for all participants, 
depending on the contest rules and scoring.  

After the contest event, participants submit their logs of contacts with the exchanges in a required 
format (e.g. Cabrillo) to the contest sponsors or organizers for subsequent adjudication. In recent 
years, live online scoreboards have also become possible during the contest event.  
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Contesting Software 
In the distant past, operators in contests would typically record all the contacts in a paper log. This 
often required lots of work checking and preparing the entry afterwards. In most contests, working 
the same station twice is not allowed, subsequent repeated ones being known as duplicates or 
dupes. This also had to be monitored by the operator in the past using paper check sheets of one 
sort or another.  

Over the years, the personal computer has increasingly been used by contest operators to record 
the contacts made and to prepare the entry for submission to the organizers. As the technology 
has progressed, such contest logger software has begun providing additional facilities of use to 
the contest operator, including real time analysis of how far the specific objectives are being met, 
sending Morse code (CW) or audio calls, analyzing which stations are active on the bands and 
others. Additionally, some software specifically supports teams of operators taking part in one 
event and allows for communication between them and synchronization of logged contacts by 
them. 

Many contest loggers have been produced over the years; most of the best ones being produced 
by experienced contest operators themselves, who understand the precise requirements that 
contest operating puts on the software. Most of the well-known packages have been written for 
Microsoft Windows operating system. They include CT, G3WGV, N1MM, N1MM+, WinTest, DXLog, 
WriteLog, SuperDuper, Minos, FJP Log, and TAClog. Until SkookumLogger, users of the macOS 
operating system have had a more limited selection to choose from, including RumLogNG, Aether, 
and MacLoggerDX combined with Cab-Converter. These are “Swiss Army knife” applications that 
tend to offer general logging facilities with contesting features “bolted on.” SkookumLogger’s 
prime purpose is contest logging, offering a more comprehensive set of facilities specifically for 
contesters than general logging software does. 

Unlike general logging programs, contest loggers need to be optimized to facilitate quick and 
accurate entry of only the information which is required per contact. Much of this information is 
ideally presented by the software so that minimal keying is required to enter or edit the exchange 
received. This may include pre-populating or auto-completion (known as “pre-filling”) of some 
information fields. Since different contests have different exchange requirements, the data entry 
fields must be customized accordingly. Duplicates must be flagged for the operator as soon as 
possible, and ideally any specific objectives such as new countries, regions, or islands worked 
should also be highlighted. Information tables should ideally allow the operator to easily see which 
stations are required or are most valuable for points. Essentially, the software must understand the 
rules of each contest supported. 

Contesters typically employ two modes of operation, known as running and S&P (search and 
pounce). When running, the operator stays on one frequency and calls CQ, letting other stations 
answer. In S&P, the operator tunes up and down the bands and answers others who are running. 
Good contest loggers will understand these two modes and support ways to switch between them.  

The rules for most major contests provide separate entry categories for “assisted” and “unassisted” 
(or “connected” and “unconnected”) entrants. Although the exact definition of those two words 
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varies somewhat from sponsor to sponsor (ARRL uses “unlimited” instead of “assisted”), “assisted” 
usually means the use of help from beyond one’s self or one’s own station during the contest 
period in identifying and working stations, knowing which bands are open to what areas, etc. A 
superior contest logger will be optimizable for either assisted or unassisted operation; in the 
former case, it will support sensible presentation of information from the ubiquitous DX Cluster 
and allow the operator to easily make use of it — by tuning the radio to the correct frequency for a 
needed contact, for example. A feature known as band-mapping is extremely useful for bringing 
together information about activity on the band(s) of interest from a variety of sources. 

For some of the features already mentioned above, as well as other reasons, a contest logger 
should connect to the CAT (Computer Aided Transceiver) port of each radio used by the operator 
and exchange at least frequency and mode information with it. There are also other pieces of 
hardware which the software can usefully connect to. One is the key jack of the radio for CW so that 
required Morse messages stored in the computer’s memory can be quickly, easily and 
automatically sent, letting the operator concentrate on receiving (often at high speeds in contests) 
rather than constantly switching their brain from sending to receiving and vice-versa. Although 
some software attempts to generate the keying signal from the computer itself, this is often 
problematic in achieving reliability of timing due to variation in the computer internal clock speeds. 
Therefore one common hardware box which has almost become a de facto standard, the WinKeyer 
by K1EL, is often supported by loggers. Additional interfaces to hardware in the contest operator’s 
shack that a contest logger can usefully connect to include antenna switches, linear amplifiers, and 
antenna rotators.  

To cope well with both HF and higher band contests, a contest logger needs to understand and 
reflect the ways that operators of each persuasion typically work. Given the difference in distances 
and propagation modes worked, signal reports in contests on HF tend to be given consistently as 
59(9) for each contact, whereas on the higher bands more genuine reports tend to be used so that 
there is some indication given to the other party about the number of times the exchange may 
need to be given to successfully copy it under the prevailing conditions (e.g., aggressive fading). 
The upshot is that the sent report field is not usually needed for HF contest exchanges whereas for 
higher band events it is. For the latter, the scoring is usually based on some element of distance 
calculation between 6 character locator grid squares (based on the Maidenhead system), whereas 
for HF the scoring is typically based on country, continent or other fixed points per band/mode/
contact. This is another example of a difference which the logger needs to accommodate. 

Finally, a good contest logging program will minimize the operator’s need to take his or her hands 
away from the keyboard — whether to use the mouse or to change settings on station equipment. 
This is especially true when “running” contacts on a single frequency or when interleaving contacts 
between two separate rigs. Consequently, virtually every feature of SkookumLogger has been 
designed with that objective in mind. Throughout this Guide you will find reference to “clicking” on 
an option button or a menu choice. Where such “clicking” might reasonably be expected to be 
invoked during a contest, SkookumLogger’s author has made every effort to be sure an equivalent 
keyboard command is available — either as a default or through customization techniques 
described in the following chapters.  
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SkookumLogger Overview 
SkookumLogger is an amateur radio contesting application for macOS 10.15 (Catalina) or later. 

SkookumLogger supports participation in CW, SSB, FM, FSK (RTTY), PSK and mixed-mode contests 
on the 6 HF contest bands and 10 VHF/UHF.  

All information for a specific instance of a contest or special event is stored in a single file called a 
log. Log files are identified by the SkookumLogger icon (shown on the title page of this guide) and 
also by the macOS file extension “sl-binary” if your Mac Finder settings have file extensions visible. 
There is no practical limit to the number of QSOs in a log. Only one log file can be open at a time. 

QSOs are tabulated in the application main window, named the Log window. New QSOs are 
added by filling in data entry fields and tapping ⏎, which automatically saves the updated log 
after each QSO. QSOs may be separately entered for running and during search & pounce, 
allowing for the latter to be easily interleaved with the former.  

The Log window has many optional utility windows, including: 

✦ Pass Information, showing bands where the entered call, or the multiplier of the entered call, 
has been worked before. 

✦ Checksheets, showing the number of QSOs logged with six kinds of multipliers: countries, 
zones, regions, prefixes, grids and other. 

✦ Time Tracker, showing on-time and off-time data. 
✦ Rate Tracker, showing QSO rate statistics. 
✦ Score Breakdown, showing per-band and total QSOs and multipliers, and score. 

✦ Activity Tables, showing tables of known calls with their frequencies, modes, and other 
information 

You can connect a radio to provide frequency and mode for each QSO record. You can connect a 
K1EL WinKeyer USB ASCII-to-morse generator to send CW from the keyboard or from 
customizable stored messages. With a radio that has voice message memory functions, you can 
trigger such voice messages from SkookumLogger. 

SkookumLogger can display a global Great Circle map with optional overlays showing the solar 
terminator, space weather data, receive and transmit antenna patterns, antenna names, and target 
location of the current QSO. An interface for up to three rotators can also be used to point the 
transmit antenna towards the current QSO for Green Heron, EasyRotor, or SarTek rotor systems.  

A Grid map may also be displayed, which can highlight grid squares worked, as well as the 
optional overlays already described for the great circle map above. This map of grid squares is 
especially useful for VHF and up contests where grid square multipliers or bonus points can often 
be part of the scoring. 

Data (PSK/RTTY) contest support is provided for radios that include inbuilt encoders/decoders 
accessible by CAT connection (such as Elecraft K4, K3S and KX3 etc.). In such data contests, the 
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received decoded text is displayed in an additional window and stored messages may be sent 
using the function keys (similar to CW messages).  

Hardware support is also provided for linear amplifiers such as KPA500, KPA1500, ACOM 2000A 
and Alpha87A, for the SteppIR SDA100 antenna controller, for an XK-24 keypad and for YCCC 
MOAS, SO2R box and SO2R Mini. These YCCC SO2R boxes may also be used instead of the K1EL 
Winkeyer for sending CW. 

With internet access, you can connect to a DX cluster node for sending and receiving DX 
announcements. Local spots added from another instance of SkookumLogger running on a locally 
networked machine will also appear in the activity window, uniquely labelled. These data are 
presented in separate activity windows for each contest band. 

SkookumLogger has a database containing the exchanges for stations that you have worked in 
previous contests, which can pre-fill exchange fields.  

You can export a log document in the Cabrillo format for submission to contest sponsors or for log 
analysis, in the ADIF format for import into other logging software, and in CSV (comma-separated 
values) format for import into spreadsheet analysis tools such as Numbers or Excel. 
Comprehensive statistics reports are also available after a contest, including rate analyses.  

Contest operating is supported for single operators using one receiver, two receivers in one radio, 
and two radios (SO2R). Advanced operating such as 2BSIQ (Two Band Synchronized Interleaved 
QSOs) is also supported.  

Multi-operator support is also provided, either in partner mode where a second operator assists 
the main operator by listening to calls on the same radio and can prompt for callsigns heard 
without needing audio conversation, or where both operators are using separate radios and 
contributing QSOs simultaneously (Multi-Two). These features use SkookumNet, a built-in local 
networking facility which allows other instances of Mac computers running SkookumLogger to be 
detected and share information about the current log. “Gab” messages may also be passed 
between operators using this networking.  

If you have a radio with panadapter video output available and a suitable USB frame-grabber 
interface, the video can be displayed within SkookumLogger. Signals on the waterfall display of an 
Elecraft K4 can be labelled from the Activities information and colored according to needed status. 
Pouncing can be achieved by clicking within the SkookumLogger Panadapter window. 

A practice mode simulating a contest is provided to help improve CW operating skills in handling 
pile ups when running a frequency. The practice sessions can simulate multiple stations 
simultaneously responding to your CQs, with the primary objective of helping you learn how to 
accurately and quickly pick out individual callsigns in the presence of QRM and band noise. This 
practice mode can also support some advanced dual radio setups. Practice with S&P is also 
possible in SkookumLogger, using your radio to tune around finding simulated stations that are 
calling CQ. These “pouncees” answer you or others calling them to complete simulated QSOs.  

Although optimized and intended as a contest logger, SkookumLogger also provides some 
general logging configurations which can be used for special event stations, etc. 
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Table Manipulation 
Many SkookumLogger windows contain tables. These tables share behaviors provided by macOS 
that are not easily discoverable. These behaviors involve using the mouse with the pointer over the 
table header — the row of labels above the table content. 

Column Size 
Hovering over the edge of a column in the header may show the left-right resize pointer, indicating 
that the column width can be changed for the column to the left of the pointer. Drag left or right to 
change the width. Each column has minimum and maximum widths which limit how much you can 
resize the column. The pointer changes appearance when the width is at a limit, and doesn’t 
appear at all when the width can’t be changed. 

Column Ordering 
Hold the mouse button down on a column title, wait until you see the drag (hand) pointer, then 
drag left or right to move the column to another location in the table. 

Column Visibility 
The Log > Log Table Columns > submenu affects the table in the main window. Some of the 
columns in this table are always visible, and the visibility of some others depends on the contest 
rules. 

The Activity > Table Items > submenu has submenus for each Activity window, and the All Activity 
Tables Columns submenu that toggles column visibility to the same state for all activity tables. 

 Visibilities for table columns can also be toggled by command-clicking anywhere in the table 
header row to pop up a visibility menu. 

Sorting 
Click on a column title to sort the table rows on the contents of that column. Click again to reverse 
the sort order. Most sorts are alphanumeric. 
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Installation 
SkookumLogger is available from the Apple Mac App Store. After your first download of the 
application, Apple will let you know when an update is available. The app does not depend on any 
other applications. 

There are some system settings that are best optimized once-off for using SkookumLogger. The 
instructions that follow are for macOS 13 (Ventura). 

First, macOS sets the function keys to perform the actions indicated by the icons at the tops of the 
keys. SkookumLogger uses the same keys for often-used actions such as message sending, 
clearing the logging fields, and toggling between Run and S&P fields. With the system settings, 
you would need to hold the fn key while tapping a function key to trigger the SkookumLogger 
action. 

Second, macOS defines and enables keyboard shortcuts that override some SkookumLogger. 
System shortcuts that you don’t need should be disabled, and if the remaining shortcuts interfere 
with SkookumLogger shortcut you should create replacements. 

Using Function Keys as Standard Keys 

Choose  > SystemSettings…, then choose Keyboard near the bottom of the sidebar and click the 
Keyboard Shortcuts… button to open a floating settings window. Choose the Function Keys item in 
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the sidebar and slide the button to the right to enable use all of the function keys as standard 
function keys. 
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Disabling System Keyboard Shortcuts 
Open the floating settings window as above. Select each item in the sidebar except the App 
Shortcuts, Function Keys and Modifier Keys items and disable all non-essential shortcuts. 

Defining Shortcuts for SkookumLogger 
This isn’t necessary when you first begin using SkookumLogger. See Changing Shortcuts for 
details. 

Quickly Making SkookumLogger the Active App 
SkookumLogger creates an item named Focus QSO Entry that shows up in the General category of 
every app’s Services menu when SkookumLogger is running. Choosing this item opens 
SkookumLogger if it isn’t already open, makes SkookumLogger the active application, and sets 
keyboard focus in the most-recently-focused QSO data entry field. This can be useful when, for 
example, you are momentarily using another application while the CQ message is being sent, and 
someone suddenly answers — you need to get back to the entry fields as quickly as possible to 
enter the call you have heard. 

You can define a keyboard shortcut for the service in the Services sidebar item of the Keyboard 
Settings floating window settings window described above. 
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Settings Window 
SkookumLogger settings (nee “preferences”) are collected in a window with a tool bar containing 
buttons that choose one of six panels containing related setting values: 

The name of the selected panel is shown in the window title; New Log in the example. The panel 
name for each icon from left to right are: New Log, Activities, DX Cluster, Logging, Messages, and 
OpMode. 

Choose SkookumLogger > Settings… to open the window. Alternatively, the SkookumLogger main 
window has a row of three settings (gear) buttons that directly open the Logging, Messages, and 
OpMode panels: 

Activity windows and the DX Cluster window also have settings buttons that directly open their 
settings panels. 
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First Time Setup 
1. Open the SkookumLogger > Settings… window and choose the New Log panel. 

2. Set up your Cabrillo defaults in the Cabrillo tab. 

3. Set up your sent exchange defaults in the Sent Exchange tab. 

4. Close the settings window. 

5. Choose File > New Log… to create a new log. 

6. Optionally, but highly recommended: configure your radio. 

Note: In macOS 13 (Ventura), Apple changed terminology from Preferences to Settings and 
introduced an awful new user interface. The steps below separately describe system setting 
changes for each case. The SkookumLogger user interface and this document use the new term. 

System Preference (Before macOS 13) Recommendations 
Turn off the “Close windows when quitting an app” option in the General pane, so that 
SkookumLogger will open your most-recently-open log at startup. 

Turn on the “Use F1, F2, etc. keys as standard function keys” option in the Keyboard tab in the 
Keyboard pane, so that you don’t need to hold the fn key while tapping a function key to transmit 
SkookumLogger messages. Also review the settings in the Shortcuts tab if you discover a collision 
with default SkookumLogger shortcuts. 

If you use two displays with SkookumLogger, turn off the “Displays have separate spaces” option in 
the Mission Control pane, so that open windows will be restored to positions they were in prior to 
any SkookumLogger restarts. 

System Setting (macOS 13+) Recommendations 

✦ The “Close windows when quitting an application” option is located in Desktop & Dock settings, 
within the Windows & Apps group. Turn this off so that SkookumLogger will open your most-
recently-open log at startup. 

✦ The “Use F1, F2, etc. keys as standard function keys” option is buried in Keyboard settings. Click 
the Keyboard Shortcuts… button, then choose Function Keys in the sidebar. Turn this off so that 
you don’t need to hold the fn key while tapping a function key to transmit SkookumLogger 
messages. While there, review the shortcuts in the other sidebar items, and define shortcuts for 
SkookumLogger in the App Shortcuts sidebar item. 

✦ The Displays have separate Spaces option is located in Desktop & Dock settings, with in the 
Mission Control group. If you use two displays with SkookumLogger, turn this off so that open 
windows will be positioned as you left them across SkookumLogger restarts. 

✦ If you prefer the Dark system appearance, experiment with the effect of the Increase contrast 
option in the Display group of system Accessibility settings. 

Note:  If you use a Logitech MX-3 keyboard,  hold the “fn” key and Tap the “ESC” key to toggle “Use 
F1, F2, etc. keys as standard function keys” behavior. 
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Help 
This guide contains the latest documentation. It is accessible via Help > SkookumLogger Guide, 
which opens the document in Preview or your default PDF app. Open the Table of Contents 
sidebar to navigate to topics in the document.  

Hint: macOS shows a search field at the top of the list of Help menu items. Type into the field to 
find matches in the SkookumLogger menus. This is a convenient way to choose menu items that 
don’t have keyboard shortcuts, without navigating through the menu system with the mouse. 

Hint: Many user interface elements throughout SkookumLogger have tooltips which appear when 
you hover your mouse over the element. 

When you first run SkookumLogger after installing it, you will likely see just the SkookumLogger 
menus across the top and a single window titled Status Messages. This window logs various status 
information.  

The first thing to do is to complete some basic information for new logs. Chose SkookumLogger > 
Settings…, then chose the New Log panel by clicking the SkookumLogger document icon (the left-
most icon in the window toolbar). 
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Cabrillo Default Settings 

Choose the Cabrillo tab to enter defaults for information needed when you generate a Cabrillo file 
with SkookumLogger. Cabrillo is the name of a log format used universally by contest sponsors for 
processing your contest entry. When you create a new log in SkookumLogger, most of the fields for 
the Cabrillo log format are initialized from the defaults in this pane. You can modify the settings for 
a particular log using Log > Settings… without affecting these defaults. 

If you forget to change the default My call setting to your own call, the Status Messages window 
will open the Status Messages window every time you start SkookumLogger as subtle reminder. 
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Sent Exchange Default Settings 

Choose the Sent Exchange tab to establish defaults for various kinds of fields in your sent 
exchange. 

The initial values shown here are meant as an examples of what you should enter. SkookumLogger 
uses these fields when setting up your sent exchange for a new contest log, depending on the 
contest’s rules. The sent exchange is shown in the Prompt line above the log table in the main 
window. After creating a new log, you should always confirm the Prompt is correct before logging 
any QSOs; if it wrong, use the Sent Exchange Editor to correct it. 

The Grid field defines the location of your transmitter in Maidenhead locator coordinates. See the 
Grid Information Tool for details on this topic. 
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CW Messages Default Settings 

SkookumLogger stores up to 16 messages that can be sent by pressing a single key. The messages 
in the left column are associated with the first eight function keys. These defaults are enough to get 
started. See Morse Messages Editor to learn about these settings and how to change either the 
defaults for new logs or the messages for a particular log. 

Message Special Key Settings 
SkookumLogger allows defining special keys for sending messages with a single key. These 
include various messages typically used for CQ and exchange passing and acknowledgement, and 
Magic Message.  
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Connecting Your Radio 
Before any contest, ensure SkookumLogger is set up to work with the radio(s) you will use. If your 
computer is in the shack and permanently connected to the radio then the settings and connected 
status are remembered for you. Otherwise, configure the radio as described in the Radios chapter.  

With the radio connection enabled, the current frequency and mode of the radio should be 
displayed above the data entry fields at the top of the main SkookumLogger logging window. 
Changes to the radio (e.g. frequency and mode) should be reflected in this information. If ’NS’ (not 
supported) is displayed then the radio has not been recognized and you should check the 
connections and parameters again. 

If for any reason you cannot yet connect your radio to your computer, you should select the 
Phantom option on the Other sub-menu for Type. This will allow you to set frequency and mode 
manually. The easiest way to set the frequency manually is to type it in the call entry field and tap 
⏎. For example, typing 3560 will result in setting the frequency to 3.560MHz in the 80m band. 
Typing CW or another recognized mode into the call field and tapping ⏎ will similarly set the 
mode. You can also select mode from the Radio 1 menu. 

Version 5.4	 Page 18



SkookumLogger Guide

Contest Log Setup 
There are three important steps for setting up to operate in a specific contest event: 

1. Select the contest event 

2. Check the start date 

3. Check the sent exchange 

You may want to do three additional tasks; these can be done any time before or during the 
contest: 

1. Customize the Cabrillo info 

2. Customize the log table 

3. Set up additional windows 

This steps are detailed below, using the CQWW DX SSB contest as an example. Additional 
guidance for contests which involve CW or data modes is provided later. 

Select The Contest Event 
Choose File > New Log… to open the 
New Contest Log window. The default 
selected contest is CQ World Wide DX 
Contest CW. Use the Contest Names drop 
down Contest Names to choose the name 
for the contest you want to enter. In this 
example, select CQ > CQ World Wide DX 
Contest SSB. For contests where there is 
an “inside” or “outside” option, be sure to 
select the relevant one depending on 
your location to ensure that the exchange, 
scoring and other parameters will be 
correctly configured (e.g., for the All Asian 
contests, select the Inside option if you 
are in Asia and “outside” if you are not).  

Click the Done button once your selected 
contest is displayed below the drop down 
menu. A new logging window opens, replacing an existing logging window if one exists, and the 
normal macOS save file dialog appears. Choose a location and name for your log file and click 
Save.  

Note: If you cancel the Save dialog, SkookumLogger will ask you to name and save it as soon as the 
first contact is logged, which may not be as convenient! 

After saving, the file name is displayed in the main window title bar.  
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SkookumLogger is now configured to know the rules of this particular contest, including what the 
exchange format is, what multipliers, if any, are involved, what constitutes a dupe, and what the 
scoring is for the contest. 

Check the Start Date 
Choose Window > Tools > Time Tracker to open the Time 
Tracker window. This window shows information about the 
start, duration and end for the next running of you new 
contest. Sometimes SkookumLogger gets the start date 
wrong. Verify that Start date is correct; if not, edit value and 
choose Apply Changes. See Time Tracker for more 
information. 

 
 
 
 
 
 
Check the Sent Exchange 
The sent exchange is displayed in the prompt text above the 
data entry fields of the logging window, to the right of the 
current UTC time display. SkookumLogger tries to populate 
the sent exchange fields correctly for you, from the information that you originally entered in Sent 
Exchange Default Settings. In our example the sent exchange is Contest Call, RS(T) and CQ zone. 
The zone value is derived from the Contest Call. 

If you need to correct the exchange, choose Window > Editors > Sent Exchange Editor. 

Customize the Cabrillo Info 
Choose Log > Cabrillo Settings… to display the settings sheet for the log. On the left, you will see 
much of the information you originally entered in Cabrillo default settings. If any of this information 
is incorrect for the contest you are configuring, alter it at this stage. On the right, you will see a set 
of drop down menus offering various Cabrillo category items. Ensure that each item is set 
appropriately for the sections of the contest that you will enter. Add other operators to the list 
Operator Calls list for multi-operator entries; these will show up in the Log > Operators submenu 
where you can select one as the active operator during the contest. 

Click Done once you have completed this step. If you have selected Non-Assisted as the Assisted: 
category option, you should disable your DX Cluster connection. If the DX Cluster symbol ( ) 
below the contest name in the main logging window has a red cross through it, you are not 
connected. Clicking the symbol toggles your connection. 
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Customize the Log Table 
You can choose to reorder and hide or show many of the available log table columns. See Table 
Manipulation for how to do this. For example, you may only want to display the Operator column if 
the configuration is a multi-operator setup. Columns flagging multipliers relevant for the particular 
contest chosen are automatically displayed and can not be removed. In the CQWW example these 
are “C” for country multipliers and “Z” for zone multipliers.  

The “D” and “SQ” columns are alway visible. The “D” column of the log table identifies duplicate 
QSOs as defined in the rules for the particular contest. The “SQ” column identifies suspect QSOs. 
See Suspect QSOs for details. 

Open Additional Windows 
The final step is to open and lay out the SkookumLogger windows that you prefer as an operator. 
This can be largely a matter of personal preference, and will be highly dependent on the number, 
screen size, and resolution of any monitor(s) you use. For most contests you may want to show 
Activity windows, the Score and Rate Tracker windows. Some contests specify that the operator 
must take some time off during the event. The Time Tracker window tracks how much time has 
been used and how many off periods have been taken. 

In the case of the CQ WW DX contest, you might want to open the Countries and Zones 
Checksheets to keep track of worked and needed multipliers. Since CQ WW DX is a multi-band 
contest, you may also want to open the Pass Information window. This instantly tells you, for 
callsigns entered, the bands and modes where you need or have worked that entity. You can then 
decide whether to ask the station if they can be on another needed band too. The Pass Information 
window also offers an excellent way to see in a very screen-efficient window whether you’ve missed 
some easy multipliers on this or other bands. For those without room on a small screen to open the 
full multiplier checksheet, this can be very useful.  

Drag and resize the auxiliary windows to suit your layout. See Example Window Layouts for ideas. 

Now SkookumLogger is set up and customized for your contest.  

Setting Up a Contest From an Earlier Log 
You can create a new log from an existing log, to preserve the base log’s contest rules, sent 
exchange, message definitions, and Cabrillo settings: 

✦ Open the log file that will be the base for your new log. 

✦ Choose File > Save Log As… to create a copy of the log. The Log window title will change to 
the name you specify in the Save dialog. Do not use the same name as the base log unless you 
want to discard the base log. 

✦ Choose Log > Reset Log to remove the QSOs, set the serial number to 1, and change the start 
date to the next occurrence.  
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Other Setup Tasks 
Review Logging Settings  
Logging settings reference lists these options, their purposes, and their default values. You may 
want to turn on Remap ‘.’ key to ‘?’ key in Call field, Refuse to log incomplete QSOs, and Confirm 
Quit, and review the default choices in Fonts and Colors. 

For Phone contests you can now skip to Making contacts and start logging. Otherwise for contests 
involving CW, read on to the next section, or for a data mode contest (PSK/RTTY) check out the last 
section of this chapter. 

Setting Up Extra Items for a CW Contest 
If the contest involves CW, you will want to additionally configure SkookumLogger to use a CW 
keyer to send CW messages.  

Messages for a new log are initialized from the Messages tab of New Log settings. Use the Morse 
Messages Editor to customize those messages as needed, without affecting the defaults.  

Check that the correct Morse message is played when you press function keys. Note that the four 
buttons on top of your WinKeyer USB are also associated with messages 1 through 4. 

Setting Up Extra Items for a Data Mode Contest 
SkookumLogger supports some radios that have inbuilt encode/decode capability for RTTY / 
Frequency Shift Keying (FSK) or Phase Shift Keying (PSK). Use the Data Messages Editor to define 
what gets sent to the encoder, and the Text Decode/Encode window to send arbitrary text to the 
encoder and see text delivered by the decoder. 
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Making Contacts 
SkookumLogger is designed to make it simple and fast to enter contacts. Information is entered in 
the entry fields within one of the QSO Entry panes. See Log Window Components for a description 
of your primary contesting interface. For now, assume that all data entry takes place in the same 
QSO Entry pane. Use of both panes is covered later in Why there are two QSO entry panes. 

Accessibility Features 
SkookumLogger has three commands in the Log menu that augment standard macOS VoiceOver 
accessibility features for blind users: 

Log > Speak Status — Voices the QSO entry status text displayed above the active QSO entry field. 

Log > Speak Status Changes — Voices the status text whenever it changes. 

Log > Speak Next Serial — Voices the next transmit serial number. 

You can also configure SkookumLogger to make a beep when the status text changes to Duplicate, 
using a Logging setting. 

Entering Contacts for a SSB Contest 

For the purposes of an example, we will assume the contest is the ARRL DX SSB contest for 
entrants inside USA. SkookumLogger has configured four entry fields for this contest: received call, 
sent report, received report and received power, from left to right. The thick border around the call 
field indicates that the field will process keyboard input. 

To create a new QSO: 

✦ Enter a call in the left-most field. After you have typed more than three characters, 
SkookumLogger will display needed status (Multiplier in the example above), and will fill the 
pane to the left of the entry pane with calls that are partially matched to the entry call. 

✦ Tap the space bar to move the cursor to the power field, skipping over the report fields. If the 
power can be determined from the call prefix, SkookumLogger will fill the power in for you, 
indicate that the value is a guess by shading the zone field background, and select the value. 
Type over the guess if you need to change it; the shading will disappear.  

✦ Tap ⏎ to log the QSO. The log file is automatically saved. 

Tapping the tab key instead of space bar will cycle through all four fields in left to right sequence, 
while shift-tab will do the same but from right to left. Tabbing or shift-tabbing beyond the leftmost 
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or rightmost field will cycle back (wrap around) to the other end of the entry fields. In this way, you 
can easily edit any details before committing the contact to the log table.  

In HF contests, participants typically send 59(9) reports (as a cue for the other information) rather 
than genuine/variable reports. Using space bar to move between fields skipping the report fields is 
therefore useful. In higher band contests, reports are more variable as discussed in a later section. 

The prompt line in large text above the Run QSO Entry pane reminds you of your sent exchange. 
For contests where the exchange includes a serial number, the number to give the station you are 
working updates as you log QSOs.  

To clear all contact details input into the entry fields, choose Log > Clear Focused QSO Entry. The 
default shortcut for this menu is is F11. 

Editing a Logged QSO 
Should you wish to edit any details of a committed (logged) contact, double-click the cell to be 
changed in the Log table. If the cell content doesn’t then become selected, information for that 
table column cannot be changed. Tap ⏎ or double-click another cell to commit the change. These 
changes are automatically saved in the log file. Score changes as a result of the edit are 
automatically updated at that time unless the number of logged QSOs exceeds the Automatically 
rescore logs smaller than value in Logging settings. 

You can also edit the last QSO that you logged as follows: 

✦ Enter the values to be updated into their entry fields. 

✦ Choose Log > Correct Last QSO. 

These steps will copy the non-empty entry fields to corresponding fields in the logged QSO. This 
feature is particularly helpful when one field has a typo 

Choose Log > Append to Last QSO Notes to quickly add information to that field. 

Deleting a Logged QSO 
Choose Log > Delete Last QSO to erase the most-recently added entry in the Log table. Or, select 
one or more rows in the Log table and choose Log > Delete Selected QSOs. In general it is better 
not to delete any contacts actually made, even if incomplete and non-scoring. This helps the 
adjudication process. This also applies to duplicates, which should never be deleted. You cannot 
be sure what the other station logged on each occasion and so leaving them in ensures the best 
chance of claiming at least one good contact. You are not penalized for duplicates in your score in 
any contest. It is safe to delete the last QSO in serial number contests, but otherwise deletion will 
cause gaps in the sent serial sequence that may upset some adjudicators. 

Entering Contacts in a CW Contest When Using Messages 
Let’s suppose you are running a frequency in a CW contest. You will typically follow these steps: 
(Note: These steps assume the default shortcut key assignments for clarity of what keys to press). 

✦ Tap F1 to transmit your CQ message. 
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✦ When someone answers, type their call in the call field and tap F5 (His Call) followed by F2 
(Exchange) to transmit his call and your exchange. You can tap F5 before you have finished 
entering the complete call as long as your typing stays at least one character ahead of what is 
being sent; this is called type-ahead. 
Hint: Messages > His Call + Exchange combines these two key presses. 

✦ If they respond with their exchange, navigate to the entry fields as described for SSB logging 
and fill in the information. 

✦ If they instead ask you to repeat your exchange, tap F2. 
Hint: In serial number contests, tap ⌘F2 to transmit just your serial number. 

✦ When you have their exchange, tap F3 (Acknowledge) and ⏎ to transmit your 
acknowledgement and log the QSO. 
Hint: Messages > Acknowledge + Log QSO combines these two key presses. 

Now let’s suppose you are searching and pouncing. Typically you will then follow these steps: 

✦ Type a call into the call entry field to determine needed status. 

✦ Tap F4 (My Call) to respond to his CQ. Repeat as needed until he responds to you with his 
exchange. If he is clearly responding to you but has your call wrong, tap F4 until he gets it right. 

✦ Fill in the remaining entry fields. If you need a repeat, tap F7 (?). 

✦ When you have his complete exchange, tap F2 to transmit your exchange. Repeat as needed 
until he acknowledges your exchange. 

✦ Tap ⏎ to log the QSO. 

These sequences for running and for searching and pouncing may seem complex, but actually you 
soon get used to the routine and are able to concentrate more on receiving incoming CW. 

If at any time you need to stop a CW message being transmitted, either tap the escape key (the 
shortcut for Messages > Abort) or touch a paddle connected to your WinKeyer unit.  

If you need to transmit any un-programmed CW information you can use a connected paddle key 
to do this. Alternatively you can use Morse > Keyboard Mode (⌘K) and type what you want sent. 
Use the same command again to exit Keyboard Mode.  

Entering Contacts in a Data Contest 
SkookumLogger supports a number of data contests for logging only. These include RTTY (FSK), 
Phase Shift Keying (PSK) and Machine Generated Modes (MGM) as defined by RSGB. However, full 
support (processing the data signals in addition to logging QSOs) requires a radio which can 
generate and decode the data signals internally, and is limited to the data modes that the radio 
can support. If you are using some other external means to generate and decode data modes and 
SkookumLogger just for logging, use the Phantom radio type to to set frequency and mode 
manually. For modes other than FSK and PSK, choose Data as the mode.  
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For radios that support FSK or PSK encoding/decoding internally, SkookumLogger offers specific 
features. One is the ability to send messages as with CW and SSB, but using separate set of 
messages. The QSO process is very similar to that described in the previous section. 

In addition you will want to open the Text Decode/Encode window. This shows decoded text from 
the radio in the normal text color, and transmitted text in red. You can use the Grab command to 
copy any received selected text into the QSO entry field with keyboard focus. You can also use the 
lower text entry field to send arbitrary text.  

Some mixed mode contests accept QSOs using data modes that require WSJT-X software to 
complete them (e.g. FT8). After the contest, use WSJT-X to generate an ADIF file from its log, then 
merge that file into your log.  

Entering Contacts in a VHF/UHF Contest 
The steps when entering contacts in a contest on the higher bands (VHF/UHF) are very similar to 
those already described, although some features of SkookumLogger allow additional techniques 
to be employed.  

When a station calls you on a run 
frequency, it may be advantageous to 
check the bearing information and tweak 
the antenna rotor to peak up the signal 
before completing the contact. 
SkookumLogger uses coordinates in the Countries database to compute bearing for a call. This 
bearing can be inaccurate for calls in a geographically large or close-in country, so 
SkookumLogger will provide a more accurate bearing when possible, using information from a 
previous QSO in your log or in your Exchange database. This case is indicated by a hollow target 
point. 

Also it is customary to send and receive genuine RS(T) reports on the higher band contests and so 
it may be better to tab between the fields to include the report entry fields rather than using the 
Spacebar which skips straight to the other fields.  

Note: When you Tab into a Report field, the second digit (signal strength) is highlighted by default 
so that the S (strength) component may be simply overtyped if that is the only (often) edit required. 
Should you need to replace the entire report with a new one, ⌘A will select the whole content of 
(any) current field for this purpose.  

Entering QTCs in WAEDC Events 
The Worked All Europe DX Contest (WAEDC) events include the feature that non-European 
participants can, in addition to making a normal QSO, send reports of QSOs already made (QTCs) 
to European participants, which offers the chance for both sides to achieve additional points. See 
QTCs for instructions on how to do this. 
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After the Contest is Over 
This chapter deals with the processes that you might typically follow once the contest is finished, 
including sanity checking your log for obvious errors flagged during the contest, generating your 
entry file, and the methods of submitting it. Note that most contest rules preclude adding 
additional logged info for contacts after the contest, whereas a reasonable correction at the end 
might be realizing that you mistakenly typed a letter O for a zero, for example.  

Before you submit your log, it is recommended that you choose Log > Rescore Log, then sort the 
log on the SQ (suspect) column and deal with any QSOs that were flagged as suspect during the 
contest. Then re-sort by Date/Time column before proceeding with log submission.  

You may also want to check the selections made for your contest entry in Log > Cabrillo Settings… 
to confirm your entry sections and perhaps add some comments in the Cabrillo Soapbox field, 
about how you found the conditions, your experiences, etc. 

In Analysis and Log Aggregation, we will cover other things you may want to do after the contest, 
including analysis of your performance and how to aggregate individual SkookumLogger contest 
logs into a single general logging program such as MacLoggerDX, RUMLogNG or Aether, for 
reference (e.g. QSL and statistical tracking for example). 
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Submitting Your Contest Log 
Once you have finished operating in the contest, you are 
ready to create the file you will send to the contest 
adjudicators. This uses a standard Cabrillo format. Some 
adjudicators provide a website to upload your entry and 
some provide an email address to send it to as an 
attachment.  

Selecting File > Submit Log Via Web Browser… will generate the Cabrillo format entry file and then 
open your browser to the correct page to upload it. Complete the process on the website and 
you’re done!  

Selecting File > Submit Log Via Apple Mail… will generate the Cabrillo format entry file and then 
create a new mail message with the address of the adjudicators pre-filled and the entry file 
included in the message as an attachment. Start Mail first, generate the file, send the constructed 
email and you’re done! 

Alternatively, selecting File > Export Cabrillo… will simply create the file. A standard macOS File 
Save dialog will appear and you should choose the name and location that you wish to save the 
Cabrillo file.  

After the file is written, you can open it with a text editor such as macOS’s TextEdit program to 
check that all the header declarations are as you would want them (these will have been generated 
from your SkookumLogger settings information and the options selected in the Cabrillo settings 
for this contest). Also perform a quick check that the total number of contacts in the Cabrillo file is 
as you would expect from what you worked in the contest.  

If all seems well, you can submit this file to the contest sponsors/adjudicators by visiting the 
relevant website or creating an email as appropriate. If you are unsure, check the rules website for 
the contest using Help > WA7BNM Resources > Contest Rules for Current Log. 

Posting to 3830 
Long ago, it was customary for contesters to meet with other contester after a contest on 3830 kHz. 
to exchanges raw scores and experiences. That same exchange now happens via the internet. To 
participate: 

✦ Choose Help > WA7BNM Resources > 3830 Scores Web Site. 

✦ Click on the contest name in the Submittal Forms sidebar. 

✦ Fill in the form: 

❖ Use the SkookumLogger Score window for the Summary section. 

❖ Optionally copy the Soapbox from Log > Cabrillo Settings… to the Comments section. 
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Creating a New Log 
When you choose File > New Log…, SkookumLogger presents the New Contest Log window. 
Select the name of the contest for your new log, then click Done. SkookumLogger will present a 
standard file save dialog. You can save the log document anywhere you like with any name you 
like.  

The new log will have start date set for the next occurrence of the contest, and Cabrillo, sent 
exchange and CW messages set from your settings. In Log > Cabrillo Settings…, Cabrillo Category, 
the Mode item will be set to one of CW, SSB, FSK, PSK, Data, or FM for single-band contests, and to 
Mixed for multi-mode contests. The Band item will set to All for multi-band contests, and to the 
appropriate band for single-band contests.  

Note: The “next occurrence” is the first contest start date after the date that you created the log. 
That date may not be what you expect when you create a log in the middle of a contest. Don’t do 
that, or use Time Tracker to edit the start date. 

You can review and edit these settings for your new log in Time Tracker, Sent Exchange Editor, 
Morse Messages Editor, and the Cabrillo settings sheet, respectively. Changes that you make in 
these editors affect only the log document, not the default settings values. 

Important: After setting up a new log, always check that the sent exchange prompt (shown in large 
bold text in the Log window) is what you expect. Use the Sent Exchange Editor to make corrections 
as necessary. You must make these corrections before logging any QSOs. 

You can create a new log from an existing log, to preserve that log’s contest rules, sent Exchange, 
message definitions, and Cabrillo settings: 

✦ Open the log that will be the basis for your new log 

✦ Choose File > Save Log As… to create a copy of the log 

✦ Choose Log > Reset Log to remove the QSOs, set the serial number to 1, and change the start 
date to the next occurrence. 
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Log Window 
The main window in SkookumLogger is known as the Log window, and is the most import user 
interface in the app.  

Log Window Components 

The title bar shows the user-defined file name. The window Close button is disabled because 
SkookumLogger always shows one and only one Log window. Use File menu items to create a new 
log or open an existing log; either approach closes the the existing Log window and opens a new 
Log window. 

1. The contest name, which defines the log’s rules.  

2. Search the log table, see Using Search. 

3. Settings panel buttons for Logging, Messages, OpMode. 

4. Current UTC time. 

5. Sent exchange prompt showing your contest call and exchange. 

6. Beacon CQ status. 

7. Partials panes. 
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8. State gumdrop indicators, , see QSO Entry pane icons. 

9. See Radio Information. 

10.Call entry field status, see QSO Status Information. 

11.QSO entry fields. 

12.QSO Information. 

13.QSO Entry panes. 

14.Log Table. 

15.Status indicators for DX Cluster, SkookumNet, Radio 1, and for Radio 2 in 2T2R operating mode. 
Red indicates not available, Green indicates available. The indicators are buttons that toggle 
status. Command-clicking an indicator open the relevant window instead of changing status. 
The bullseye appears when audio recoding is enabled, and pulses when recorders are running.  

QSO Entry Pane Icons 

Each QSO Entry pane has icons that appear, or not, depending on context. These icons are located 
in the top row of the pane beginning at the top left corner. This image shows an artificial condition 
where all of them are visible: 

Here is what they mean: 

✦ The keyboard icon behind the gumdrops is visible when Keyboard Mode is on. 

✦ The red gumdrop means the QSO Entry pane has transmit focus. It always appears in one pane 
and not the other pane. The tiny white gumdrop centered on the red gumdrop appears in the 
2T2R mode when Alternating CQ is on. 

✦ The green gumdrop appears in the 2T2R mode to indicate whether or not you are listening to 
the pane’s radio. The tiny white gumdrop centered on the green gumdrop appears when 2BSIQ 
is on. 

✦ The yellow gumdrop appears in the 2T2R mode when the pane is in pounce mode. 

✦ The up/down arrows after the receive frequency display appear when the frequency has been 
modified to be above or below a central frequency by the Log > Bump Run Frequency 
command. 

Suspect QSOs 
The Suspect QSO log table column, labeled SQ, is displayed for all contests, to flag contacts that 
SkookumLogger cannot match with the rules of the contest such as time outside the contest period 
or missing elements in the received exchange. Select one or more suspect QSOs in the log table, 
then choose Log > Explain Selected Suspect QSOs to open a window explaining why the QSOs 
are marked as suspect. If you correct a suspect issue, the suspect status will be edited the next time 
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the Rescore Log function runs. Suspect QSOs are ignored when computing your score and various 
other statistics. Type “X-QSO” in the Notes field to force on the SQ flag.  

Use the Mark suspect QSOs as X-QSO in the Cabrillo pane of New Log settings to instruct score 
checkers to exclude your suspects when analyzing your log. You should use this feature instead of 
deleting suspect QSOs because score checkers may penalize the station you worked. 

Radio Information 
SkookumLogger converts VFO and RIT/XIT offset frequency information from the radio into main 
receive frequency, transmit frequency, and, if the radio has a subreceiver, subreceiver frequency. 
The subreceiver frequency is not displayed, but is used in the 1T2R operating mode and can be set 
by the user. 

The first line in each QSO entry pane shows mode, main receive frequency, and transmit frequency 
offset. The mode is NA represents an unrecognized mode. The offset is positive when the transmit 
frequency is above the receive frequency. 

When you have an active radio connection, SkookumLogger gets that information from the radio. 
When you don‘t have a radio connection, you can set the information for the Phantom radio type 
manually using text commands. 

When you choose Radio > Bump Run Frequency, arrows appear after the radio frequency 
indicating the direction of the bump. 

When sending messages, the color of the radio mode text changes indicating the status of the 
message queue. 

QSO Status Information 
The line above the QSO entry fields in each QSO entry pane displays what SkookumLogger will 
interpret what you have typed into the call field. When the call field content looks like a call, the 
color of the status line is determined by the needed status for the call and the status line shows the 
needed status in text. When the content looks like a text command, the status line shows the name 
of the command. This text is selectable so that you can define it as a Voice Over hotspot.  

QSO Information 
The line below the entry fields in each QSO entry pane displays everything SkookumLogger knows 
about the call in the call field. The bits of information are separated by spaces. The information line 
has a help tag for each bit of information. 

✦ Name if available. See Name prompts. 

✦ Entity information: prefix, continent, CQ Zone and ITU zone, from the Countries database. 

✦ Location information: short-path bearing and distance, Maidenhead grid. The location is 
determined as follows: 

❖ If the QSO has a received grid field and the content is valid, use that. 

❖ If your Exchange database has a grid entry for the call of the QSO, use that. 
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❖ If your Exchange database has a US State entry for the call of the QSO, use the grid for the 
state. 

❖ If the contest rules for the log have Region information for the QSO, use the grid for the 
region. 

❖ If the Countries database has an entry for the call of the QSO, use the grid for the latitude 
and longitude of that entry. 

✦ QSO points 

✦ Country names and administrative districts, from the Countries file. 

Log Table 
The log table shows a row for each completed QSO. You can customize which columns are visible 
in the log table by right-clicking on the table heading row or using the Log > Table Columns menu; 
you can sort and resize columns. 

The Band data is determined from Tx Freq and is not editable. 

The D column identifies duplicates. 

The Ro column identifies Rovers. 

The SQ column identifies suspects. 

The C, G, O, P, R, Z columns identify Country, Grid, Other, Prefix, Region, and Zone multipliers, 
respectively. 

Editing Log Table Entries 
All table columns are normally editable except Band, Tx Exchange, and the flag columns like D. 
Editing is disabled when Keyboard Mode is active. 

To edit a QSO, first select a row in the log table. You can do that by clicking on a row in the table, or 
by choosing Log > Focus Log Table. Use the up and down arrow keys to change the selected row. 
When a row is highlighted, click on the cell to be edited, or use tab and shift-tab to select an 
editable cell. Then type in your change. 

Columns that have popup menus are skipped over by tab key navigation and you will need to use 
the mouse to change their values.  

Changing the Operator popup selection also selects that operator in the Log > Operator > 
submenu.  

Use Log > Focus Recent QSO Entry to return to the most recently active QSO entry field when you 
have completed edits. 

Use Log > Append to Last QSO Notes transfers keyboard focus to the Notes cell in the log table 
row for the last QSO and positions the insertion point after existing content. When you finish 
editing (tab or return), focus is transferred back to the most recently focused QSO Entry field. 
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The Log > Correct Last QSO command copies the content of each non-empty entry field in the 
QSO entry pane to the most recent QSO. You can define a special key shortcut for this command in 
the Correct Last QSO special key option in Logging settings. 

Changes to logged QSOs can affect duplicate detection, scoring, and other information. The 
Automatically rescore logs smaller than option in Logging settings sets a threshold to prevents 
time-consuming rescoring for larger logs. For large logs, use Log > Rescore Log and Activity > 
Update Needed Flags during a slow period or off time. 

The Notes column may contain information derived from the QSO. This information is surrounded 
by « and » and is updated when the log is rescored. You may add and edit any text after the » 
character; that text will be preserved during rescoring. One type of derived note is distance 
between you and the worked station in km, available for most contests where the exchange is 
grids. The other type is multiplier information from the Countries database or the appropriate 
Multiplier database, available for most contests when the contest exchange is not grids. 

Searching in the Log Table 
You can find QSOs in the log that contain a string that you type into the search field. To begin the 
search, click the search field or choose Log > Focus Log Search Field. Click the magnifying glass to 
change the name of the log column to match against, then begin typing. The log table changes as 
you type to show QSOs that contain the typed characters. If the call entry field is not empty when 
you choose Log > Focus Log Search Field and the search field is set to match Call, the log is 
immediately searched for QSOs with the call. 

The “m of n” label to the left of the search field indicates how many rows are selected (m) and how 
many are displayed (n) as the result of a search.  

Press escape to end the search.  

If the Automatically search option is enabled in Logging settings, then typing into a call field 
searches the log to show only QSOs with calls that contain what you have typed when you type the 
third character. This can be useful in QSO Parties when you want to quickly review QSOs for a 
particular rover. 

QSO Data Entry 
The QSO Entry pane text fields contain received exchange information for pending QSOs. The row 
of text entry fields has items for the received call and other exchange entry fields. The number and 
type of the exchange fields depend on the contest name. The fields are ordered left-to right in the 
same orders and they are transmitted. Each of the entry fields has a help tag that identifies what is 
expected as content. The two QSO Entry panes are identical and create the same information in 
your log, with the exception that SkookumLogger keeps track of which pane created each QSO. 
The only place where this flag is used is the statistics report. 

You can use the mouse to change keyboard focus to any of the QSO entry fields, or use the 
keyboard to move focus left and right. The tab key moves keyboard focus to the next field on the 
right, or to the first field when the last field has focus. Shift-tab moves keyboard focus in the other 
direction. Tapping the spacebar acts like the tab key, except that it skips over signal report entry 
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fields. The Notes entry field accepts anything you can type, including spaces, so you need to use 
the tab key or the mouse to navigate out of that field. Log > Focus Call Field jumps keyboard focus 
to the call field for the active QSO entry pane. 

Note: Entry field navigation in the ARRL Sweepstakes contest is slightly different from other 
contests. Initially the call field is focused. The spacebar then jumps focus to the first field (number), 
and thereafter spacebar behaves normally until the navigation logic is reset by logging a QSO or 
clearing the entry pane. 

Standard macOS behavior when a non-empty text entry field becomes focused is to select all of 
the existing text. SkookumLogger overrides this behavior for the call field and for report fields: 

✦ When the call field becomes focused and the content contains a question mark, then the 
question mark is selected. Otherwise the content is deselected and the cursor is positioned at 
the location it had when the call field lost focus. 

✦ When a report field becomes focused and the content has at least two characters, the second 
character (the ‘S’ digit) is selected. 

In addition, the Position cursor at end of entry field option in Logging settings changes the 
standard behavior for all other entry fields. 

The arrow keys are helpful when editing content in a focused text entry field: 

✦ All arrow keys first deselect the content. 

✦ Control-Left moves the insertion point to the beginning of the content. 

✦ Control-Right moves the insertion point to the end of the content. 

✦ Left move the insertion point over the previous character, or to the beginning of the content if it 
was selected. 

✦ Right moves the insertion point over the next character, or to the end of the contest if it was 
selected. 

There are many other macOS text editing keyboard shortcuts that involve modifier keys. In 
addition, macOS text fields also supports many emacs keyboard commands.  

When using the Call Stacking feature, separate calls with a comma. With straddlers, separate calls 
with a forward slash. You can also set radio bands, modes and frequencies, and rotator bearing, 
using text commands. 

When keyboard focus leaves the call field, SkookumLogger searches your log and your Exchange 
database for previous QSOs with that call and uses the results to pre-fill other QSO entry fields. 
When a field content is set this way, the background color for the field is changed to the Entry field 
background highlight color defined in Logging settings.  

When a QSO entry field expects codes like states, counties, oblasts, etc., Edit > Complete shows a 
list of the expected codes. If you type something first, the list will be restricted to codes that begin 
with what you have typed. Use the up and down arrow keys to select a list entry, then press return 
to choose the selected entry. 
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The QSO entry fields have formatters that affect what happens as you type. The behavior of a 
formatter depends on what kind of information SkookumLogger expects for the field. All formatters 
define a list of acceptable characters and silently ignore all other characters. For example, a serial 
number field accepts only digits and a few cut number characters. 

Press the return key to log a QSO with the data in the entry pane with keyboard focus, and clear the 
the entry fields. SkookumLogger will not stop you from logging incomplete QSOs unless you 
enable the Refuse to log incomplete QSOs option in Logging settings. The log document is 
automatically saved after adding a QSO.  

Exchange Pre-fill 
When you enter a call and navigate to the next QSO entry field (tap spacebar or tab), 
SkookumLogger may fill in the content of some non-empty exchange fields. An exchange value 
entered this way is identified by changing the entry field background color. If you edit the 
exchange value, the background color is changed back to the default color. If you edit the call and 
trigger another pre-fill, only those fields with highlighted backgrounds will be changed. 

There are several sources of exchange pre-fill information, including QSOs in your current log, 
entries in your Exchange database, and the Countries file.  

You should always listen to the exchange to confirm that the guessed pre-fill value matches what 
was sent to you. Always log what was sent, with the exception of zones — when you are certain the 
sent zone is incorrect, log the pre-filled value. For example, sometimes casual contesters send CQ 
zone or a serial number when ITU zone is required. 

IARU Society Code Pre-fill 

When a call ends in “HQ”, SkookumLogger looks up the country for the call in the Countries 
database, then looks for the society code for that country in a table of societies constructed from 
data published on the IARU web site. It is possible that the country for call ending in HQ doesn’t 
map to a society code; OHØHQ for example. Log what you hear. 

That table is also used when populating the Other Multipliers checksheet, to identify suspect 
received exchanges, and to supply the completion list (option-esc) in the received exchange field. 
Official society codes are not unique; SkookumLogger disambiguates internally by appending the 
country code to ambiguous society codes like CARS. Log the code as sent; the checksheet will 
show the disambiguated code, CARS-ZF or CARS-5B for example. 

Not all society station calls end in “HQ”, and some don’t send the official society code for their 
country. Log what you hear. 

Rovers and Straddlers 
Rovers are mobile contesters who operate from more than one location during a contest. In some 
contests, working a rover using the same call from different locations is a valid QSO rather than a 
duplicate. 
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Identifying Rovers 

When the rules for a contest allow rovers, the Log table has a column titled Ro, with cells 
containing a checkbox. A new logged QSO with a known rover is automatically marked as a rover. 

SkookumLogger automatically checks for new rovers when logging a QSO, by comparing the 
location for the new QSO with the locations for previous QSOs with the same call. If a different 
location is found, the call is marked as a rover. You can manually identify a call as a rover by 
checking the pane for any QSO with that call; SkookumLogger will then check the boxes for all the 
other QSOs with that call. You should do this when you first work a call known to be a rover, due to 
the special treatment described below. 

When a contest has rovers, SkookumLogger cannot determine the needed status until the location 
(Info) field is filled. When the location field is empty, the status is indicated by adorning the call with 
the “May be multiplier” color and font. When the location field is pre-filled by guessing the location 
from a previous QSO, the call might be incorrectly marked as a duplicate. To prevent this case, pre-
fill for a known rover is disabled.  

To quickly see all logged locations for a rover, enable the Automatically Search option in Logging 
settings. 

Being a Rover 

Use the Sent Exchange Editor to change your location before logging QSOs from a new location. 

Country-line QSOs (Straddlers) 

Some QSO Parties allow rovers to sit near (straddle) county lines and provide credit for the 
counties on each border. This is indicated by sending the multiple locations separated by forward 
slashes. If your are straddling yourself, separate the locations in the Sent Exchange Editor. When 
you log a straddler QSO, SkookumLogger will manufacture separate QSOs for each combination 
of sent and received locations. QSOs with straddlers will be marked as rovers by the identification 
logic above. 

You can use Log > Correct Last QSO to update the call and received locations for the most recent 
set of manufactured QSOs. To update received locations, you must enter the complete 
specification — each location separated by slashes — in the QSO Info entry pane. 
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Partial Call Matching 
When you type into a call entry field, SkookumLogger looks in internal sets for known calls similar 
to the partial call you have typed, and lists up to eight known calls in the Partials pane to the left of 
the QSO Entry Pane. Each of the listed calls is adorned with font and color indicating its needed 
status. 

The internal sets are the Super Check Partial (SCP) database, your Exchange database, and a “good 
calls” set containing logged calls and your activity announcements. The source set for a known call 
is identified by characters surrounding the call: 

✦ ( and ) for calls in the good calls set  

✦ [ and ] for calls in your Exchange database  

✦ Otherwise no adornment for calls in SCP  

When there is a known call that exactly matches the partial call, the background color of the Call 
entry field is set to the Entry field background highlight color in Logging settings. In the example, 
the call is exactly matched, all of the calls are already logged because SCP is disabled in the WRTC 
contest, and the red calls aren’t needed because that have been worked on 20m. 

SkookumLogger begins looking for similar known calls when you have typed at least 3 characters. 
You can type a question mark when you know there is a character at that location in the partial call 
but you have no idea what the character is. 

Use the list of calls in the Partials pane to judge whether or not what you have typed is a good call, 
and to guess what characters you might be missing. But do not rely on the list, always enter what 
you hear. 

SkookumLogger has two approaches for judging similarity between a partial call and a known call.  
Contains similarity is the default.  Fuzzy similarity is enabled instead with the Use fuzzy similarity 
 option in Logging settings. 

Contains Similarity 
When there are no question marks in the partial call, known calls that contain any characters before 
and after the partial call that you have typed are considered similar. 
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If the partial call contains one or more question marks, Contains similarity finds known calls that 
match the other characters in the partial call along with any letter or number substituted for 
question marks. 

Fuzzy Similarity 

Fuzzy similarity applies a variation of the Levenshtein Distance algorithm, created by JH5GHM, to 
consider the likelihoods of changes to the partial call needed to convert it into a known call. For 
CW mode, the consideration includes similarity of morse code characters. The list of known calls 
has the most likely match at the bottom right (closest to the call entry field) and proceeds upward 
with less likely matches. The known calls are grouped by the similarity value determined by the 
algorithm. Calls with the same similarity value are then grouped by their source and sorted 
alphabetically within those sub-groups.  

Underlines in a known call identify characters that are present in the partial call. Use Underline 
unmatched characters to instead underline characters that are not present in the partial call. The 
color for the underline is set to Partial match underline color in Logging settings. In the example, 
Use fuzzy similarity and Underline unmatched characters are on, and Partial match underline color 
is red. 

Using Partial Call Matching 

When you hear only part of a call, a glance at the Partials pane will often provide a good idea of the 
correct call. Additionally, if you have typed a complete call and it is not matched, you might suspect 
that you misheard the call.  

Hint: When CQing on CW, if you have a partial call and need the caller to send his call again, use 
the His Call message instead of Again to stimulate just that caller to repeat; too often Again will 
cause everyone in your pileup to begin transmitting. 
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Why There Are Two QSO Entry Panes 
A basic QSO has a timestamp (date and time together), a frequency, a radio mode, a sent 
exchange, and a received exchange. SkookumLogger fills in the first four of these items when you 
log a QSO, by copying them from the candidate QSO in the active QSO Entry pane. You provide 
the components of the received exchange by typing into the text entry fields inside the QSO Entry 
pane. The components of the exchange are specified by the contest rules. SkookumLogger sets up 
the entry fields according to those rules. 

The most straightforward way to work with the QSO Entry panes is pick one and enter all of your 
QSOs there. However, with two panes you can work with two candidate QSOs at the same time. 
This provides interesting and useful possibilities: 

✦ While the sequences described in Basic Operating for completing QSOs apply to both QSO 
Entry panes, if you log run QSOs in the Run pane and pounce QSOs in the Pounce pane, 
SkookumLogger can use knowledge of which pane is active to choose for you the messages to 
transmit when using Magic Message or Begin QSO/End QSO. 

✦ The candidate QSOs are independent, so you can use one of the QSO Entry panes to “store” 
information.  

✦ The items in an Activity table are a set of possible candidate QSOs. You can transfer candidate 
QSOs back and forth between an Activity table and the Pounce QSO Entry pane, for even more 
information storage and use. 

✦ The transfer from Pounce to Activity table can be automated to happen when you change the 
radio frequency and the call field in the Pounce QSO Entry pane isn’t empty. 

✦ The transfer from Activity to Pounce can be automated to happen when the radio frequency is 
near a table entry. 

✦ You can type information into one QSO Entry Pane while transmitting the candidate QSO 
information in the other pane. 

By the way, logged QSOs know which QSO Entry pane created them, enabling a variety of silly 
statistics reports for post-contest amusement. 

Keyboard Focus and Transmit Focus 
Fully leveraging SkookumLogger logging feature requires understanding two important concepts: 
keyboard focus and transmit focus. Keyboard focus determines which QSO Entry pane accepts 
what you type. Only one text field at a time within an application can have keyboard focus. A 
focused text field has a thick border called a focus ring. Log > Focus Recent QSO Entry changes 
keyboard focus from anywhere within SkookumLogger to the most recently focused text entry field. 
Other commands in the Log menu toggle keyboard focus between the QSO Entry panes and 
assign keyboard focus to a particular pane, always returning focus to the most recently use text 
field within the pane. 
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Transmit focus determines which candidate QSO is used when transmitting messages. Again, there 
are commands for toggling and assigning transmit focus for QSO Entry panes. The pane with 
transmit focus has a red gumdrop at the top left corner. 
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Operating Modes 
SkookumLogger supports three operating modes: 

✦ One Transmitter One Receiver (1T1R) — A transceiver with no subreceiver or with subreceiver 
dedicated to diversity reception. 

✦ One Transmitter Two Receivers (1T2R) — A transceiver with a subreceiver, also known as Single 
Operator 2 VFOs (SO2V). 

✦ Two Transmitters Two Receivers (2T2R) — Two transceivers, also known as Single Operator 2 
Radios (SO2R). 

You choose which operating mode is active in OpMode settings. 

1T1R and 1T2R Behavior 
In the single radio modes, the QSO Entry panes are labeled Run and Pounce, SkookumLogger 
interacts with Radio 1, and Radio 1 should be connected to the Morse Keyer KEY 1 output. The 
QSO entry pane that has transmit focus tracks radio frequency and radio mode and so determines 
where you are transmitting. When you change transmit focus from one entry pane to the other, the 
radio is changed to the frequency and mode of the newly-focused QSO pane.  

Use Log > Toggle QSO Entry Focus, Log > Focus Run QSO Entry or Log > Focus Pounce QSO 
Entry to choose which of the Run and Pounce entry boxes reacts to keyboard input. The pane with 
keyboard focus has an entry field with a thicker border called the focus ring.  

Use Log > Toggle Transmit Focus, Log > Toggle Transmit Run, or Log > Toggle Transmit Pounce to 
choose which of the entry boxes tracks changes in radio frequency and mode. The pane with 
transmit focus is identified by a red gumdrop at the top right corner. If you change transmit focus 
change while a message is playing, the message is aborted. 

If you prefer to always have keyboard and transmit focus on the same pane, choose the Transmit 
focus follows keyboard focus option in OpMode settings. When you do this, you give up the ability 
to enter QSO information in one pane while sending a message using the frequency and mode of 
the other pane. 

Some messages depend on which of Run or Pounce has transmit focus. Grabbing activities 
transfers information to the Pounce entry pane. 

K4 RIT/XIT Management 

The K4 TCP module in SkookumLogger automatically manages the on-off state for K4 VFO A RIT 
and XIT as follows: 

✦ When Run has transmit focus, turn on RIT and turn off XIT. 

✦ When Pounce has transmit focus, turn off RIT and turn on XIT. 

With that logic, you can use the OFS knob or a K•Pod to tune around near your transmit frequency 
when running, and adjust your transmit frequency without changing receive frequency when doing 
S&P. The K4 limits the offset to less than +/- 10 kHz. 
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The K4 panadapter shows the VFO A receive frequency with a blue cursor, and the transmit 
frequency with a red cursor when transmit frequency is different from receive frequency. Both 
cursors displays correctly account for RIT/XIT state and offset value. 

1T2R Behavior 
This operating mode has independent settings from the 1T1R operating mode but otherwise has 
all the features described above. In addition, when Run has transmit focus then Pounce tracks the 
subreceiver frequency, and when Pounce has transmit focus then the subreceiver listens to the Run 
frequency. Also, the Pounce receive frequency change … options in Activities settings apply when 
Run has transmit focus. 

For this mode, unlock transmit focus from keyboard focus using the 1T2R Transmit focus follows 
keyboard focus option so that you can type into the Pounce QSO Entry pane at the same time as 
transmitting in the Run QSO Entry pane. 

With two receivers, SkookumLogger automatically sets the subreceiver to listen to the receive 
frequency for the QSO Entry pane without transmit focus. So, your second receiver will hear your 
run frequency when Pounce has transmit focus (to alert you when somebody transmits there), and 
your pounce frequency when Run has transmit focus (to know when to pounce). Also, when Run 
has transmit focus the Pounce QSO Entry pane tracks the subreceiver frequency, (to find new 
pounce candidates). Of course, the main receiver listens to the frequency of the QSO Entry pane 
that has transmit focus. 

Listening to two receivers involves stereo audio, which can sometimes limit how well you can hear 
the station you are trying work. Use Radio 1 > Toggle SubRX to turn the second receiver on and off, 
which also toggles stereo audio on and off. 

Instead of tuning the radio’s second receiver frequency, you can use Activity > Set SubRX to jump 
the second receiver directly to an activity frequency. 

1T2R Scenarios 

A typical scenario when using DX Cluster to populate activity tables is: 

✦ Enable the Fills QSO entry from nearby activity option 

✦ CQ with keyboard focus and transmit focus in the Run pane 

✦ Tune the subreceiver, stopping when a needed QSO is automatically entered in the Pounce 
pane 

✦ Listen to the needed QSO when not CQing to determine when to call 

✦ Toggle keyboard focus and transmit focus to Pounce to work the needed QSO while monitoring 
your run frequency 

A typical scenario when not using DX Cluster might be: 

✦ Enable the Creates activity from QSO entry and clears entry option 

✦ CQ with keyboard focus and transmit focus in the Run pane 
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✦ Tune the subreceiver, stopping when you hear a possibly-needed call 

✦ Change keyboard focus to Pounce and type the call 

✦ Tune the subreceiver away to to add the call to the activity table and clear the Pounce entry 
pane; grab from the table to work later 

✦ Or, change transmit focus to Pounce to work the call 

2T2R Behavior 
In the 2T2R mode, the entry panes are labeled Radio 1 and Radio 2. This operating mode uses 
both Radio 1 and Radio 2. You must connect KEY 1 and KEY2 of your keyer to the corresponding 
radios. SkookumLogger does not manage sub-receivers in this mode. The Radio 2 and 2T2R 
menus are added to the menu bar and the R2 status icon is added to the bottom bar of the Log 
window. 

The Log window has additional gumdrops for this operating mode. 

Command names for managing keyboard focus and transmit focus are changed. Use Log > Toggle 
QSO Entry Focus, Log > Focus Radio 1 QSO Entry, or Log > Focus Radio 2 QSO Entry to change 
keyboard focus. Use Log > Toggle Transmit Focus, Log > Transmit on Radio 1, or Log > Transmit on 
Radio 2 to change transmit focus. If you change transmit focus while a message is playing, the 
message is aborted. 

When transmit focus and keyboard focus are different, SkookumLogger automatically changes 
transmit focus to the entry pane with keyboard focus when you start a message, and when you 
enter Keyboard Mode. 

2T2R has run and pounce submodes for each radio. Pounce mode for a radio is identified by a 
yellow gumdrop in the radio’s QSO entry pane. 

You can copy QSO information from an Activity window into either QSO entry pane. Activity > 
Grab to Radio 1 (click) copies to the Radio 1 pane; Activity > Grab to Radio 2 (shift-click) copies to 
the Radio 2 pane. The frequency and mode for the corresponding radio are changed, and 
keyboard focus is not changed. 

2T2R > Swap Radios interchanges radio frequencies and modes, run/pounce submodes, audio 
routings and keyer speeds between Radio 1 and Radio 2. 

2T2R > Bump Transmit Frequency cycles the current transmit radio frequency +100, –200, 0 Hz to 
get re-spotted by skimmers. 

See 2T2R Scenarios for descriptions of these remaining 2T2R menu items: 

2T2R > Automatically Enable Alternating CQ 

2T2R > Listen to Radio 1 

2T2R > Listen to Radio 2 

2T2R > Listen to both radios 

2T2R > Enable 2BSIQ Audio Routing  
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2T2R > Radio 1 and 2T2R > Radio 2 

2T2R > 2BSIQ.  

2T2R Examples 
The example below by WA1Z describes a traditional approach for doing SO2R with 
SkookumLogger, using one keyboard for both radios. JH5GHM documents his full-blown 2BSIQ 
practices as YouTube videos — search for Katsuhiro Kondou. 

2T2R Audio Routing 
With two radios, you need a way to switch key, PTT, and transmit audio between the radios, 
because you are not allowed to transmit simultaneously on both radios. Additionally, you need a 
way to configure stereo headphones to listen to either or both radios. These function are handled 
by external switching hardware controlled by SkookumLogger. 

SkookumLogger supports two SO2R devices produced as kits by the Yankee Clipper Contest Club 
(YCCC), the YCCC SO2R+ Box and the YCCC SO2R Mini, and also the Neo by JH5GHM. Each 
provides computer-controlled switching between two radios for audio signals, a foot switch, and 
an internal CW keyer. The Box has indicators, toggle switches, and a CW speed pot, the Mini is a 
much smaller unit with no radio mapping, blending, indicators , or controls. and the Neo is similar 
to the Mini with indicators. 

When the operating mode is 1T1R or 1T2R, SkookumLogger sets the SO2R switches to use Radio 
1, disables the audio routing choices and turns off blending in the user interface.  

Choose Window > External Devices 
> YCCC SO2R to configure your 
audio switch. 

The SO2R Box uses USB-HID and 
will be discovered automatically 
when plugged in and turned on, 
with a message in the Status 
Messages window. The Mini and 
Neo are USB-serial devices with the 
usual Port chooser. To choose 
between the YCCC SO2R Box and 
the Mini or Neo, choose the Use 
Mini instead of Box option. 
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Set the TRANSMIT and RECEIVE switches on the SO2R Box to AUTO. Choose the association 
between SkookumLogger Radios 1 and 2 with the output ports on the SO2R Box using the Box 
Radio Mapping buttons. 

SkookumLogger always switches the microphone to the radio with transmit focus. Receive audio 
switching is more complex; you can choose to listen to Radio 1 in both ears, to Radio 2 in both 
ears, or to both radios with Radio 1 in left ear and Radio 2 in right ear. Use the 2T2R > Listen To 
Radio 1, 2T2R > Listen To Radio 2, or 2T2R > Listen To Both commands or the corresponding 
buttons in When Not Transmitting. For the YCCC SO2R Box, you can control blending between the 
two receive channels using the Box Blend Receive Audio slider. 

Green gumdrops at the top-right corner of the Radio 1 and Radio 2 QSO entry boxes indicate 
which radios you are listening to. 

When SkookumLogger is sending messages, it manages receive audio switching for you. When a 
message begins sending on Radio 1, the receive audio configuration changes to your selection in 
the ‘When Radio 1 Transmits’ button group. Similarly, when a message begins sending on Radio 2, 
the choice in the ‘When Radio 2 Transmits’ button group applies. When message sending ends, the 
receive audio configuration changes back to the choice in the ‘When Not Transmitting’ button 
group. 

2T2R > Enable 2BSIQ Audio Routing turns on additional routing change behavior when not 
sending a message:  

✦ Log > Focus Radio 1 QSO Entry sets routing to Listen to Radio 1 if Radio 1 already has 
keyboard focus. 

✦ Log > Focus Radio 2 QSO Entry sets routing to Listen to Radio 2 if Radio 2 already has 
keyboard focus. 

✦ Messages > Abort sets routing to Listen to both radios. 

These additional routing changes are temporary. They do not affect the choice in the  ‘When Not 
Transmitting’  button group, which will be restored at the end of the next message transmission. 

2T2R Operating Scenarios 
The following sections concisely describe what happens for the basic SO2R and 2BSIQ 
configurations. 

The 2T2R > Automatically Enable Alternating CQ and 2T2R > Enable 2BSIQ Audio Routing 
commands are on/off toggles, with the on state for Alternating CQ and 2BSIQ indicated by a 
checkmark preceding the menu item. 

There are three basic SO2R scenarios without special audio routing: Run on one, S&P on the other, 
Run on both or S&P on both radios. The advanced 2BSIQ (Two Band Simultaneous Interleaved 
QSOs) techniques has two scenarios, with and without special audio routing. 
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SO2R running on one radio, S&P on the second 

When one radio is running and the other is S&P, Alternating CQ determines whether or not Beacon 
CQ is used on the Run radio and 2BSIQ is off, establishing the basic environment for SO2R run & 
pounce. 

✦ When tapping F1, CQ is sent from the Run radio. If transmit focus is set to the S&P radio, it will 
first be switched to the Run radio.  

✦ All messages, except the CQ message, are sent from the radio which has keyboard focus 

✦ Changing transmit focus always interrupts message sending 

✦ Messages, including CQ, to the both radios are queued and will be sent in order.  

✦ Ongoing CQ is not interrupted by changing keyboard focus  

✦ The defend message is sent to the Run radio, changing transmit focus if necessary 

✦ When enabling keyboard mode, transmit focus follows keyboard focus  

✦ Always follows audio routing setting  

SO2R running on both radios 

Both radios are running, with Alternating CQ and 2BSIQ off. Practice mode supports this 
configuration.  

✦ When tapping F1, CQ is sent from radio which has transmitting focus  

✦ Other messages except for defend are sent from radio which has keyboard focus  

✦ Ongoing CQ is not interrupted by keyboard focus  

✦ Any message including CQ is interrupted by transmitting focus change  

✦ Message, including CQ, is always queued, not interrupt ongoing message regardless of which 
radio to transmit  

✦ Transmit focus except for CQ follows keyboard focus when transmitting  

✦ Defend message is sent to different radio which does not have keyboard focus and transmitting 
focus moves to different radio  

✦ When enabling keyboard mode, transmit focus follows keyboard focus  

✦ Always follows audio routing setting  

SO2R S&P on both radios 

Both radios are pouncing, with 2BSIQ and Alternating CQ off. In this configuration you can send 
CQ messages, but neither of Beacon CQ or Alternating CQ is applicable. This provides the basic 
environment for SO2R pounce & pounce.  

✦ When tapping F1, CQ is sent from radio which has transmitting focus  

✦ All messages are sent from radio which has keyboard focus  
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✦ Any message including CQ is queued  

✦ Ongoing CQ is not interrupted by keyboard focus  

✦ Transmit focus except for CQ follows keyboard focus when transmitting  

✦ Defend message is sent to radio which does not have keyboard focus  

✦ When enabling keyboard mode, transmit focus follows keyboard focus  

✦ Always follows audio routing setting  

2BSIQ operation without special audio routing 

In this configuration, Alternating CQ is on and 2BSIQ is off. This provides the basic environment for 
2BSIQ with no special audio routing.  

✦ When tapping F1, CQ is sent from different radio which has transmitting focus and transmitting 
focus moves to different radio  

✦ Other messages except for Defend are sent from radio which has keyboard focus  

✦ Next CQ from different radio starts immediately after the end of non-interrupted CQ and 
transmitting focus moves to different radio  

✦ Next CQ from different radio starts immediately after the end of either of End QSO or Short 
Acknowledge and transmitting focus moves to different radio  

✦ Ongoing CQ is interrupted by sending message from the same radio (not from different radio, 
but following CQ does not happen)  

✦ Ongoing CQ is not interrupted by keyboard focus, but following CQ does not happen 
regardless of which keyboard is focused  

✦ Any message including CQ is interrupted by transmitting focus (even for the same radio)  

✦ Message including CQ is always queued, not interrupt ongoing message regardless of which 
radio to transmit  

✦ Defend message is sent to different radio which has keyboard focus and transmitting focus 
moves to different radio  

✦ When enabling keyboard mode, transmit focus follows keyboard focus  

✦ Always follows audio routing setting  

2BSIQ operation with special audio routing 

This is the most advanced environment for 2BSIQ including special audio routing. Both Alternating 
CQ and 2BSIQ are on.  

✦ When tapping F1, CQ is sent from different radio which has transmitting focus and transmitting 
focus moves to different radio  

✦ Other messages except for Defend are sent from radio which has keyboard focus  
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✦ Next CQ from different radio starts immediately after the end of non-interrupted CQ and 
transmitting focus moves to different radio  

✦ Next CQ from different radio starts immediately after the end of either of End QSO or Short 
Acknowledge and transmitting focus moves to different radio  

✦ Ongoing CQ is interrupted by sending message from the same radio (not from different radio, 
but following CQ does not happen)  

✦ Ongoing CQ is not interrupted by keyboard focus, but following CQ does not happen 
regardless of which keyboard is focused  

✦ Any message including CQ is interrupted by transmitting focus (even for the same radio)  

✦ Message including CQ is always queued, not interrupt ongoing message regardless of which 
radio to transmit  

✦ Defend message is sent to different radio which has keyboard focus and transmitting focus 
moves to different radio  

✦ When enabling keyboard mode, transmit focus follows keyboard focus  

✦ Follows audio routing setting except, when not transmitting:  

✦ Tapping ESC listens to both radios  

✦ Focus radio 1 when radio 1 has keyboard focus listens to radio 1  

✦ ‘Focus radio 2 when listening to radio 1’ listens to both radios (radio 2 now has gained 
focus)  

✦ Focus radio 2 when radio 2 has keyboard focus listens to radio 2  

✦ Focus radio 1 when listening to radio 2 listens to both radios (radio 1 now has also focused)  
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Data Entry Techniques 
Stacking Calls 
If you hear more than one call answering your CQ call, you can type them separated by commas in 
the call entry field. Then you can complete QSOs with each call without editing the call field, as 
follows: 

✦ Transmit the Begin QSO message. 

✦ Enter the received exchange. 

✦ Transmit the End QSO message. SkookumLogger will remove the call just sent. If another call 
exists, SkookumLogger will then transmit the ‘Unstack QSO’ message. 

The default Unstack QSO message is “R NW * &”, which sends a short acknowledge for the 
previous QSO together with a hint that a new QSO is about to begin immediately, followed by the 
unstacked call and your exchange. You can customize this message in the usual way. 

County Line Straddlers 
With straddlers, separate counties with a forward slash. 

Text Commands 
Text commands are things you type into a call field that do not look like calls. Press return after 
entering the command to apply the command and clear the call field. Commands that affect radio 
frequency or mode apply the to radio with transmit focus in 1T1R and 1T2R, and to the radio with 
keyboard focus in 2T2R. 

Frequency text command 

Type a frequency in kHz into either call field. You can include a decimal point in the frequency. If 
you have the Remap ‘.’ key to ‘?’ key in Call field option enabled in Logging settings, a question 
mark in the typed frequency will be treated as a decimal point.  

If the frequency is less than 1000, it is treated as offset from the current band edge in kHz. The 
radio is set to transceive on that frequency.  

If you type an asterisk (*) before the frequency, the frequency is processed as above and used to 
set the transmit frequency without changing the receive frequency. 

If you type an ampersand (&) before the frequency while Run has transmit focus, the subreceiver 
will be set to the frequency. If the operating mode is not 1T2R, or if Pounce has transmit focus, or if 
Radio 1 doesn't have a subreceiver, or if Radio 1 is in SPLIT mode, or if the subreceiver diversity 
mode (K3) is on, nothing happens. 

Also see the Radio Frequency Editor. 

Band text command 

This command recognizes a band name typed into a call field and sets the radio to that band. 

Band names end in either ‘M’ or ‘CM’. The call field converts lowercase letters to uppercase for you. 
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The accepted band names are 160m, 80m, 60m, 40m, 30m, 20m, 17m, 15m, 12m, 10m, 6m, 4m, 
2m, 125cm, 70cm, 33cm, 23cm, 13cm, 9cm and 6cm. 

Mode text command 

This command converts what you type into a radio mode and sets the radio to that mode. 

Type CW to change the radio mode to either LCW or UCW. The choice is determined by the Prefer 
upper sideband in CW mode option in the Radios window.. 

Type SSB to change the radio mode to LSB or USB. LSB is used when the radio transmit band is 
below 20m, otherwise USB is used. 

Type FSK, PSK, DATA, or FM to change to those modes. If the radio does not support the mode, the 
command is ignored. 

Bearing text command 

This command converts what you type into bearing in degrees and begins turning rotator 1 to that 
bearing. 

Type a bearing in degrees followed by the degree symbol (°) to change rotator 1 bearing. The 
degree symbol is typed as option-shift-8. 
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Custom Keyboard Behavior 
The function keys are the only way to trigger an action like sending a message with a single 
keypress. A standard mac keyboard has 12 function keys; not enough. An extended keyboard has 
7 more; still not enough. SkookumLogger has two ways to add more single-key actions. The first, 
named special keys, assigns an action to a key that is otherwise not used in QSO entry. The second 
uses an external keypad. 

Special Keys 
A special key is a single character typed on your keyboard that is either a punctuation character or 
a symbol character, with the except of these characters that are used for other purposes in QSO 
entry fields: 

& * , . / ? ° - _ 

Special keys are recognized only when a QSO entry field has keyboard focus. 

Note: In SkookumLogger 4.3 or newer, if you have previously defined a now-illegal special key, that 
definition will be silently removed. Simply redefine the action with another key. 

Messages special keys 

The message-sending commands that can be triggered by a special key are listed in the Special 
Keys tab of Messages settings. It is important to define just a few that you will use often and leave 
the rest empty, so that you can develop muscle-memory for when to tap each key. One approach is 
to define only the Magic Message V1 special key. In that case, you need to be comfortable with the 
context-sensitive decisions that SkookumLogger makes for you about which of 6 messages to 
send, and what to do when a decision is wrong. Another approach is to define the Begin QSO and 
End QSO special keys; in this case SkookumLogger chooses one of 2 messages for each key that 
depend on run/pounce transmit focus. Those who don’t trust software to make decisions for them 
will want to use other message special key choices. 

Correct Last QSO special key 

This command is helpful for quickly correcting typos in the most recently logged QSO. The QSO 
entry fields are empty after logging a QSO, so you simply enter the correction(s) in the field(s) with 
the typo and run the command to replace the typo. The special key definition is entered in the 
Correct Last QSO special key field of Logging settings. 

Focus activity table special key 

The Activity > Focus Table for Current Band command quickly changes keyboard focus to the an 
activity table for the current band, where you can then select and grab an activity, again using only 
the keyboard. The definition for Focus activity table in Activities settings is an alternate way to 
trigger this command. 

Radio spot tone toggle special key 

 This special key is defined in the Radios window, used for quickly turning the radio spot function 
on and off. 

Version 5.4	 Page 61



SkookumLogger Guide

XK-24 Keypad 
 This keypad is an external device connected by USB, with 24 keys. Each key has two backlights, 
red and blue. The keys have replaceable labels. SkookumLogger automatically detects this device 
and enables the connection when it is discovered at startup.  

Pressing a key sends a key ID to SkookumLogger, which performs a task associated with the ID and 
may indicate the task result using blue and red backlights behind the key. The backlights blink 
when an error occurs. Holding a key for more than 0.5 seconds performs the task for Radio 2 
instead of the default, Radio 1. 

Some examples of uses for the keypad: 

✦ Choosing among a set of directional receive antennas, with the buttons located in a 3 x 3 group 
indicating the direction, a backlight on to indicate the selected antenna, and the center button 
used to select the direction appropriate for the call in the QSO entry field with transmit focus. 

✦ Choosing among different transmit antennas, using backlights to indicate which are selected 
for each of two radios, and blinking backlight to indicate YCCC MOAS conflicts. 

✦ Choosing one of four panadapter settings, again using a backlight to indicate the selection. 
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Keypad Button Menu 

The effect for each button is configured in a popup menu 
that lists the available commands. Most commands are 
prefixed with the name of the corresponding 
SkookumLogger menu and perform the same function as 
choosing them from the menu. 

The Select Antenna for Key ID command chooses receive 
and transmit antennas. When you press a keypad key, the ID 
for the key is identified at the bottom of the window. You 
associate this ID with an antenna choice using the Keypad ID 
property in the antenna switching configuration file. 

The Select Best Antennas command combines commands 
for selecting the best transmit antenna and the best receive 
antenna for the current target bearing. 

The blue button backlight indicates a selected antenna or a 
Elecraft P3 span setting. The four P3 span choices also apply 
to the Elecraft K4 panadapter. For Radio 2 antennas, the 
backlight is red. If both red and blue backlights are lit, the 
antenna switch has reported a conflict — one radio tried to 
select an antenna in use by the other radio. 
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Script Support 

Beware: Here be advanced topic. 

The bottom two items are examples of commands that are defined via external scripts. To add a 
script where SkookumLogger will find it, copy it into ~/Library/Application Scripts/
com.k1gq.SkookumLogger and make it executable. 

The script is invoked with a single command line argument which is the path to a JSON file. The 
format of the JSON file is described below. 

JSON Format

Key Data Type Description

key_id integer The index of the XK-24 key that was pressed. A single script 
can be used to handle various keypad keys

active_radio integer An index matching the id in the radios key

radios list A list of entries as described in the Radio Keys table

Radio Keys

Key Data Type Description

id integer A unique ID for this radio. This zero-indexed and will be 0 for 
SkookumLogger Radio 1 and 1 for Radio 2

enabled bool true if the radio is enabled, otherwise false

main_frequency integer The frequency of the main receiver in Hz

sub_frequency integer The frequency of the sub receiver in Hz

xmit_frequency integer The radio’s transmit frequency in Hz

mode string The current radio mode

band integer The current radio band, e.g. 40 for 40 meters

is_tcp bool true if the radio is configured to use TCP/IP, false 
otherwise

ip_addr string The ip address of the radio, exists only if is_tcp is true

ip_port integer The ip port of the radio, exists only if is_tcp is true

serial_port string The name of the serial port used by the radio, exists only if 
is_TCP is false. May be null if no serial port is associate 
with the radio.
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Example Script up2.py 
#!/usr/bin/env python3 

import json 
import pprint 
import subprocess 
import sys 

def main(): 
    with open(sys.argv[1]) as fh: 
        data = json.load(fh) 
     
    # Note that data[‘key_id] holds the XK-24 key pressed 
    # so a single script could service multiple keys 
     
    # Choose the info for the active radio 

    radio = data[‘radios'][data['active_radio']] 

    #Check if we’re a TCP K4 
    if radio['type'] != 'K4 TCP' or not radio['is_tcp']: 

        pprint.pprint(radio) 
        print("ERROR: Only K4 TCP radios are supported") 
        sys.exit(1) 
    else: 
        # Send the command to the IP:port of the K4 
        # for complex scripts you might open a proper socket, for 
        # this script just invoking a shell script using netcat (nc) 

        cmd = 'UP;UP;' 
        ip_addr = radio['ip_addr'] 
        ip_port = radio['ip_port'] 
        subprocess.run(f"echo '{cmd}' | nc {ip_addr} {ip_port}", shell=True) 

    return 0 

serial_baud integer The serial baud rate of the serial port used by the radio, 
exists only if is_TCP is false. May be null if no serial port is 
associate with the radio.

serial_parity integer The serial parity of the serial port used by the radio, exists 
only if is_TCP is false. May be null if no serial port is 
associate with the radio.

serial_stop_bits integer The serial stop bit of of the serial port used by the radio, 
exists only if is_TCP is false.

Key Data Type Description
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if __name__ == '__main__': 
    sys.exit(main()) 

Keyboard Maestro 
This is a powerful app that can associate keyboard keys with one or more SkookumLogger 
commands. It is useful when you want to use keys that are not accessible as shortcuts in macOS 
preference, such as caps lock and keypad keys on extended keyboard. It can access any menu item 
in SkookumLogger using the default shortcut if there is one, or the names of the menus in the path 
to the menu item. 

See Using Keyboard Maestro. 
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Fonts and Colors 
SkookumLogger uses the System monospaced 
font in order to display slashed zeros. You can 
choose the font style for all QSO entry fields 
except the Call field from a menu listing font 
weights.  

Text adornments (font style and color together) 
indicating needed status are applied to the call 
entry fields and QSO Status Information in QSO 
Entry panes, to the calls in Activity tables, and to 
known activity cursors in the Panadapter window. 

Suggestion: Use heavier font weights to 
emphasize needed calls. 

Open the Logging panel to access Fonts and 
Colors settings. Click a color well to open the system Color chooser. If you alternate between Dark 
mode on and off, use the colors in the Developer palette with names beginning with “system, 
which adapt to system appearance mode changes.” 

QSO entry style (Regular) determines the weight of the text displayed in QSO entry fields other 
than the Call field. The font is monospaced with a slashed zero, and has nine weight styles between 
Ultra-light and Black. 

The items with both a font style chooser and a color well determine appearance of calls based on 
their needed status. Note: the font for Worked before and and Zero-point QSO is always Regular-
italic. 

Buddy (Regular, systemPurple) is used for your own call and for call that match those in your Buddy 
Calls list. Orange can be a good choice for this. 

Worked before (Regular-italic, systemRed) is used when the call is would be a duplicate according 
to the contest rules. Red is a good color for this status. 

Needed multiplier (Regular, systemGreen) is used when the call would be a new multiplier. A 
medium green color is one option to use for this.  

May be multiplier (Regular, systemYellow) is used when SkookumLogger believes the call might be 
a new multiplier but can’t be sure. This condition occurs when multiplier status depends on more 
than just the call. 

Needed QSO (Regular, systemMint) is used when the call hasn’t been worked before and isn’t a 
needed multiplier or a possible multiplier. Blue might be a good choice for this as hopefully many 
calls typed in will fall into this category.  

Zero-point QSO (Regular-italic, systemGray) is used when the call is known to not contribute QSO 
points. A thin weight and neutral color are suitable for this case.  
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When SkookumLogger doesn’t have enough information to determine status for a call, it uses the 
system default text color (white in Dark mode, black when Dark mode is off). Common cases for 
this are an invalid call or contest rules that require received location information to check for 
dupes. 

Partial match underline color (systemRed) is used for underlining characters in known calls in the 
Partials pane that are either matched or not matched, depending on the Underline unmatched 
characters Logging setting. 

Entry field background highlight color (unemphasizedSelectedTextBackground) determines the 
background color for the call field when the call is exactly matched to a known call in the Partials 
pane, and for other QSO entry fields when SkookumLogger has pre-filled the field value. In 
addition, the color determines the highlight color behind the text of an exactly-matched call in the 
Partials pane. 
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Activities 
An activity encapsulates information about a particular signal heard on the air by you or — if 
connected to DX Cluster — by others. The information is extracted from DX Cluster announcements 
and from your logged QSOs. Activities may also be created manually or automatically via options 
in Activities settings. Activities are displayed in tabular format in a separate window for each band. 
They can also be displayed graphically in a Panadapter window. 

Activity Windows 

You can have any combination of thirteen activity windows open at the same time. You manage 
your activity window using items in the Window > Activity Tables menu. 

Activities are presented in a table. The two popup lists above the table have choices for which 
among all activities for a band are displayed in the table. 

The Call column content use the fonts and colors defined in Logging settings to distinguish 
needed multipliers, needed QSOs, and duplicates.  

In a WAEDC contest, # preceding a call identifies a station that can send/receive QTCs, and the 
prohibited emoji 🚫  identifies a station that has refused QTCs.  

The call column for the current radio band also shows pseudo-activities named <rx> 
and <subrx> at the frequencies for your receiver and subreceiver. When the frequency of a 
pseudo-activity is near an activity, the activity is selected. The Frequency tolerance option in 
Activities Settings defines “nearness”. 

Note: The subreceiver pseudo-activity appears only in 1T2R mode. 
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The Age column displays how many minutes have elapsed since the activity was added to the 
table. The Activity age limit option in Activities Settings sets the threshold for removing old 
activities from the table. Tip: to reset all of the activity tables, temporarily change the limit to 1. 

The Frequency column displays the transmit frequency for the activity. The frequency is preceded 
by an asterisk if the activity has differing receive and transmit frequency. This can occur if QSX 
information is detected, and when you create a spot from Pounce QSO that has a transmit offset. 
Grabbing an offset activity will set up the radio in split mode. Note: QSX means “I am listening on 
…”, used by stations operating split to indicate the frequency they are listening to. 

The Mode column lists the mode for each activity. For some DX Cluster announcements, 
SkookumLogger has to guess mode from frequency. When the guess is wrong, you can correct it 
by selecting the activity and choosing the correct mode with the appropriate Activity > Set Mode 
to menu item. 

The ° Bearing column contains the short-path bearing from your location to the call, determined 
when the activity is created. 

The Info column contains either information extracted from the DX Cluster spot comment field 
when the spot source is a skimmer, or, for internally-generated activities, the received QSO 
exchange information. See Skimmer Filters for details on the extracted information. 

The Source column identifies the origin of the activity. When the source is a skimmer, the source 
call has "-#" as the suffix. 

The By Me column contains checkmarks for internally-created activities. 

You can choose which columns are visible, rearrange and resize columns, and sort on a column; 
see Table Manipulation. Activity > Activity Table Items also manages table column visibilities, 
individually for each band, or for all tables. 
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Activity Settings 

The gear icon at the top right 
corner of each Activity 
window opens the Activity 
Settings window. The 
properties defined here apply 
to all Activity windows. 

Activity age limit (60) — 
Activities with ages greater 
than the limit are discarded. 
Activities generated by 
skimmers are separately aged 
out with a 10 minute limit. 

Table update interval (1.0) — 
Determines how often 
SkookumLogger updates the 
activity tables from queues of 
incoming activities. 

Frequency tolerance (200) — Determines the matching tolerance when comparing frequencies for 
removing nearby activities, highlighting nearby activities, and autofilling nearby activities. When set 
to zero, no nearby activities are removed or highlighted.  

Focus activity table special key () — Assigns a single key as the shortcut for changing keyboard 
focus from the Log to the Activity table for the log's current band. 

Remove old activities near new activities (YES) — Prevents accumulating many activities near the 
same frequency. 

Activity >Create clears QSO Entry (NO) — clears the QSO entry pane fields for the pane with 
keyboard focus after creating an activity from the contents of that pane. 

Pounce receive frequency change … 

Fills QSO entry from nearby activity (NO) — Fills Pounce QSO entry fields from an activity near 
the pounce receive frequency. If there is no activity within the tolerance, the entry fields are 
cleared. “Near” is ± the Frequency tolerance setting. While tuning near an activity in Pounce 
mode, the receiver frequency may snap back to the activity frequency unless you tune slowly. 

Creates activity from QSO entry and clears entry (NO) — Creates an activity when tuning by 
more than the tolerance after entering a call, using the information in the Pounce QSO entry 
pane before clearing the entry fields. 

Neither (YES) 

Log > Clear Focused QSO Entry … 

Version 5.4	 Page 71



SkookumLogger Guide

Removes nearby activities (YES) — removes activities near the same frequency as the radio 
when clearing a QSO entry pane. 

Creates activity from QSO entry (NO) — If the QSO entry call field has a valid call sign, adds a 
new activity to the Activity table for the current band using the information in the QSO entry 
fields, then clear the QSO Entry Pane. 

The Buddy Calls list has two roles. First, any call in the list is exempted from filters that you may 
apply to your activity tables. Second, the list supplies the elements of the <buddies> token for DX 
Cluster  “always pass” spot filtering, so that announcements for your buddies will always pass the 
filter. The list is alphabetically ordered. To add a call, click the + button, then edit the “new buddy” 
item. Be sure to include your contest call so that spots for you are distinguished in activity tables. 

The calls in the list of buddies are adorned with the Buddy font style and color when the calls 
appear in activity tables, partials lists, and call entry fields. 

Activity Commands 

The Activity menu has items for interacting with the active 
Activity window. The active window responds to your 
keyboard input, used for navigating the rows it the table, 
and for applying commands to the selected table row. To 
make an Activity window active, click on the Activity 
window with the mouse, use Activity > Focus Table for 
Current Band, or choose an item in the Window > Activity 
> Tables menu.  

Note: While an Activity window has keyboard focus, the 
content is not updated. This makes it easier to interact with 
specific rows in the table. 

The Focus activity table special key option in Activities 
settings defines a single-key shortcut for the Activity > 
Focus Table for Current Band command.  

To select a row in the activity table of an active Activity 
window: 

✦ Use the up or down arrow keys 

✦ Begin typing a call 

✦ Click on the row 

The Activity menu items with “-click” in their name select the row and apply the action in one step. 

If the call field of the QSO pane with keyboard focus is not empty, Activity > Announce and Activity 
> Create, construct an activity from the information in the QSO pane and add it to the Activity table 
for the QSO’s band. In the Announce case, the activity is converted to a DX announcement and 
sent to your DX Cluster connection. 
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Activity > Grab to Pounce (click) loads the activity into the Pounce QSO entry fields and changes 
keyboard focus to the Pounce entry pane. In the 2T2R operating mode, this item is Activity > Grab 
to Radio 1 (click) and loads the activity into the Radio 1 QSO entry fields, changing the radio mode 
and frequency but not changing which entry pane has keyboard focus. The 2T2R Grab spots to 
transmit/not-transmit radio OpMode setting changes this item to Activity > Grab to Transmit Radio 
(⇧-click), loading the QSO entry fields for the radio with transmit focus. 

Activity > Set Pounce (⇧-click) loads the activity into the Pounce QSO entry fields without 
changing keyboard focus. In the 2T2R operating mode this item is Activity > Grab to Radio 2 (⌥-
click) and loads the activity into the Radio 2 QSO entry fields, changing the radio mode and 
frequency but not changing which entry pane has keyboard focus. The 2T2R Grab spots to 
transmit/non-transmit radio setting changes the item to Activity > Grab to Not-transmit Radio, 
loading the QSO entry fields for the radio without transmit focus. 

When the Pounce receive frequency change … Fills QSO entry from nearby activity option is on in 
Activities settings, the Activity > Set Pounce command is automatically executed as you tune the 
receiver across an activity. If there is no nearby activity, the Pounce QSO entry is cleared. 

Activity > Set SubRX (⌥-click) changes the subreceiver frequency of the current transmit radio to 
the frequency of the activity. 

Activity > Delete (⌘-click) removes the activity from the table. 

Activity > Add to Reject List (⇧⌘-click) removes the activity from the table and adds the activity’s 
call to a list of calls are ignored when processing DX Cluster spots. The list is saved in the 
RejectedCalls.txt file, in the Applications Support folder. Typically, use this feature for calls that 
are frequently bad spots. 

Activity > Call Rejected QTC adds the call in the active QSO entry pane to a list of calls that refused 
when you asked to exchange QTCs. Calls in that list appear in Activity tables flagged with the 
prohibited emoji: 🚫 . The command is hidden except for the WAEDC contest. The list is emptied 
when you start SkookumLogger, reset the log, or change to a different log. 

Activity > Update Needed Flags update status for all activity tables. Editing a logged QSO can 
invalidate the needed status for activities; this won’t be noticed for logs that exceed the 
Automatically rescore logs smaller than Logging settings limit. 

Locally Networked SkookumLogger ActivitIes  
When two more computer running SkookumLogger are using SkookumNet, activities created on 
one computer show up on all other computers. 
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DX Cluster 
SkookumLogger supports DXSpider nodes running version 1.57 build 440 or newer, with RBN 
capability enabled. Behavior if you connect to any other kind of DX Cluster node is undefined. 

Some contests or entry categories require that the operator doesn’t use any externally provided 
information to find stations to work, generally known as unassisted categories. In SkookumLogger, 
you should disconnect (log out) in the DX Cluster setting window to ensure that external sources 
do not add entries to the Activity windows. The DX Cluster icon in the main widow status bar  
should be red, indicating no connection. 

DX Cluster Window 

Window > DX Cluster opens a simple terminal window for interacting with your connected 
DXSpider node. The window title shows the node URL and your login call. The upper text pane 
contains text received from the node, and the lower pane contains commands you have sent to the 
node. In the example, the received text pane shows what you might see when your first connect to 
a new node. The gear icon opens the DX Cluster settings pane, described in the next section. 

During a contest, you generally don’t need to keep this window open. 

The user manual for DXSpider is somewhat dated. To get more current information, use the 
DXSpider help command, as illustrated in the example window. The responses to those commands 
appear the received text pane. The Show spot announcements option turns on display of all 
received spots, which can be helpful when debugging spot filters, discussed below. 
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DX Cluster Settings 

The DX Cluster pane (globe icon) in the SkookumLogger > Settings window configures your 
DXSpider connection. The DXSpider node popup chooses a node name from an editable list of 
node names and URLs. Login call is you identity on the connected node. You can use any call you 
want as the login call, but be aware that spot filters that you set up on the node are associated with 
that call. Additionally, if you want to announce DX on the node, you need to register your login call 
with the node’s sysop, as shown in the login greeting for the example DX Cluster window above. 

SkookumLogger remembers your login status across sleep/wake and quit/restart cycles, and 
automatically logs in when necessary. 

DXSpider nodes may a password associated with your login call that needs to be supplied when 
you connect. For now, SkookumLogger does not support DXSpider node that have enabled this 
security feature. 
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Node List 
The DX Cluster nodes popup list initially 
has a few pre-defined entries. You can 
add or remove items by clicking Edit 
List to open the DX Cluster Nodes 
window with a table listing node names 
and URLs. The Name for a node can be 
anything you like. Address must be a 
valid URL, optionally followed by a colon 
and a port number. SkookumLogger 
assumes the port number is 23 (the 
telnet default) when none is supplied. 
Click the DXSpider Nodes List button to 
visit a web page containing a large table 
of DXSpider nodes, included their 
addresses and their software versions. Look for table entries with version at least 1.57 build 440, 
and that indicate  support for RBN (Reverse Beacon Network), which delivers spots generated by 
skimmers around the world. 

Note: the KM3T ARCluster and KM3T CC entries in the example list are used for testing and not 
part of the default list. 

Spot Filters 

When you connect to a DX Cluster node, you receive DX announcements, termed spots, from all 
around the world. If you do this, you should choose the Assisted item for the Assisted: choice in the 
Cabrillo Category Items box in your settings opened by Log > Cabrillo Settings…. 

During a contest, there can be millions of spots per day. SkookumLogger converts received spots 
into activities and displays them in Activity tables for each band. The conversion eliminates some of 
the spots, but that processing can interfere with other concurrent processing by SkookumLogger 
so it is better to eliminate unneeded spots before they are sent to you by the node. You do this by 
defining a spot filter. Spot filters are stored on the node that you are connected to, and reduce the 
number of spots that are sent to you without affecting anyone else. Each node maintains a spot 
filter associated with your login call, independent of your spot filters on other nodes. 

Use The Spot Filter text box DX Cluster settings to define your. The default filter is: 
set/skimmer 
clear/spot all 
accept/spots 0 call <buddies> 
reject/spots 1 call <rejects> 

This filter turns on receiving spots from the Reverse Beacon Network (RBN) which aggregates 
skimmer spots from all around the world, clears all 10 spot filters (numbered 0 through 9), passes 
all spots for calls in your buddies list, and rejects all spots for calls in your rejects list. 
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Mostly you will out more than just your rejects list, like I do in this example: 
set/skimmer CW 
clear/spots all 
accept/spots 0 call <buddies> 
reject/spots 1 call <rejects> 
reject/spots 2 by K3PA,K2PO/7 
#reject/spots 3 not on contesthf 
#reject/spots 4 not by_itu 4,8,9 

Adding CW to the set/skimmer line rejects skimmer spots for modes other than CW. The modes 
recognized by this command are CW, BEACON, PSK, RTTY and FT. Separate multiple modes with 
spaces, as in: 

set/skimmer CW RTTY 

Clearing all spots when defining a filter is important because the DXSpider node remembers each 
of the 10 previously defined spot filter lines, and they will be left in place if you don’t overwrite 
them in the new set of filter lines, almost certainly yielding confusion. After setting a filter, use this 
command in the DXCluster window to examine the filter settings at the node: 

show/filter 

Filter 0 passes all spot for calls in your SkookumLogger buddies list with no further ado. 

Filter 1 does not pass (rejects) all spots for calls in your SkookumLogger rejects list.  

Filter 2 in the example rejects spots made by the calls in the list. Do not use spaces in the list of 
calls, and do append the symbols at the ends of skimmer sources, typically “-#”. The two calls in the 
example are for skimmers located in zones different from the zones inferred from their call signs. 
Their spots are distracting when I want to see only spots from sources near me (see filter 4). 

Filter 3 in the example rejects spots on bands other than the 6 HF contest bands. There are many 
other ways to specify bands you want, see Filters to reject spots based on frequency. This web 
page is also accessed by Help > DXSpider Spot Filtering. 

Filter 4 in the example rejects spots from not made by sources in my itu zone or a couple of nearby 
zones. Said another way, only spots made by sources near me (and most likely to be workable) are 
delivered to SkookumLogger. The previous link describes other “by” filter options. 

Two of the lines on the example spot filter are “commented out” by placing # at the beginning of 
the line. This is an easy way to change your spot filter without needed to record the previous filter 
lines in case you want to restore it. 

Note: DXSpider adds “spot quality” information to the comments field for spots generated by 
skimmers. That information is challenging to digest at a glance during a contest, so 
SkookumLogger instead displays “U” (unverified) when the spot was reported by two skimmers,  
and “V” (verified) when the reported by more than two skimmers. You can see the full quality 
comment in the DXCluster Window when you turn on the Show spot announcements options. 
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Note: RBN delivers some CW beacon spots that are uninteresting for contesting. SkookumLogger 
logger ignores spots for calls ending in “/B”, which removes those spots from you Activity tables. 
You can use Activity > Add to Reject List to ignore other beacons. 

Other Settings 

Update Spot Filter at log in sends your spot filter to the node each time you log in, so that you 
don’t have to remember to do that yourself after changing your buddies list or your rejects list. 

Update Spot Filter is for use if you have changed your spot filter after log in. 

Get WWV Forecast at log in asks the DXSpider node to send the most recent WWV propagation 
forecast data. When received, SkookumLogger displays the most recent data at the lower left 
corner of Map windows. When a WWV announcement is received while connected, 
SkookumLogger updates that display. 

Ignore band-edge DX announcements discards activities for frequencies at a lower band edge. 
Some illiterate DX Cluster users send band-edge spots with messages in the information field as a 
way to broadcast to everyone. 

Three radio buttons determine how to guess the mode when a spot doesn’t explicitly specify it. 

Guess spot mode using phone band edge guesses mode based on the spot’s frequency relative to 
the phone band edge.  

Assume CW mode for non-skimmer spots is useful when the contest mode is CW only. 

Assume SSB mode for non-skimmer spots is useful for SSB-only contests and the phone band edge 
is ill-defined, like the CQ 160m SSB contest. 
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Messages 
SkookumLogger can transmit stored messages. For CW mode, the messages are defined in 
SkookumLogger and transmitted via your CW Keyer. For SSB mode SkookumLogger uses your 
radio’s voice memories. For FSK/PSK modes, the messages are defined in SkookumLogger and 
transmitted via your radio’s text-to-data encoder. 

SkookumLogger assigns specific roles to most messages. You can change the names and 
definitions of some messages, but you should not change their roles because other messages 
depend on them. 

Start a message transmission by choosing a message in the menu, or by using its keyboard 
shortcut, or by pressing a special key. You can also start CW messages 1 through 4 by pressing one 
of the four buttons on your WinKeyer, and abort message sending by tapping your WinKeyer 
paddle.  

When you trigger a message, information about the message is added to the end of a queue. If the 
queue is empty, the message begins transmitting immediately, and is removed from the queue 
when the complete message has been sent. If the queue is not empty when transmitting ends, the 
next message in the queue begins transmitting. 

This approach allows you to chain messages by triggering them without concern for overlapping 
the triggers — the queue handles when they will be transmitted. For example, you can send your 
call twice by quickly tapping F4 twice; the queue takes care of including a space between them. 

SkookumLogger manipulates the color of the mode text in the QSO Entry pane with transmit focus 
to show you the status of the queue: 

✦ Normal text color (black or white depending on Light/Dark display mode) when the queue is 
empty. 

✦ Blue when transmitting a CQ message. 

✦ Red when transmitting a message that isn’t a CQ message. 

✦ Orange when transmitting a message and another message is in the queue. 

The Messages > Abort command immediately stops keyer sending, practice mode sending and 
radio (DVR) transmission, pauses Beacon CQ, stops Alternating CQ, resets Magic Message, clears 
the CW message queue, and sets receive audio routing. You should do this when (rarely) the 
queue stalls, indicated by a colored mode text when no message is transmitting. 

The Messages menu is divided into several groups of items that transmit messages: 

✦ Basic Messages — Simple messages with no side-effects. Many are used as components of 
compound messages and intelligent messages.  

✦ CQ Messages — Messages for various CQing techniques, including beacon CQs and alternating 
CQs for 2T2R.   

✦ Compound Messages — These messages combine basic messages to construct common 
messages that can be transmitted with a single key press.  
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✦ Intelligent Messages — Messages that depend on context.  

Basic Messages 
The default titles and content for basic messages in new logs are defined in the CW Messages tab 
of New Log settings. The titles appear on the Messages menu. You can customize some of the 
titles, marked with † below, using either the default settings to affect all new logs, or the Morse 
Messages Editor for the current log. 

Use the Morse Messages Editor to define the content of these messages for CW mode, and the 
Data Messages Editor to define content for data modes. For SSB, use the SSB tab in Messages 
settings to associate a basic message with a DVR message number. 

The content of CW and Data messages can include tokens that are substituted just before the 
message is transmitted. 

Messages > Exchange  — Your sent exchange, displayed in the prompt line of the Log window. 

Messages > Repeat Serial Number  — The serial number for the current QSO, or for the previous 
QSO if the current QSO is empty. 

Messages > Repeat Exchange — The sent exchange, omitting the report if any. 

Messages > Acknowledge — Your “I got it, thanks” message. 

Messages > My Call — Your own contest call. 

Messages > His Call — The other station’s call. 

†Messages > Call? — Ask to repeat call. 

Messages > Again? — Ask to repeat what was just sent. 

†Messages > Number? — Ask to repeat number. 

Messages > Short Acknowledge — A concise acknowledge for use when you know another caller is 
waiting. 

Messages > Defend — A “frequency is in use” message. In 2T2R, the message is sent on the radio 
that doesn’t have keyboard focus. If necessary, sending is aborted and transmit focus is changed to 
that radio. Morse message tokens are not processed in this message. 

†User 1 … User 5 — Messages to be fully customized by you. 

CQ Messages 
SkookumLogger increments a counter each time you send a CQ message, including customized 
messages with CQ in their title. The count is displayed in the Score window. 

Messages > CQ — The basic CQ message. For 1T1R and 1T2R, transmit focus is changed to Run 
before transmitting if the CQ changes focus to Run option is on in Messages settings. For 2T2R, 
transmit focus is toggled before transmitting.  

Messages > Beacon CQ  — Transmits the basic CQ message. When the message ends, the basic 
CQ message is added to the message queue again after a delay determined by the CW Beacon 
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Delay setting in Messages settings. When a Beacon CQ message is transmitting and Abort is 
triggered, beacon CQing is paused. When paused, triggering the CQ message resumes beacon 
CQing. Sending with the paddle, or typing into a Run QSO entry field when the Typing stops 
CQ option in Messages setting is enabled, also pauses beacon CQ. The label Beacon CQ appears 
in the Log window below the search field and the menu item is checked when beaconing. The 
label changes to (Beacon CQ) and the checkmark on the menu item changes to “—” when 
beaconing is paused. In either of these states, choosing Messages > Beacon CQ turns beaconing 
off. 

Messages > Alternating CQ (2T2R only) — Transmits the the basic CQ message. When the message 
ends, the message is added to the message queue again with no delay, and transmit focus is 
toggled. When an Alternating CQ message is transmitting and the Typing stops CQ option is on 
and transmit focus matches keyboard focus, typing into a QSO entry field invokes Messages > 
Abort. If keyboard focus is changed while Alternating CQ is transmitting, alternating stops when 
the CQ ends. Alternating CQ is also started by tapping the F1 (CQ) key with 2T2R > Automatically 
Enable Alternating CQ checked, if both radios are in run mode (no yellow gumdrops). 

Compound Messages 
Compound messages combine basic messages to construct common messages that can be 
transmitted with a single key press. These messages cannot be directly edited because their 
content depends on the content of their basic messages components. 

Note: Messages with Focus in their title may tell your radio and amplifier to change frequency and 
begin transmitting with almost no delay. Transmitting might begin before your radio/amplifier has 
completed the change, which can cause hot-switching or clipping of the beginning of the 
message. To avoid this possibility, do not use these compound messages. Instead use the 
equivalent focus command and basic message, waiting for the frequency change to complete 
before starting the message. 

Messages with Log in their title log the QSO for the entry field that had keyboard focus at the time 
the message was added to the message queue. 

When the Correct mode option in Messages settings is on, compound messages with Log in their 
title will prepend the call about to be logged if it differs from the call that was transmitted as His 
Call. 

Messages > Call Again sends the content of the call field with transmit focus, with ‘?’ appended 
when the content has less than 3 characters. In 2T2R, the beginning of the message is delayed by 
the duration of your sent exchange at the current sending speed. This is an alternative to simply 
sending Messages > His Call to stimulate someone to call again when you have part of their call. 

Intelligent Messages 
When SkookumLogger knows whether you are running or searching and pouncing, it can decide 
for you what messages to transmit. You enable that feature simply by running in the RUN QSO 
Entry pane and pouncing in the POUNCE QSO Entry pane. 
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Messages > Magic Message V1 or V2 — Walks through making either a run QSO or a pounce QSO, 
based on which QSO entry pane has keyboard focus while pressing the same key at appropriate 
times. See  Magic Message. 

Messages > Begin QSO — Transmits either Messages > His Call + Exchange or Messages > My 
Call, depending on run/pounce mode at the time the message is added to the queue. For 1T1R 
and 1T2R, the mode is determined by transmit focus. For 2T2R, the mode is determined by the 
submode (yellow gumdrop) for the radio with keyboard focus at the time the message is added to 
the queue. 

Messages > End QSO — Transmits either Messages > Acknowledge + Log or Messages 
> Exchange + Log, depending on run/pounce as above. 
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Messages Settings 

Click the gear icon labeled M in the main window, or choose the messages icon in the 
SkookumLogger > Settings window to display Messages settings.  

The SSB tab defines the DVR message number to play for some Messages menu items. You should 
should create DVR messages that correspond to the message names. Set the DVR number to 0 to 
tell SkookumLogger not to play that message. For example, if your radio has three DVR channels, 
you might assign the first channel to CQ, the second to Acknowledge, the third to My Call, and 
assign 0 to the other five messages. 

The QTC tab in Messages settings defines CW messages that are transmitted when sending or 
receiving a QTC series. These message apply only for WAEDC contest logs. 

Some QTC messages are sent automatically as described in QTC Series. Others with a function key 
in their label are sent when you press that key while the QTC Series window is active. Messages 
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that involve sending the series number and count are prepended to those values and you will 
need to include a space at the end of your prefixed string. 

The Special Key tab in Messages settings defines additional single-key shortcuts to augment the 
limited supply of function keys. These keystrokes are recognized only when a QSO entry text field 
has keyboard focus. You can leave the definitions empty for any of the commands that you do not 
intend to use via this mechanism. To define a special key, type any single character that isn’t a digit, 
a letter, or one of these symbols * , . / ? ° : 

Hint: Begin QSO and End QSO are the most powerful of these items. Assign them to semicolon 
and apostrophe, respectively. 

The four Beacon CQ Delay (4.0) values set the interval between the end of your CQ message and 
the beginning of the next CQ when Beacon CQ mode is on. The delay for FSK and PSK messages 
is fixed at 5 seconds. 

Correct mode (NO) sends the received call before logging if it was changed after it was sent. 

Typing stops CQ (NO) aborts a CQ message and pauses Beacon CQ mode when you type into a 
QSO entry field for the entry pane with transmit focus. 

CQ changes focus to Run (YES) automatically switch transmit to Run before sending the CQ 
message. This option does not apply for 2T2R. When Pounce has transmit focus and switching to 
Run causes a band change, SkookumLogger waits 1 second before beginning to send the CQ 
message. 

Send leading zeros in serial numbers (YES) prepends zeros to sent serial numbers smaller than 
100. 

Cutify leading zeros in serial numbers (YES) sends T instead of 0 for prepended digits. 

Enable message chaining (YES) queues a message when you tap a send key while a message is 
already sending. Turn this off to ignore sent key presses while a message is sending, which can be 
important in keyboard-intensive operating scenarios like 2BSIQ. 
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Messages Editor 

The Morse Messages Editor customizes basic message titles and content for CW messages. 
Changes that you make with this editor are saved with the current log and do not affect other logs 
or the default messages in the Messages tab of New Log settings. 

Some of the Menu Title items are editable. Text that you enter here also appears for the 
corresponding items in the Messages menu. 

All message definitions in SkookumLogger can contain plain text and tokens. The plain text is case-
insensitive, and may include any characters recognized by the WinKeyer. Unrecognized characters 
are ignored when sending a message. 

Tokens are placeholders for information that depends on your log, such as the received call or the 
sent serial number. When you trigger sending a message, SkookumLogger quickly scans the 
message definition for tokens and replaces them with suitable plain text. 

The available message tokens are: 

sent call (~) — The call sign in the Call field of the sent exchange. 

sent exchange (&) — The content of Morse Sent Exchange Template in the Sent Exchange Editor. In 
CW mode, SkookumLogger automatically sends the content of the Sent Report entry field before 
sending the exchange message when the current log has a Sent Report entry field. That field does 
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not accept alphabetic characters, although “9” is converted to “N” when sending. So, for example, 
you cannot create the “ENN” abomination. 

sent exchange field (&1 … &5) — the components of the sent exchange for contests where the 
exchange has up to five fields (think ARRL Sweepstakes). Use these messages to respond to 
requests to repeat a specific field. 

sent serial (#) — The next serial number, shown in the exchange prompt of the log window. 

received call (*)  — The content of the Call field of the active QSO data entry pane. When the token 
for received call is at the beginning of a message, it is sent with call type-ahead, and the sent call is 
remembered for detecting whether or not the call field changed afterward. 

received name (+)  — The content of the Name field of the active QSO entry pane. If there is no 
Name field, SkookumLogger looks for a name associated with the received call in your Exchange 
database. 

message-n ({n)  — Inserts the n-th (1 through 16) basic message definition. The first column of 
messages are numbered 1 through 8, and the second column message numbers are 9 through 16.  
The special token “{0” inserts the content of the sent exchange info field, typically used when the 
info field is an administrative code such as a county. You can include multiple message-n tokens in 
a message, but be careful not to construct an endless message by directly or indirectly referencing 
the same message. These messages apply only for the Magic Message Version 1 protocol. 

QSY frequency (!)  — Inserts the transmit frequency (in kHz) for the QSO entry pane that does not 
have transmit focus (the pane without the red dot). Use this to  a message for passing a station you 
have just worked to another band. In 2T2R, when transmit focus and keyboard focus are different 
SkookumLogger automatically changes transmit focus to the entry pane with keyboard focus when 
you start a message. In this case, the frequency in the QSY message will be the frequency for the 
radio that had transmit focus before the change and it will be transmitted on the radio with transmit 
focus after the change. When using SkookumNet, the frequency is determined differently. 

half space (|)  (CW messages) — Inserts a space with half the duration of the normal space between 
Morse characters. 

CRLF (}) (data messages) — Starts a new line. 

There are two simple rules to be aware of when defining messages: 

✦ The CQ message is the message that plays when Beacon CQ mode is active. 

✦ The token for message-n must not be used in the definition for message-n, or in any other 
message referenced by message-n. 

CW Messages 

SkookumLogger requires a WinKeyer or certain WinKeyer emulations to send CW messages. The 
tested emulations are the keyers in the two YCCC SO2R devices, including a customized version of 
the YCCC SO2R Mini by JH5GHM. 
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Note: it is possible to send messages using a radio with a CW text encoder, which is the same thing 
as a builtin CW keyer. This has limitations: call type-ahead and keyboard mode are unavailable. See 
Text Decoding and Encoding. 

Use Window > External Devices > Morse Keyers to set up your keyer. 

Each SkookumLogger log has a set of 16 basic CW messages and 6 Magic Message messages. 
When you create a new log, the messages are copied from the definitions in the CW Messages tab 
of New Log settings. Choose  Window > Editors > Morse Messages Editor  to open a window for 
customizing messages in an existing log. Changes that you make in the editor are saved in the log 
document and do not affect preference values. 

In CW mode, the relevant Messages menu items are disabled unless Practice Mode is enabled or a 
supported keyer is available. The SO2R Box+ is available if it is turned on; other keyers are 
available when their serial port connections are enabled. 

DVR Voice Messages 
In SSB mode, SkookumLogger can play up to eight radio DVR messages for radios that have voice 
message playback. The Messages  >  Record Voice Message  > menu items instruct your radio to 
begin recording one of up to eight DVR messages. Use Messages  >  Save Recording to end the 
recording. You may find it easier to get the message length just right with these keyboard actions 
than with buttons on your radio. The radio is in transmit mode during the recording. An Elecraft K4  
stores the recording in a buffer, and can be discarded without affect the existing message using  
Messages > Cancel Recording. 

See the SSB tab in Messages settings to assign which DVR message plays for when you choose a 
message item in the Messages menu. 

Synthesized Voice Messages 
SkookumLogger 4.6 or newer leverages the macOS Personal Voice and Live Speech features, 
available in Sonoma on silicon Macs, to send voice messages in a manner similar to CW message 
sending. You define the messages in a voice messages editor, and trigger a message using the 
same keyboard shortcuts. SL replaces message tokens with text, optionally replaces words — 
typically call signs — with phonetics for the characters in the words, then converts the text to 
speech. This feature is named the Voice Keyer. 

Enabling the Voice Keyer 

When you first start SkookumLogger on a computer that satisfies the 
requirements for using the Voice Keyer, you will see an Alert asking 
permission to use Personal Voice. If you click Allow, the permission 
alert won't appear anymore when you start SkookumLogger. A 
permission status message will appear in the Status Messages 
window when you start SkookumLogger. If you have no personal 
voices on your computer, a second status message will appear 
explaining that Voice Keyer cannot be enabled. 
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When the Voice Keyer is enabled, you will see two "waveform" status buttons next to the recording 
icon at the bottom right corner of the log window, corresponding to Radio 1 and Radio 2: 

 . The status button without a slash indicates that the Voice Keyer is using speech 
synthesis when sending SSB messages. Otherwise, the Voice Keyer uses the radio DVR, if available. 
Click the button to toggle voice keyer enabling, command-click to open the Voice Messages 
Editor. The Radio 2 voice keyer status button is disabled unless the operating mode is 2T2R. 
Sending with the DVR is the default when the Voice Keyer is not enabled. 

Voice Messages Editor 

Window > Editors > Voice Messages Editor opens the editor for changing the current  log's voice 
messages. The menu item is hidden when the Voice Keyer is not enabled. The items in the  Radio 2 
tab are disabled unless the Operating Mode is 2T2R. Use the Voice Messages tab in New Log 
settings to define default messages for new logs. 

 The two Use radio DVR radio buttons select either the existing radio DVR scheme or the Voice 
Keyer.  

The Output Device chooser is currently disabled because Apple does not allow applications to 
redirect Personal Voice audio. The default output goes to the Output selected in System Sound 
preferences. 

The Voice choosers lists all of your available Personal Voices. 
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Preparing to Use Personal Voice 

 See this support article, for details 
about creating and naming Apple 
Personal Voices. You will need to 
begin in the Personal Voice system 
setting panel, found in the Sound 
group of Accessibility settings. 

Click the info icon to rename the 
voice. 

You must enable “Allow applications 
to use your Personal Voice”. 
Optionally, also enable “Share across 
devices” to use your voices on other 
computers or iOS devices via iCloud 
using you Apple ID. There is no simple 
way to manually transfer voices between devices.  

SkookumLogger will ask permission to use personal voices when it next begins running. If you 
choose Allow, the application icon will show up in the Personal Voice panel the next time you open 
the panel. 

Use the Output & Input group in Sound 
system preferences to choose where voice 
messages output by SkookumLogger will go. 
In the example, messages will play to the 
computer speakers. The Output list will 
include all items that can accept audio, 
including audio codecs built into radios or 
SO2R devices attached to a USB port. You 
may need to mute system sounds that also 
play to the selected output device. 

Voice Message Syntax 

Voice message definitions have a special notation, in addition to the message tokens you know 
and love for CW messages. When you surround text or a token with brackets, the Voice Keyer 
speaks the message character-by-character using phonetics. For example, the sent call token 
without brackets says “K1GQ”, while [~] says “Kilo One Golf Quebec”. Additional notes and advice: 

✦ Callsign type-ahead is not available; type the complete call before trigging a message that 
includes the * token. 

✦ Trick: text followed by a comma, semicolon, colon or period+space, followed by more text, 
adds a delay in the spoken text. The duration of the space is shortest for a comma, longest for a 
period. Do not use these punctuation characters inside square brackets.  
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✦ Do not nest brackets. 

✦ Question mark affects the pronunciation of the preceding word. 

✦ Fussing with the spelling of phonetics can be useful. For example, to change which syllable is 
emphasized in ‘Quebec’ use ‘Cuebec’, or use ‘Keylow’ to slightly stretch ‘Kilo’.. 

✦ Spaces preceding left bracket are ignored. 

✦ /M in a callsign is phoneticized as ‘Mobile’. 

✦ /MM is phoneticized as ‘Maritime Mobile’. 

✦ /P is phoneticized as ‘Portable’. 

✦ Otherwise '/' and the remaining text are phoneticized. 

✦ Magic Message works with these limitations: 

✦ The content for a message is taken from in the CW Messages Editor. 

✦ The content can be only references to voice messages 1 through 9, no other text. 

Voice Message Properties 

Each of the 16 basic messages has, in addition the message definition, a choice for the personal 
voice and settings for Pitch multiplier and Rate. The table at the top right in the window shows 
which properties will be used for compound messages. For example BeginQSO (Run) uses the 
properties for the His Call message. These properties provide options for tailoring things like the  
“urgency” of you voice messages. Pitch Multiplier can be changed between 0.5 and 2 with default 
1. Rate can be change between 0 and 1 with default 0.5. 

Phonetics 

The fields in the Phonetics box supply the words that are synthesized when speaking characters. 
You can customize these, typically to overcome intelligibility problems. For example, you might 
change the phonetic for 2 from Two to Tu-oo. The checkboxes below the digit phonetics disable 
custom phonetics for numbers. 

Known Issues 

✦ Radio 2 tab item enabling doesn't notice changes in operating mode. 

✦ Command-clicking a Voice Keyer status button should select the editor radio tab 
corresponding to the button. 

✦ QTC messages have not been tested for WAE In Europe. 

✦ Not all radios support PTT via CAT. 

Voice Messages for QTCs 

Use the new QTC(SSB) tab in Messages settings to set messages for exchanging QTCs in the 
WAEDC contest. 
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Data Messages 
SkookumLogger can send stored messages via your radio‘s text encoder for FSK or PSK modes. 
Choose Window > Editors > Data Messages Editor to open a window for customizing the 
messages. 

Data (FSK/PSK) messages are similar to CW messages. The primary difference is an addition token 
(}) for inserting CR and LF characters in order to start a new line in the receiver’s display. Also, 
SkookumLogger does not automatically insert 599 when sending the exchange (& token) so that 
you can choose how many times to repeat the signal report. 

Magic Message 
The concept behind this feature is that you press the same key to send messages while completing 
a QSO, and SkookumLogger magically determines which messages to send. This behavior is 
popularly known as Enter Sends Message (ESM), where “Enter” refers to the return key (↩︎) on 
Apple keyboards.  

There are two versions of the decision logic. You choose which version is active using Magic 
Message Protocol Version in Messages Settings. When version 1 is selected, the hot key for 
sending is defined by Magic Message V1 in the Special Keys tab of Messages Settings. When 
version 2 is active, the hot key is the return key, as well as the enter key on extended keyboards. For 
version 2, the shortcut for Log > Log QSO is changed from ↩︎ to ⌃↩︎. When version 2 is active, the 
version 1 hot key has no effect. Hot keys have no effect when no QSO entry fields has keyboard 
focus. 

Note: When the version choice is Off, neither of the hot keys are active. This state enables a subtle 
behavior while entering QSO information: If you enter a call, enter the received exchange, erase 
the received exchange, toggle back to the call field and possibly edit the call, then tap tab or 
spacebar, the exchange will be prefilled. That pre-fill does not happen when Magic Message is on. 

Magic Message Version 1 
Version 1, designed by GØDVJ, offers the flexibility to use a variety of keys for triggering Magic 
Message, see Special Keys. GØDVJ uses the key below the escape key at the top left corner of the 
keyboard, easy to locate without looking and conveniently adjacent to the Abort key. Tapping the 
hot key transmits one of three messages for each of the Run and Pounce operating modes, 
depending on the operating mode when you first trigger Magic Message. You define defaults for 
the six messages and set the decision logic version in the CW Messages tab of New Logs settings. 
Choose Window >Editors > Morse Messages Editor  to customize the messages for an existing 
log. 

When Run has keyboard focus: 

✦ If necessary, change transmit focus to Run. 

✦ If the Run call entry field is empty, transmit the Run Begin (CQ) message.  

✦ Otherwise if your exchange has not been sent, transmit the Run Continue (his call and your 
exchange) message.  
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✦ Otherwise transmit the Run End (typically acknowledge) message and log the QSO. 

When Pounce has keyboard focus: 

✦ If the Pounce call field is empty and CQ changes focus to Run is on ( Messages settings), clear 
all Pounce entry fields, change transmit focus and keyboard focus to Run, and start the logic 
above.  

✦ Otherwise if the call entry field has keyboard focus, transmit the Pounce Begin (your call) 
message.  

✦ Otherwise if your exchange has not been sent, transmit the Pounce Continue (exchange) 
message.  

✦ Otherwise transmit the Pounce End message and log the QSO. 

Magic Message Version 2 

Version 2 uses the return key (↩︎) as the trigger, also known as “Enter Sends Message” (ESM). The 
logic for which message is sent is similar to that in the Windows DxLog contest logger. The logic 
depends on whether SkookumLogger is in Run or Pounce mode. 

Normally, the return keys logs a QSO whether or not it is valid. When version 2 is active, use 
control-return (⌃↩︎) to do that. 

If none of the QSO entry field are focused when return is tapped, nothing happens.  

You can send any message at any time without confusing the Version 2 logic, which doesn't 
depend on remembering the sequence of previous messages. 

The definitions for these six messages are used: 

✦ F1 CQ 

✦ F2 Exchange 

✦ F3 Acknowledge 

✦ F4 My Call 

✦ F5 His Call 

✦ F7 ? (Again) 

Run Mode Behavior 

When return is tapped in Run mode: 

✦ If the Call field is focused and empty, send the CQ message. If a CQ repeat mode was paused, 
also resume the mode.  

✦ If the Call field is focused and not empty, send the His Call and Exchange messages. 

✦ If the Call field is not focused: 

❖ If all other entry fields have valid content, log the QSO and send the Acknowledge message. 

Version 5.4	 Page 92



SkookumLogger Guide

❖ Otherwise, send the Again message. 

Run Mode Usage 

When you get a response to a CQ, enter the call and tap return to start sending His Call and 
Exchange. When you have entered the complete call, tap spacebar to move focus to the next entry 
field. You can start sending His Call before entering all of the call as long as you stay one character 
ahead of the His Call message (this is 'type-ahead'). 

Hint: Enable the Typing stops CQ option in Messages setting to pause repeat CQing. 

Fill in each of the remaining QSO entry fields. When ready, tap return. If any of the fields is invalid 
the Again message should stimulate the caller to repeat his exchange so you can correct the 
invalid field(s). Use the spacebar, tab, or shift-tab to navigate focus to an invalid field. Tap return to 
try again to log the QSO and send Acknowledge. If you edited the Call, move focus out of that field 
before tapping return.  

Hint: Enable the Correct mode option in Messages settings to send an edited call before the 
Acknowledge message. 

Pounce Mode Behavior 

When return is tapped in Pounce mode: 

✦ If the Call field is focused, send the My Call message. 

✦ If the Call field is not focused: 

❖ If all other entry fields have valid content, send the Exchange message and log the QSO. 

❖ Otherwise send the Again message. 

Pounce Mode Usage 

When the target station responds to your call, navigate to each of the other entry fields, enter the 
information, then tap return. If any of the fields is invalid the Again message should stimulate the 
caller to repeat his exchange so you can correct the invalid field(s). Once all fields are valid, 
tapping return logs the QSO without sending any message. 

Invalid Entry Fields 

SkookumLogger has rules for each kind of QSO entry field that ignore or convert illegal characters 
as you type them. For example, a serial number field can contain only digits; the rules convert 
AENTO letters to digits. With that feature, most kinds of entry fields are invalid only if they are 
empty. 

Fields other than Call may be pre-filled as you enter a call, so you don't need to fill in those fields 
yourself unless there is an empty field or the pre-filled value is wrong. 

Hint: Turn off Position cursor at end of entry field in Logging settings to select pre-filled content 
when you navigate into an entry field. Then whatever you type replaces the pre-filled value instead 
of appending to the end of the value. 
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If you want to log a QSO without correcting all invalid fields, tap control-return. The QSO will be 
marked SQ. You can then use Log > Correct Last QSO to change missing or incorrect information, 
or edit in the log table later on. 

Serial Numbers 

When your sent exchange includes a serial number, the Sent Exchange Prompt shows the serial 
number to send. The prompt applies for the QSO entry pane that has keyboard focus in 2T2R, and 
otherwise for the pane that has transmit focus (indicated by the red gumdrop). 

The prompt shows the serial number that will 
become part of the logged QSO. When you 
send a CW or Data message that includes the 
sent exchange, the serial number will be 
inserted for you. For SSB, you must say the 
serial number yourself.  

A serial number is reserved as soon as you 
send it. The reserved serial number for each 
QSO entry pane is shown next to right of the 
the call field, 21 in the example. When you use Log > Clear Focused QSO Entry to abandon a QSO, 
the reserved serial number will be returned to the serial number pool unless a serial number after 
it has been used.  

Sometimes you need to resend a serial after you have logged a QSO. The serial numbers for the 
most-recently-logged Run and Pounce QSOs are shown beneath the keyer speeds at the right 
edge of the QSO entry boxes 19 and 20 in the example, with the number for the pane with 
transmit focus colored red. 

If you send the Exchange message or the Repeat Serial Number Message while the call field is 
empty, SkookumLogger uses the red serial number instead of the prompt value. When the sent 
exchange doesn’t include a serial number, the Repeat Serial Number Message sends the number 
of QSOs you have logged. 

All of this complexity reduces the chances that the serial in a logged QSO will differ from the serial 
that was sent. If you manually send a serial number that is different from the serial number that was 
logged, you should edit the Sent Serial field in the logged QSO to correct the number to what was 
actually sent. Otherwise, the station you worked will be penalized, and in some contests you will 
also be penalized. 

Correct Mode 
In correct mode, when about to log a QSO, SkookumLogger tests wether or not the call field 
matches what was sent as part of a CW message. If not, SkookumLogger adds the call to the 
acknowledge message. The mode is enabled by the  Correct mode  option in Messages setting. 
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Keyboard Mode 
Keyboard mode (also known as Immediate Morse mode) is available when the mode of the radio 
with transmit focus is CW, FSK, or PSK. In the CW case, the keyboard icon appears, and you choose 
the command again to exit the mode. In the FSK or PSK case, keyboard focus is transferred to the 
text entry field at the bottom of the  Text Decode/Encode window. 

In keyboard mode for CW, everything you type while any QSO entry field has keyboard focus is 
diverted directly to your keyer and transmitted immediately. The content of the entry field is not 
changed. 

Note: The Special Keys pane in Messages settings has an Ignore Special Keys in Immediate Morse 
mode option. Use this to prevent special key definitions from interfering with keyboard morse 
entry.  

In data mode, nothing is transmitted as you type into the text field until you type return. Then, the 
entire content of the field is transmitted and keyboard focus is transferred back to the Log window. 

You should use a keyboard shortcut for this command, the default is ⌘K. The caps lock key is ideal 
for this, but cannot be assigned as a shortcut except via Keyboard Maestro. 

Call Stacking 
Call stacking is an advanced CW feature that supports entering more than one call at a time into a 
call field, separated by commas. The first call in the list is the “active” call, used by SkookumLogger 
for tasks like duplicate testing and partials matching. Logging a QSO or clearing a QSO entry field 
promotes the next entry in the list to be the active call and sends the Unstack QSO message. 

This feature helps you chain QSOs when you are able to copy multiple callers answering your CQ. 
The default definition for Unstack QSO is “R NW * &”. Use call stacking as follows with keyboard 
focus and transmit focus in the Run QSO Entry pane: 

• Type a call followed by a comma and another call.  

• When the first caller stops transmitting, send His Call + Exchange. While the message is 
transmitting, you can edit his call or the call after the comma call as needed.  

• When you have finished entering the received information for the first caller, 
send Acknowledge + Log. The QSO with the first caller is logged, the call and trailing comma 
is erased, and the Unstack QSO message is sent, substituting the newly-active call for the 
received call token.  

• When you have finished entering the received information for the newly-active caller, 
send Acknowledge + Log again to log the newly-active caller and possibly proceed to the 
next stacked call as above.  

Call stacking also works with the Begin QSO message in place of the  His Call + Exchange 
 message and the End QSO message in place of the Acknowledge + Log message, and with  
Magic Message V1. 
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Matching a Caller’s CW Speed 
When you pounce on a CW station who is CQ-ing much slower than you are, you might want to 
temporarily match his speed for that QSO. SkookumLogger provides for this through Messages > 
Morse > Set Pounce WPM, which searches the current band’s activity table for a match to the call in 
the Pounce call entry field. If a match is found and the activity specifies WPM in the Info column, 
your WinKeyer is temporarily set to that speed. The original speed is restored when you change 
transmit focus. 

Set Pounce WPM is hidden in 2T2R and disabled unless Pounce has transmit focus. The temporary 
override of Pounce WPM does not affect the displayed WPM.  

To use this feature, first assign a shortcut to the menu item (see Defining shortcuts). Then grab an 
activity table and press the shortcut key before calling the station.  

Hint: GØDVJ assigns the shortcut ⌥- (option-minus) to this menu item. That shortcut may not work 
when macOS interprets it as meaning “type an ’n-dash’. In that case, control-minus should work. 

Version 5.4	 Page 96



SkookumLogger Guide

QSO Parties 
The general theme for a United States State QSO Party divides participants into two groups. One 
group is stations inside a state or several adjacent states, and the other group are the outside 
stations. Competition is between stations within the same group. 

Stations in the outside group get QSO points only for working stations in the inside group. The 
inside stations send an exchange with a component that identifies their location — typically a 
county or state-county code. The same station can be worked once for each different code. A 
station which changes locations during the contest is termed a rover. 

Stations in the inside group get QSO points for everyone they work. Rovers in the inside group 
may work the same station once for each different location code that they send. 

Some QSO parties allow county-line straddling, where an inside station is located on one (or more) 
county borders. In that case, a single “real” QSO includes more than one location code in the 
exchange, resulting in separate QSOs in the log for each of those codes, for each side of the QSO. 

Identifying QSO Party Multipliers 
SkookumLogger distinguishes needed QSOs and needed multipliers using fonts and colors that 
you define. In QSO parties, SkookumLogger cannot always determine needed status from the call 
alone; it needs to know whether or not the call is an inside station, and if so it needs to know the 
location (e.g. county). When SkookumLogger cannot determine that a potential QSO is either 
certainly needed or certainly not needed, the needed status is May Be Multiplier. 

Discovering Rovers 
A rover is a station that changes location during a contest. You can work a rover multiple times 
without the QSOs being dupes, as long the locations are different. 

How do you know when a station is a rover? You don’t know for sure until you hear the station send 
a location code different from what you heard before. Some clues that a station might be a rover: 

✦ The call ends in /m 

✦ The call is in a list of rovers (AKA mobiles) at the contest sponsor’s web site 

✦ The call ends in /<location code> (you should not enter that suffix in the call field) 

✦ The call is known to you to be a rover; e.g, WA1Z 

Being a Rover 
If you are operating as a rover, use the same log throughout the contest. When you change 
locations, change your sent exchange in the Sent Exchange Editor. If you are straddling a county 
boundary, enter the codes separated by a slash. 

It is common practice to append your county after your call when CQing. To do this without 
changing your CQ message every time you change counties, set the CQ message in the Morse 
Messages Editor to something like this: 

CQ NEQP ~ & 
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The ~ token expands to your contest call, followed by a space, followed by your sent exchange 
(county code). Use a space instead of a /, because, for example, some software will treat the call 
and location together as your call.  

Working Straddlers 
An inside station straddling a country boundary will send two (or more) location codes. Type the 
codes into the QSO entry field separated by a forward slash. When you log the QSO, 
SkookumLogger creates separate log table entries for each location. 

Yes, when both ends of one real QSO are straddlers, the result is four QSOs in the log. Hey, I don’t 
make the rules. 

Operating in Concurrent QSO Parties  
Set up your log for the QSO Party that you want SkookumLogger to score for you. Log whatever the 
other station sends for their location, whether or not it is a location that your selected log type 
expects. For example, in NEQP Inside, when you work N7XU and he sends ORDES, log that; 
SkookumLogger will figure out that you just worked OR, the state code expected by NEQP Inside 
rules. After the contest, export your Cabrillo file and send it to the sponsors of each of the 
concurrent contests; the sponsor will score your log appropriately and not penalize you for zero-
point QSOs. 

Inside/Outside Status Logic 
SkookumLogger has a list of the acceptable location codes for each QSO party that it supports. If 
the content of Info field for a candidate QSO matches an entry in that list, then the candidate QSO 
is known be be Inside. 

Otherwise, if your in-memory exchange database (which includes logged QSOs) has a record for 
the call of the candidate QSO, and that record has a US state code field, then if the value of that 
field matches the state code associated with the location codes, the candidate QSO is known to be 
Inside, otherwise it is known to be Outside. 

Otherwise, if the DXCC code for the candidate call isn’t the same as the QSO party inside DXCC 
code, the candidate QSO is known to be Outside. For example, the DXCC code must be KH6 for 
the Hawaii QSO Party. 

Otherwise, if the Countries database specifies possible state codes for the candidate call and none 
of them match the state code associated with the location codes, the candidate QSO is known to 
be Outside. 

Otherwise, the Inside/Outside status is not known. 

Needed QSO Status Logic 
SkookumLogger computes a hash for a candidate QSO as described below, and looks for a match 
in a set of hashes for logged QSOs. If a match is found, the candidate would be a duplicate. 

The hash is a string with components of the hash depending on the contest rules. The format for 
QSO parties is: 
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<received call><band><mode><sent location>_<received location> 

The <band> component is omitted when QSOs are not per-band. The <mode> component is 
omitted when QSOs are not per-mode. This can have trouble identifying duplicates for county-line 
straddlers before they are logged 

When you type a call that is already in the log, SkookumLogger pre-fills the location field from the 
previous QSO. However, setting the rover flag prevents pre-filling the location field in Outside QSO 
Parties, to prevent rovers being as duplicates you enter the (county) location. 
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QTC Series  
The Worked All Europe DX Contest (WAEDC) has a unique feature termed QTCs that involves a 
complex set of rules for increasing your score by sending or receiving information about previous 
QSOs during the contest. Entrants outside Europe may send QTCs only to entrants inside Europe, 
so logging software support depends on whether you are inside Europe (receiving QTCs) or 
outside Europe (sending QTCs). The components of a QTC series are the QTC series number, the 
count of QTCs in the series, and the fields of each QTC (derived from a prior QSO made by the 
sender of the series): time, call, and received serial. The series number and count are expressed as 
a pair separated by a forward-slash; for example, 21/10. Time is expressed as two hour digits 
concatenated with two minute digits; for example 0123. 

There are some intricate details: 

• The maximum number of QTCs that a sender may transmit to a particular receiving entrant is 
10. They may be distributed across as many as ten separate QTC series. 

• A QSO with a receiver may not be sent to that receiver as a QTC. 

• A QSO may be sent only once as a QTC. 

• The exchange of a QTC series does not count as a contest QSO unless serial numbers are 
exchanged in the normal fashion. In that case, normal duplicate rules apply. It is not required 
to log a contact made for the sole purpose of exchanging QTCs; that information is 
embedded in the QTC series records. 

The Activity > Call Refused QTC command adds the call in the active QSO entry pane to a list of 
calls that have refused when you asked to exchange QTCs. Calls in that list appear in Activity tables 
flagged with the prohibited emoji: 🚫 . The command is hidden except for the WAEDC contest. The 
list is emptied when you start SkookumLogger, reset the log, or change to a different log.  If you are 
operating in unassisted mode and would normally have your Activity window closed, in WAEDC 
you may wish to keep the that window open (but disconnected from any external spotting sources) 
for quick reference. 

The prohibited symbol is also displayed for activities (calls in the Activity tables) that have already 
exchanged 10 QTCs with you. Otherwise, if the call can exchange QTCs with you, the activity is 
flagged with the sharp character: #. This condition is true if the mode for the activity matches the 
log‘s mode and either you or the activity is in Europe and the other is not. 
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QTC Series Window 

SkookumLogger supports both sending and receiving QTC series with a special window, opened 
via Window > QTC Series. This menu item is disabled when the log’s contest type isn’t WAEDC. 
You should keep the QTC Series window open during the contest. The status line at the top of the 
window updates each time you change the content of the current call entry field, showing 
important information about potential QTCs for that station. 

When the QTC Series window is active, SkookumLogger changes the commands associated with 
some function keys. In CW mode, there are many WAEDC-specific QTC messages that can be 
customized. Keyboard Mode is available when the QTC Series window is active, but only when no 
table cell is selected for editing. 

The Delete Series button is always enabled, it removes the selected QTC series from your log, 
resets the sent-as-QTC flags for the associated QSOs and returns keyboard focus to the Log 
window. You might want to delete a series if it wasn't properly completed. 

Sending QTCs 
As you type call signs into the Log window, the status line at the top of the QTC Series window 
shows whether or not that call can receive QTCs. To respond to a QTC? request, make the QTC 
Series window active using the Log > Begin QTC Series keyboard shortcut, which causes 
SkookumLogger to perform one of three actions: 

✦ If transmitting a QTC series is already underway, return keyboard focus to the QTC Series 
window. 
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✦ Otherwise, if the receiving station is not eligible to receive QTCs, transmit the I have no QTCs 
message and return keyboard focus to the Log window. 

✦ Otherwise, create a new series and transmit the Begin Series message followed by “N/C”, where 
N is the series number and C is the count of QTCs about to be sent. The receiving station 
should indicate ready to receive, typically by sending QRV. If the receiver asks for a repeat of 
the series preamble message, choose Repeat N/C (F3). 

Alternatively, use the Log > His Call + Begin QTC Series keyboard shortcut to prepend the 
receiver’s call to the messages sent above. Neither of these messages is sent if a series is already 
underway when you activate the QTC Series window. 

When a new series is created, all of the QTC Series table items are filled in for you, the QTCs for 
Selected Series table is filled with information from your log, and the first row in that table is 
selected. 

Choose Next QTC (F8) to send the selected row. SkookumLogger indicates that the QTC for a row 
has been sent using your Worked Before font. If the radio mode is CW, SkookumLogger also sends 
the three items in the selected row as a Morse message. The selected row is automatically 
advanced appropriately until you reach the end of the table. Continue choosing Next QTC until all 
rows have been sent, then choose End Series (F9). 

The Repeat buttons are convenience commands for sending fills for parts of CW QTCs. They apply 
to the QTC of the selected row in the QTCs for Selected Series table. You can change the selected 
row after sending all QTCs using the up and down arrow keys. You also can resend all of a 
particular QTC using the buttons showing the row labels. The shortcuts for these buttons are ⌘n, 
where n is the QTC number (use 0 for QTC 10). Note that these shortcuts apply only when the QTC 
Series window is active. 

Once you have started a new series, you can finish at any time by choosing End Series, even if the 
number of QTCs indicated by the count has not been transferred. If you are in run mode, End 
Series also sends the End Series message.  

Receiving QTCs 
The QTC Series window has two tables labeled QTC Series and QTCs for Selected Series. The 
following discussion refers to these tables as the series table and the QTCs table, respectively. 
SkookumLogger extends standard tab key behavior in the two tables to facilitate data entry when 
receiving a QTC series: 

✦ When a cell in the series table is selected, tab selects the cell in the column on the right in the 
same row unless the current column is Count; in that case tab selects the Time cell for the first 
row in the QTCs table. Shift-tab selects the cell in the column on the left in the same row unless 
the current column is Sender; in that case shift-tab selects the cell of the Count column in the 
same row. 

✦ When a cell in the QTCs table is selected, tab or spacebar selects the cell of the column on the 
right in the same row unless the current column is Serial (#); in that case, if there is a next row 
then tab transmits the Acknowledge QTC message and selects the Time cell in the next row. 
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Otherwise, tab deselects all table cells. Shift-tab selects the cell of the column on the left in the 
same row unless the current column is Time; in that case shift-tab selects the cell in the Serial 
column of the same row. 

When you type a call in the Log window, the status line at the top of the QTC Series window shows 
whether or not you can receive QTCs from that station. To ask for a QTC, choose Log > Begin QTC 
Series. If you were already receiving a QTC series, SkookumLogger simply changes keyboard focus 
to the QTC Series window. Otherwise, in the normal case, SkookumLogger adds a new series to 
the QTC Series table, fills in the Sender call, sets the series number to 0, sets the series count to the 
number of QTCs that the sender may send to you, and transmits the Do you have QTCs? message. 
If the sender responds no, choose End Series (F9); SkookumLogger will delete the new series and 
change focus back to the Log window. If the sender responds by asking for your call, choose My 
Call (F4). 

When the sender responds by transmitting his QTC number/count, the steps in receiving a series 
proceed as follows: 

✦ Type the series number, press tab to select the Count cell. 

✦ Type the count, press tab to transmit the Ready to receive message and select the first QTC 
Time cell. 

✦ Type four digits, press tab to select the Call cell. 

✦ Type the call, press tab to select the Serial cell. 

✦ Type the serial, press tab to transmit the Acknowledge QTC message and select the Time cell 
for the next QTC. 

✦ Repeat entry of QTC information using the three steps above until you have filled all of the QTC 
table rows. 

✦ Choose End Series to transmit the Acknowledge Series message and return keyboard focus to 
the Log window. 

If the sender transmits only two time digits, SkookumLogger will prepend the hour digits from the 
previous QTC when you tab out of the Time field. Typing anything other than a digit into the the 
Time or Serial cells is ignored, except for A, E, N, or T which are converted to 1, 5, 9 and 0 
respectively. 

You should try to have the QTC for the current row completely filled in before you press tab in the 
Serial column. You can use the four Repeat buttons below the table to transmit CW messages 
asking for fills. To change keyboard focus to an incomplete cell: 

✦ Press shift-tab to select the cell to the left of the current cell. If the current cell is in the Time 
column, then the cell in the Serial column of the same row is selected. 

✦ Or, double-click on the cell to be edited. 

✦ Or, use the keyboard shortcut for the QTCs table row button (⌘n) to select the Time cell in nth 
row, then tab to the cell to be filled. 
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Text Decoding and Encoding 
Some radios have decoders that convert 
signals into text and encoders that convert text 
into signals, for CW, FSK and PSK modes. 
Window > Text Decode/Encode displays 
decoded text in a resizable window. You must 
enable text decoding in you radio in order for 
this window to display any content. The 
window also has a text entry field for input to 
the radio text encoder. 

 
 
Using Decoded Text 
The Grab feature allows you to copy selected words in the decoded text to QSO Entry fields: 

✦ Set keyboard focus to the QSO Entry Pane field you want to fill 

✦  Select the received text that you want to copy and tap the Grab button 

Alternatively, double-clicking on a word copies it to the call field of the QSO entry pane with 
keyboard focus. 

Note: For some radios, received text that contains a semicolon is truncated at the location of the 
semicolon. 

Note: Morse Keyboard mode cannot use the CW encoder. 

Sending Text 

✦ Use Log > Send Data Message to quickly transfer keyboard focus to the Sent Text entry field. 

✦ Type arbitrary text into the entry field. 

✦ Tap Send to transmit the text. 

❖ Keyboard focus is immediately transferred back the to Log window. 

❖ The transmitted text is added to the decode text pane, colored red. 

Note: Some radio encoders limit the length of the text.  

Sending Stored Messages 
If the radio mode is FSK or PSK: 

✦ Use the Data Messages Editor to define message text. 

✦ Use Messages menu items to send messages. 

If the radio mode is CW: 

✦ Ensure that the Text Encode/Decode window is open. 
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✦ Ensure that no external morse keyer is enabled. 

✦ Use the Morse Messages Editor to define message text. 

✦ Use the Messages menu items to send messages. 

Note: Call type-ahead is not available with the CW encoder. 

Note: CW sending speed is controlled by the radio. 
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Practice Mode 2 
The original practice mode implementation has been entirely redone to improve 
performance, capability, and maintainability. The new version is solid, but still being 
enhanced and documented in detail. Feedback of any sort is invited. 

Practice mode simulates operating in a CW contest, using SkookumLogger just as you would on 
the air. The simulation creates two kinds of stations that send and receive CW messages, called 
runners and pouncers. These stations come and go and work each other during a simulation 
sessions. You hear CW from these "simulated" stations through your Mac’s audio output. 

One (1T1R and 1T2R) or two (2T2R) "user" stations are controlled by you. You determine whether a 
user station is a runner or a pouncer by which QSO Entry Box has transmit focus (or the radio 
submode for 2T2R). You determine the frequency for a user station just as you would on the air. As 
you tune across the lower 50 kHz of a band, you hear runners working pouncers and, if your user 
station is a pouncer you can work those runners. When your user station is a runner, pouncers will 
find you and call. You send CW messages just as you would during a real contest. 

When a simulated station is created, a call, a CQ response message and an exchange message are 
defined for that station. The call is chosen randomly from a subset of the SCP database, which 
typically has more than 40000 calls. The subset is based on contest rules, for example, mostly US 
and Canadian calls for QSO Parties. The CQ response is normally just the call; about 10% of the 
time it is the call repeated twice. Each simulated station will provide consistent exchange values 
(Example: if you hear a station send a serial number, their next exchange will contain serial number 
+ 1). The exchange message is specific for these support CW contests: 

✦ Any contest with CQ or ITU zone alone as the exchange 

✦ Any Inside and Outside QSO Party except Maine and QRP-ARCI 

✦ All Asian DX Contest  

✦ ARRL International DX Contest  

✦ ARRL and Winter Field Day 

✦ ARRL Sweepstakes 

✦ CQ World Wide WPX Contest 

✦ European HF Championship 

✦ Generic Serial Number Contest 

✦ IARU HF Championship 

✦ Medium Speed Test 

✦ North American QSO Party 

✦ Russian DX Contest 

✦ Worked All Europe DX Contest 
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✦ World Radiosport Team Championship  

Practice mode doesn’t require a WinKeyer, although if you have one connected you can control 
your transmit sending speed with the SPEED knob on the WinKeyer. 
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Settings 
Choose Window > 
Practice to open the 
practice mode 
options. Click the Start 
button to begin a 
simulation session. 
When the session 
cannot be started, an 
alert window will 
explain why. 
Otherwise, the button 
title changes to Stop. 

Allow logging 
incomplete QSOs 
overrides your setting 
for the Refuse to log 
incomplete QSOs 
option in Logging 
settings. 

Disable After turns off 
practice mode after you have logged the specified number of QSOs with no errors. Subtract that 
number from the number of QSOs in the log to determine how many bad QSOs you logged. 
Setting the value to 0 disables this feature. 

User Station properties affect what simulated stations you hear you hear when running, and your 
transmit monitor. 

Maximum Callers limits the number of pouncers calling you. The number for a particular 
pouncer is chosen randomly between 0 and this limit. After the first CQ by a user station in 
runner mode, the number of pouncers for that station is between 1 and the limit after each 
QSO is logged. 

Variable Number of Callers randomly chooses the number of your callers, between 0 and 
Maximum Callers, after each of your QSOs. When turned off, the number of callers starts at 
Maximum Callers, decreases one at a time as you log QSOs, and resets when you have worked 
the set of original callers. 

Soft Receive Bandpass replaces the default brickwall receive filter with a more realistic CW 
audio bandpass filter. 

QSK enables simulation of receive audio (simulated stations and noise) heard between 
characters in your messages, with Tail affecting how much you hear. When off, receive audio is 
muted during your message sending. 
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Monitor Amplitude and Monitor Pitch affect the audio tone you hear when sending messages, 
separately for each user station. The range of amplitudes is 0% to 100%. The range of pitches 
is 300 Hz to 900 Hz. 

Propagation Model affects the character of the audio to simulate HF propagation. 

Noise Amplitude and Noise Bandwidth simulate receiver noise. 

The popup button lists several standard HF path models, 
based on the W7AY CocoaPath app. Perfect bypasses all 
models. The ITU models depend on the latitude at the 
midpoint between you the other station, and are most 
realistic for world-wide contests. The CCIR and Flutter 
models are appropriate for more specific types of 
propagation effects. 

Perfect within bypasses the propagation model for relatively 
close stations. 

Simulated Stations properties apply to simulated (i.e., non-user) 
stations. 

Number of Runners per Band specifies the number of 
simulated stations that are running on a given band. The bands which are populated 
correspond directly to the band(s) of the user station(s). 

Number of Pouncers per Band specifies the number of stations that are scanning looking for 
runners to call on each band. The bands which are populated correspond directly to the 
band(s) of the user station(s). 

Runner QSOs before QRT specifies the maximum number of QSOs a simulated runner will 
complete before disappearing (replaced by another simulated runner on the same band, but 
likely a different frequency). 

Allow Lid Pouncers enables simulation of various kinds of lid-like behavior, including 
sending ?,  NR? or AGAIN? when they should send their exchange.  

Query Probability sets the likelihood of a pouncer requesting information that has already 
been sent. 

Query Maximum Count determines how many times a pouncer will annoy you like that. 

Speed applies to all simulated stations. The speed for a particular runner or pouncer is 
randomly set within Spread of the Center speed. 

Amplitude applies to all simulated stations. The amplitude for a particular runner or pouncer is 
randomly set within Spread of the Center amplitude, and is also affected by the Propagation 
Model. 
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Practice Behavior 
The practice processor has rather intricate rules for what to do when a user station is a runner or a 
pouncer. The goal is to behave just as would be the case on the air. The best way to to learn what 
to expect is to experiment. In either case, you can tune your radio to hear stations at different 
pitches and move them into or out of the passband. 

When you log a QSO, diagnostic information about the QSO appear in the Notes field. 

User Station Runner Behavior 

Abort (escape key) — Stop transmitting immediately. No callers will call until after you transmit CQ 
or Again. 

CQ (F1 or any message with CQ in the title) — Transmit the CQ message and prepare for the 
ensuing pileup. 

Exchange (F2) — Transmit the user station's exchange and listen to the exchange message for the 
caller with call exactly matching the call in the Run call entry field. 

Acknowledge (F3) — Transmit an acknowledge message and begin listening for additional callers in 
the pileup. 

MyCall (F4) — No action. 

HisCall (F5 or any message with the received call token as the first character) — Transmit the first 
character in the call. When transmission ends, send the next character. Repeat until there are no 
more characters. Then, begin listening to responses of callers with calls similar to what you just 
sent. 

Again (Any message containing ? in the title) — If the previous transmitted message was Exchange, 
perform the processing for Exchange, above. Otherwise, begin listening to the CQ response 
messages for all callers in the pileup. 

Defend — Transmit a defend message. If there is a simulated runner on the frequency, they will 
immediately stop any QSO in progress and move to another frequency. 

User (Any user message not usurped by the above rules) — No action. 

His Call + Exchange, Begin QSO — Transmit the first character in the call. When transmission ends, 
send the next character. Repeat until there are no more characters. Then send the Exchange 
message, resulting in the action described for that message. 

Log QSO (return key) — Compare the information in the logged QSO with the information for the 
caller with call exactly matching the content of the Run call field from the pileup. List errors in the 
Notes field for the QSO. The caller will then move on to another frequency. If Variable Number of 
Callers is not enabled, and this was the last caller, new simulated pouncers will move to your 
frequency to attempt to reach Maximum Callers. 

Short Acknowledge + Log QSO, His Call + Acknowledge + Log QSO, Exchange + Log QSO, 
Acknowledge + Log QSO, End QSO — Perform the Log QSO action, then begin listening to the CQ 
response messages for all callers in the pileup. 

Version 5.4	 Page 110



SkookumLogger Guide

User Station Pouncer Behavior 

Practice mode creates several pounce pileups on whatever band(s) the user station is on. You find a 
pounce pileup by, wait for it, tuning your receiver. If you change the radio band, pileups will appear 
on the new band. If you're practicing assisted, simulated runners can be viewed by opening an 
Activity window for the band you're on. 

To work the runner in a pounce pileup, send BeginQSO, MyCall, or MagicPounceBegin after the 
runner ends his CQ or Ack. The caller will answer you rather than other callers most of the time. 
Sometimes the runner will send ? or nothing at all and you will need to try again. If QSK is enabled, 
you may hear other callers. Use EndQSO, Exchange, or MagicPounceContinue to respond when 
the runner sends you his exchange. A runner may use similar "again" tactics to get you to repeat 
your exchange. If not using EndQSO, use LogQSO (return) or MagicPounceEnd to log the QSO. 

Some runners do not send their own call very frequently, or perhaps not at all. Sending the query 
message (?) may cause these lid runners to send their CQ. 

The list of other callers updates after each QSO that the runner makes. A runner disappears after 
working Runner QSOs before QRT stations, and a new runner will appear on a different frequency. 

Practice Mode Hidden Settings 
Note: This is an advanced topic for macOS geeks. 

Practice mode has many settings that aren't accessible in the SkookumLogger user interface. If you 
are comfortable using a plist editor, the preference names and their roles and default values are 
documented here. 

The SkookumLogger preference file is ~/Library/Containers/com.k1gq.SkookumLogger/Data/
Library/Preferences/com.k1gq.SkookumLogger.plist. This file contains all of the SkookumLogger 
settings that you have changed from their defaults. 

Preference names are case-sensitive strings. Preference value types are Boolean, String, or Number. 
The default value is shown in parentheses following the name. 

Notes Field Annotation 

PracticeShowSentCallsigns (NO) 

This prints all call signs sent during a specific run QSO in the Notes field. The resulting list allows 
you to identify calls you sent incorrectly over the course of the QSO. 

PracticeShowSpeedAmplitudePitch (NO) 

This prints other information related to each QSO in the Notes field. 

✦ morse speed (wpm) 

✦ amplitude (%) 

✦ pitch (Hz) 

✦ time to complete the QSO (sec) 
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✦ which radio (1 or 2) 

✦ number of active callers 

✦ number of tapped BeginQSO key 

✦ number of tapped Call Again key 

✦ number of tapped Again key 

✦ number of tapped His Call key (or My Call for a pounce QSO) 

✦ number of tapped Exchange key 

✦ number of tapped other keys 

✦ "Run" if this QSO was made while running or "Pounce" if while pouncing 

Imperfectly Matched Callers 

When there is no perfect match to a call after sending your exchange, these settings affect which in 
the list of current callers will call again. 

PracticeMaxMatchedCallsign (NO) 

When enabled, the caller which has the most characters matched to the call sign field will call. 
Otherwise, the first one (not best match) in the callers list which includes any of characters will call. 
If no characters match, the (Levenshtein) shortest distance caller will call. 

PracticeMaxMatchedThreshold (3) 

This specifies the minimum number of characters that need to be matched when 
PracticeMaxMatchedCallsign is YES. 

PracticeCallAgainQueryProbability (80) 

After sending a call (or partial call), tapping the Again key will cause some callers to call again. 
Query Probability (%) specifies the fraction of callers who will call after hearing the Again message. 

PracticePouncerCorrectCallWithExchangeEnablePct (15) 

If a caller hears a callsign that almost matches their own, but then the runner also sends an 
exchange, the caller will reply to the exchange this percentage of the time. Typically the caller will 
prefix their exchange with a corrected call, but see 
PracticePouncerDoNotCorrectCallWithExchangePct. 

PracticePouncerDoNotCorrectCallWithExchangePct (5) 

Sometimes a caller decides to send their exchange although the runner sent an imperfect call. 
Typically this exchange will be prefixed by a corrected call, but this percentage of the time it won’t 
be. 

Version 5.4	 Page 112



SkookumLogger Guide

PracticeClosestPouncerAlwaysReplies (NO) 

Setting this to YES will result in a single caller always replying to any call sent. This will be the caller 
with the callsign closest to the call sent by the runner. For example sending a single “K” will result in 
a single caller from a pileup replying with their callsign even if multiple callers have a callsign 
containing “K” 

Call Again Delay 

Center and spread (seconds) for callers that call again when you don't respond right away. 

PracticeCallersRetransmitTimerEnable (YES) 

PracticeCallersRetransmitTimerCenter (3.0) 

PracticeCallersRetransmitTimerSpread (5.0) 

Lid Serial Cut Numbers 

These enable lid callers that send cut numbers, set the percentage of callers that are lids and the 
percentages of those callers that are type1 and type2 lids. Type1 lids send 'O' instead of '0'. Type 
two lids send 'T' instead of '0' and 'E' instead of '5'. Both types will also send ‘A’ for ‘1’ and ’N’ for 
‘9’. These values also enable other "lid" behavior like runners never sending their callsign or 
pouncers calling you again even if you've worked them before. 

PracticeEnableLidCallers (YES) 

PracticeLidCallersRatio (25) 

PracticeLidtype1CallersRatio (50) 

PracticeLidtype2CallersRatio (10) 

PracticeLidtype2CallersDupeRatio (10) 

Some lid callers will add a “flourish” to their sent exchange. The following preferences control this. 
The values are relative to other values in their group and do not have to sum to 100. Both type 1 
and type 2 lid callers will potentially send Lid1 flourishes. 

PracticePouncerExchangeLid1PrefixNoneWeight (90) 

PracticePouncerExchangeLid1PrefixCallerWeight (5) 

PracticePouncerExchangeLid1PrefixRunnerWeight (3) 

PracticePouncerExchangeLid1PrefixLid2Weight (2) 

If the caller decides to add a Lid2 flourish, it is chosen from the weighted list below. 

PracticePouncerExchangeLid2PrefixBKWeight (50) 

PracticePouncerExchangeLid2PrefixQSLWeight (50) 
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QSY Request Respondents 

Sets the percentage of callers who respond to a request to QSY (any message that contains the 
QSY token). Those callers will call later on the QRG frequency you send. 

PracticeQSYRatio (40) 

Sets the distribution of responses to a QSY request. The values are relative to other values in this 
group and do not have to sum to 100. 

PracticeQSYResponseWeightAccept (40) 

PracticeQSYResponseWeightQueryQRG (20) 

PracticeQSYResponseWeightQueryAgain (10) 

PracticeQSYResponseWeightDecline (10) 

PracticeQSYResponseWeightNoResponse (20) 

Caller Speed and Amplitude Probability Distributions 

PracticeUseLogNormal (NO) 

The default probability distribution for simulated station speed is Gaussian. The log-normal 
distribution concentrates speeds more tightly around the center. 

PracticeUseContinuousUniformDistributionForAmplitude (NO) 

The default distribution for amplitude is Gaussian. The uniform distribution spreads amplitudes 
more evenly. 

Pileups Generated By Simulated Runners 

PracticeMaximumAICallers(2) 

PracticeCallBackProbability(90) 

The percentage of simulated runners who will answer you the first time that you call. 

PracticeMaximumAIRunnerQRG(50000) 

The maximum frequency span (Hz) up from the band edge where simulated runners will call CQ. 

PracticeRunnerQSOsBeforeQRT(25) 

The minimum number of QSOs that a pouncee will make before going QRT and being replaced by 
another simulated runner. 

PracticeLidPounceeRatio(5) 

Used to determine the probability with which a simulated runner is a lid. Lids may not ever send 
their callsign while running or other sub-optimal behaviors. 
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QSO Party 

PracticeQsoPartySingleCountyWeight(75) 

PracticeQsoPartyCountyLineWeight(23) 

PracticeQsoPartyMultiCountyLineWeight(2) 

Inside/Outside Contests 

PracticeUserSidePercentForInsideOutsideContests(10) 

For contests having inside/outside semantics this is the percentage of stations that will call from the 
user’s “side”. As an example if you’re practicing California QSO Party Inside and this value is set to 
5, you’d expect roughly 5% of callers to be California stations. 

These preferences determine the distribution of county line straddlers for QSO parties where 
straddling is supported. SingleCounty will result in stations sending a single county abbreviation. 
CountyLine will result in stations straddling a county line (they will send 2 counties separated by a 
slash). MultiCounty will result in stations sending 3 or more counties separated by slashes. When 
more than 1 county is sent, the counties will always be actual adjacent counties. 
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Checksheets 

A checksheet is a table of multipliers, such as countries, with columns for each band and counts 
indicating how many QSOs you have made with each multiplier on each band.  

SkookumLogger has six kinds of checksheets for different kinds of multipliers: Countries, Regions 
(states, provinces, etc.), Grids (Maidenhead locators), Prefixes, Zones, and “Other”. The Other 
multiplier type is used for contests where there are two sets of multipliers of the same kind, 
typically regions, and for contests with odd-ball multiplier types like unique call signs and IARU 
Societies. 

Checksheet windows are opened by items in the Window > Checksheets > menu. Checksheets 
that do not apply for the current contest are disabled in the menu. You can rearrange checksheet 
table columns and sort the rows using standard table customization gestures. 

✦ To quickly scroll to the row containing a multiplier code, click on any row to make the table 
active, then type the code.  

✦ Click on a band column to sort the table in order to group most-worked or not-worked 
multipliers. 

The multipliers for some checksheets are grouped by area. For example, countries are grouped by 
their continent. You can limit the checksheet table to show one group by choosing the group name 
in an area pop up menu above the table. 
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Checksheets also have a Mode pop up button. When you have set your Cabrillo Category Mode 
(Log > Cabrillo Settings…) to a single mode, the Mode pop up shows that mode. Otherwise — 
Mixed mode — the Mode pop up lists all of the modes specified by the log’s contest rules and 
choosing a mode changes the table to show the number of QSOs with each multiplier for that 
mode. When multipliers are not per-mode, consult the Score Breakdown tool window to see your 
multiplier counts. 

Checksheets with a large number of possible entities (grids, zones) or unpredictable number of 
entities (prefixes, other) list only multipliers that you have worked at least once. 

When you edit an already-logged QSO, the checksheets may become invalid. Use Log > Rescore 
Log command to rebuild the checksheets. 

When a contest has ARRL section multipliers, the Window > Checksheets > Section Checkoff 
command is available to open a display of worked sections. 
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Panadapters 
A panadapter is a display that shows signal information from a receiver over a range of 
frequencies. Typically, the display contains two panes. The upper pane is an x-y plot with frequency 
along the x axis and signal amplitude along the y axis; this is often called a spectrum plot. The 
lower pane is called a waterfall, also with frequency along the x axis, but with time along the y axis 
and colors associated to signal amplitude. The range of frequencies is called the span, and the 
point at the center of the x axis is the center frequency. The center frequency may either follow the 
receiver, called track mode, or remained unchanged as as the receiver changes frequency, called 
fixed mode. The signal level at the baseline of the spectrum plot y axis is the reference level, and 
the range of the y axis is the scale.  

Some radios output data for the spectrum plot as a stream of numbers. With that data, 
SkookumLogger can create a panadapter in a window on your Mac. The window is resizable, and a 
splitter between the two panes determines how much of each pane is shown.  

The number “–118dBm” is the reference level (baseline) for the spectrum plot. The dotted 
horizontal grid line spacing is 10 dB and the vertical grid line spacing is span-dependent (10 kHz in 
the example) and are positioned at integral frequencies (7010, 7020, 7030, and 7040 in the 
example). The solid vertical lines are cursors, explained below. 

SkookumLogger can display up to 8 panadapter windows. For each radio: a Panadapter window 
for the Main Receiver and the Sub Receiver, and a Mini-Pan window for each receiver. The 
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Panadapter window is a typical view of signals over a substantial frequency range, while the Mini-
Pan shows a fixed-size narrow view centered on the receiver frequency. 

The windows are opened, closed and controlled by deeply-nested menu items in their Radio 
menus.  

These menu items do not have keyboard shortcuts, and it isn’t possible to use macOS Keyboard 
Settings to add shortcuts because the item titles are not unique. Instead, use Keyboard Maestro, 
because it handles the complete path a menu items, which is unique. 

The window toolbar has several items that control and display radio panadapter settings. These 
items apply only to Panadapter window; the Mini-Pan windows don’t have any items except the 
smoothing factor slider. 

✦ The gear button opens a settings window for defining preset 
panadapter span values. 

✦ The Smoothing slider controls how heavily the data is 
averaged, using an exponential moving average, separately for 
each panadapter. The minimum setting does no smoothing all, 
while larger settings decrease jaggedness in the spectrum and 
waterfall displays at the expense of delaying how quickly 
signals appear and disappear. 

✦ The “Fixed2” popup menu chooses the panadapter tracking 
mode and displays the current choice. The displayed choice 
updates if you change the tracking mode using radio controls. Since the choice affects both the 
Main Receiver and Sub Receiver Panadapters, the popup menu isn’t shown in the Sub Receiver 
Panadapter window. 

✦ The “Medium” popup menu chooses one of four preset choices and shows the most recent 
choice; the choice does not update if you change the span using radio controls: 

✦ Narrow, Medium and Wide set the span to the value determined in settings and the center 
frequency so that the lower edge of the span is an integer multiple of the span width above 
the band edge. For example, choosing Medium when the receiver frequency is 14060 kHz 
and the Medium span is 50 kHz sets the lower edge to 14050 by setting the center 
frequency to 14075. 
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✦ Focus sets the span to the value from settings and the center frequency so that the current 
receiver frequency is 5% above the lower edge of the span. Use this for split pileups. 

✦ The Center button sets the center of the panadapter span to the receiver frequency. 

When the radio provides certain information via CAT, it is possible to determine the frequency for 
any point in the panadapter view. Then, SkookumLogger can set the radio frequency when a user 
clicks in the view, and overlay activity information on the view. 

The remainder of this chapter is specific to a K4 using an ethernet connection and firmware version 
R31.B2 or newer, using the K4 TCP radio type. The K4 provides all four data streams with some 
caveats: 

✦ The Sub Receiver data is not available when SUB is off or the PAN setting in DISPLAY isn’t A+B. 

✦ The Sub Receiver Mini-Pan data is identical to the Main Receiver data when DIVersity is on. 

Note: Sometimes a data stream stalls resulting in a blank display to recover, close and reopen the 
window. 

Radio Cursors 

SkookumLogger displays cursors for main receiver frequency, subreceiver frequency, and transmit 
frequency in the spectrum pane of all four windows, and briefly extends them into the waterfall 
when any of those frequency changes. The colors for these cursors match the K4 display: 

✦ A blue line shows the main receive frequency. The line is surrounded by a semi-transparent 
rectangle with width determined by receiver bandwidth and offset determined by radio mode-
dependent shift. When the mode is FSK, the blue line is at the mark frequency and a second 
dotted line is drawn at the space frequency. 

✦ A green cursor similarly represents this information for the subreceiver. 

✦ A red line represents the transmit frequency. 
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All three of these cursors are always present, but of course you don’t see them when they are 
outside the bounds of the panadapter frequency span. 

Grab Cursor 
When a panadapter window is active and the mouse cursor is over the window content, 
SkookumLogger draws a vertical white line at the horizontal mouse coordinate and displays the 
frequency at that coordinate near the top of the line. If the tracking cursor is near an activity cursor, 
SkookumLogger also displays the call for the activity. Clicking the mouse performs the action listed 
below, then makes the Log window active. 

These click actions are similar to those for clicking in Activity tables. 

Grab Cursor Click Actions for 1T1R and 1T2R

Modifier On Activity Action

none no Clear entries, set frequency for entry pane with Transmit Focus

none yes Grab activity

control no Change focus to Run, clear entries, set frequency

command yes Delete activity

shift & 
command yes Reject activity

Grab Cursor Click Actions for 2T2R

Modifier On Activity Action

none no Clear entries, set frequency for Radio 1

none yes Grab activity to Radio 1

shift no Clear entries, set frequency for Radio 2

shift yes Grab activity to Radio 2

control no Change focus to Radio 1, turn off pounce submode, set 
frequency

shift & 
control no Change focus to Radio 2, turn off pounce submode, set 

frequency

command yes Delete activity

shift & 
command yes Reject activity
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Activity Cursor 
SkookumLogger draws a vertical lines in the waterfall pan at the frequencies of activities for the 
radio’s band. These activity cursors are labeled with the activities’ calls, and they are adorned with 
the needed colors for the activities. The visible activities do not depend on the Activity table filter 
choices. 

Using the Panadapters 
A panadapter provides situational awareness at a glance. Locate the windows near your Log 
window where you can inspect them without turning your head. 

Grabbing a run frequency 

✦ Click inside a panadapter window to show the grab cursor. 

✦ Position the grab cursor over an empty frequency. 

✦ Control-click. The radio will be set to transceive on the frequency you chose, and both transmit 
focus and keyboard focus will be changed to the Run entry box. 

Grabbing an unknown signal 

✦ Click inside a panadapter window to show the grab cursor. 

✦ Position the grab cursor over a signal that is isn’t identified with an activity cursor. 

✦ Click. The QSO entry box with transmit focus (red gumdrop) will be set to transceive on the 
grab cursor frequency and keyboard focus will be returned to that entry. You can then type a 
call to determine the signal’s needed status, and choose Activity > Create to add the signal to 
the Activity table.  

Grabbing an activity 

✦ Click inside a panadapter window to show the grab cursor. 

✦ Position the grab cursor over an activity, so that the activity’s call is attached to the grab cursor. 

✦ Click. The activity is copied to Pounce, focus is changed to Pounce, the radio is set to the new 
Pounce frequencies. 

Running in 1T1R mode 

Set transmit focus and keyboard focus to Run. Open the main receiver mini-pan window. Turn off 
SPLIT and set the main receiver where you want to run. 

When Run has transmit focus, SkookumLogger turns RIT on and XIT off. Tuning the RIT/XIT offset  
causes the the spectrum plot to recenter without affecting the transmit frequency. Use this behavior 
to move the receiver to a caller outside your passband without moving your transmit frequency. 
Use CLR or a K•Pod function key to return the main receiver frequency to your transmit frequency; 
the plot will recenter again. With a K•Pod, use the knob to control the RIT/XIT offset. 
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Search and Pouncing in 1T1R mode 

Set transmit focus and keyboard focus to Pounce. Open the main receiver mini-pan window. Turn 
off SPLIT and set the main receiver to a station you want to call. 

When Pounce has transmit, SkookumLogger turns RIT off and XIT on. Tuning the RIT/XIT offset  
changes your transmit frequency without changing the receive frequency or recentering the 
spectrum display. Use this behavior to set your transmit frequency where the station you are calling 
is most likely to hear you; sometimes zero-beat to a previous caller, sometimes where nobody else 
is calling, usually not where the target was spotted. Clear the offset as above to transmit exactly 
where you are listening. With a K•Pod, use the knob to control the RIT/XIT offset. 

Cracking Pileups in 1T1R mode 

Set transmit focus and keyboard focus to Pounce. Open the main receiver panadapter. Turn off 
SPLIT and set the main receiver to a station you want to call. Choose the Focus preset mode. 

Listen to the the target station while watching the pileup in the panadapter. The pileup will subside 
somewhat when the target is working somebody; the station being worked will be among those 
still transmitting. Identify that station by whether or not he is transmitting only when the target is 
not transmitting, this is surprisingly easy to do as long as you can hear the station. You want to call 
at or near the frequency of the station just worked; use XIT offset to transmit at that frequency, as 
shown by the red radio cursor. 

Sometimes the target station will change where he is listening after one or a few QSOs. You may be 
able to detect a pattern in which direction he moves his receiver and choose a relatively clear spot 
to call in anticipation. In another pattern, the target will jump to one edge of the pileup when he he 
reaching the other edge. Basically, you want to do something more intelligent that parking on one 
frequency and hoping he will tune across you. 

The range of the RIT/XIT offset, 10 kHz, may not be large enough to cover the entire pileup. In that 
case, leave the offset at zero, turn on SPLIT, and position the transmit cursor with VFO B. In this 
configuration you can also turn on SUB to listen to both the target and to where you will be 
transmitting. 

Setting Pre-amplification Level 

Your ability to copy a signal depends on the signal-to-noise ratio (SNR), where the noise is a 
combination of noise arriving from your antenna and noise generated inside your receiver. When 
the antenna noise is much larger than the receiver noise, the receiver noise has no effect on SNR. A 
preamp can raise the antenna noise to accomplish this condition. 

You can use a panadapter to see how much pre-amplification is helpful, like this: 

✦ Select DISPLAY > REF LVL > MAN. 

✦ Set the reference level so that the “grass” level in the spectrum plot is well above the baseline. 

✦ Increase pre-amplification. If the grass level decreases, the added pre-amplification has 
improved the SNR. If not, you should decrease pre-amplification, perhaps by adding 
attenuation, to improve large-signal handling. 
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Map Windows 
SkookumLogger has two map windows. Each contains an azimuthal equidistant (also known as 
great-circle) projection centered on your geographic coordinates. One, the Great Circle Map, 
displays the entire earth with ocean and country borders and, optionally, worked countries. The 
other, the Grid Map displays a section of the earth with Maidenhead grid boundaries and, 
optionally, worked grids. Choose Window > Maps > Show Great Circle Map and Window > Maps 
> Show Grid Map, respectively. You can open both map windows at the same time. 

The Maps web page describes how to request map images for your location and download maps 
for your location.  

The Window > Maps submenu has three groups of items. 
The bottom group applies to both map windows, while the 
upper two groups have separate items with the same 
behavior for each map window. The item names are rather 
elaborate so that you can assign you own keyboard 
shortcuts. Some off these items are duplicated in buttons in 
the map window title bar. 

Zoom In and Zoom Out change the size of the map without 
changing the size of the window. The size of the zoom step 
is √2. Normally, changing the size of the window does not 
change the size of the map. Fit in Window resizes the map 
to fill the window and turns on autoresizing so that window 
size changes also change the map size. When you zoom or 
center the map, autoresizing is turned off. Control-option-
click and shift-control-option-click zoom in and out 
respectively, without panning the map. 

Center shifts the map within the window so the map center 
is aligned with the window center. The map windows have 
scrollbars that you can use to pan a zoomed-in map within 
its window. You can also pan by dragging with the mouse. 
And you can option-click on a point in the map pans the 
map to center the clicked point in the window. In either case, you cannot pan beyond the limits of 
the map, so these gestures are most useful when zoomed in several steps. 

Change Map opens a file chooser for selecting a map image file. The files available at the Maps 
web page have the coordinates of the map center embedded in the image data; you can use any 
of them to see what the world looks like from other places than your own QTH, with all of the 
functionality described below. Download the files you find interesting and store them anywhere on 
your computer. SkookumLogger remembers the most-recently opened map image across restarts. 
Note: Show the Map window before you use this command. 

Mouse clicks inside the map can also control rotator 1 and your receive antenna choice. These 
gestures are listed in the help tag for the map. 
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⇧-drag to pan 

⌥-click to center clicked point in the window 

⌃⌥-click to zoom in 

⇧⌃⌥-click to zoom out 

⌘-click to turn rotator 

⇧⌘-click to turn rotator (long path) 

⌃⌘-click to choose RX array 

⇧⌃⌘-click to choose RX array (long path) 

Each window has six overlays — graphics drawn on top of the map. Five of them are turned on and 
off with the items at the bottom of the Window > Maps submenu. The sixth overlay is a compass 
rose comprising 12 white radial lines from map center to map edge spaced 30° apart. 
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Target Point Overlay 
The target point graphic is a line from the center of the map (your location) to a dot at the location 
of the call in the QSO call entry field, colored red in the example. The color for the target point 
graphic is chosen to contrast well with the colors in the map image. 

When SkookumLogger finds grid for the call in either your current log or your exchange archive, it 
draws a donut at the end of the line. Otherwise, the coordinates are determined from the 
Countries database and SkookumLogger draws a solid dot. As a special case for UK contesters, if 
the contest name contains ‘RSGB’ and the contest bands are all above 10m, SkookumLogger draws 
nothing instead of the solid dot. 

Worked Countries Overlay 
When Window > Maps > Worked Countries is checked, the call field is empty, and the current log 
has country multipliers, SkookumLogger draws a small target-like dot at the center of each worked 
country. For the Grid map, worked grids are shaded. 

Terminator Overlay 
The terminator is the dividing line between points on the earth that are illuminated by the sun, and 
points that are not illuminated. That line is drawn as white in the terminator overlay. The sunlit area 
in the overlay is transparent, while the unlit area is translucent. 

The fuzzy shading on each side of the terminator corresponds to the location of the terminator 30 
minutes before and after the current time. The current time is shown at the top right corner. The 
current time is automatically updated every 1 minutes unless the Automatic Terminator checkbox is 
turned off; then you can enter any time of year into the date picker.  

Great circle paths approximately aligned with the fuzzy area around the terminator are known as 
gray line paths. Propagation along these paths is sometimes enhanced, and sometimes favors the 
long path to a target as well. Other enhancements can happen when either or both ends of the 
target path are inside the fuzzy region around the terminator. 

Antenna Overlays 
The TX Antenna and RX Antenna overlays show antenna patterns as pie-shaped segments for the 
selected transmit and receive antennas. A segment is shaded where the antenna lobe gain is less 
than 5 dB (one S-unit) below the peak gain. Patterns for Radio 1 are translucent blue; patterns for 
Radio 2 are translucent red.  

The names of the active transmit antennas are listed at the top right corner of the map. 

When the transmit antenna is rotary, the overlay updates when antenna bearing changes.  

To configure your antenna information, a configuration file in JSON format is required. A separate 
application exists to test the configuration you have specified, and similar code for antenna 
selection via an external YCCC MOAS switch has been integrated into SkookumLogger. 
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WWV Report Overlay 
This overlay is a simple reformatting of the DX Cluster WWV announcement messages presented 
at the lower left corner of the map window. The messages are broadcast every 3 hours, 
commencing at 00Z. The bottom line shows Geomagnetic storm (G) and Radio blackout (R) levels 
in the past 24 hours and predicted levels for the next 24 hours. See the NOAA reference below for 
details about these levels. 

The messages are broadcast every three hours, and SkookumLogger needs to be connected to a 
DX Cluster node when a broadcast happens. Alternatively, you can manually request the most 
recent WWV forecast, or automatically request a forecast when opening a DX Cluster connection; 
see DX Cluster settings. To understand the WWV terminology visit NOAA Space Weather Scales 
and DX.QSO.NET Propagation. 
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Editor Windows 
Use an editor window for changing settings during a contest. Open an editor using Window > 
Editors >. 

Country Alias Editor 

Choose Window > Editors > Country Alias Editor to open a window to define information to 
associate with a call. For example, you can create an entry for R7BA/9, associating that call with the 
UA country code in EU, instead of UA9 in AS as would have been determined from “R9BA”. Or you 
could add an IOTA definition, or provide a definition for a call that is unknown in the countries 
database. 

To create an entry in the table, enter a call sign in the Define call field, choose a country code in the 
popup list, and press Do It. The parameters for the selected country code are used to populate the 
remaining columns in the table. You may then optionally edit values in columns other than Code 
and Name. For example, you might want to change the Latitude and Longitude coordinates (the 
default coordinates are based on population centroids, and are not likely to be accurate for a 
geographically large country). To delete an entry, select the row and press Remove. The custom list 
is saved each time it is changed, and applies for all situations where SkookumLogger needs to look 
up information for a call. 

The country code list has hundreds of entries, making it cumbersome to manually scroll to a 
selection. To auto-scroll, select the button by pressing the tab key, then type the first character of a 
country code. 

You can also use this editor to deal with invalid calls like 8J1C70Y. SkookumLogger logger will 
allow you to enter anything in the Define Call, and will treat it as a valid call once you have assigned 
a country code for that call. 

Version 5.4	 Page 128



SkookumLogger Guide

Sent Exchange Editor 
Choose Window > Editors > Sent Exchange 
Editor to display the Sent Exchange editor. 

When you create a new log, SkookumLogger 
guesses an appropriate sent exchange using 
the contest rules and information that you 
provide in the Sent Exchange tab of the New 
Log settings pane. The sent exchange for the 
next QSO is displayed in the main window. If the guess is wrong or you need to change an 
exchange field because, for example, you have changed counties in a QSO party, use this editor.  

Important: You must set your sent exchange properly before you log a QSO. 

It is important to ensure that the sent exchange is correct before you log any QSOs because each 
logged QSO contains the sent exchange information and that information cannot be changed. The 
Call field must be the call you transmit during the contest. This field is copied from the Contest Call 
value in the Exchange tab of New Log settings when you create a new log. The remaining 
exchange fields depend on the contest name. SkookumLogger initializes these fields from New 
Log Exchange settings but sometimes will guess wrong, particularly for contests where the 
exchange includes a “regional” location. For example, my “State-County” for NEQP is NHCAR, 
while the “State-County” for W2RU in that contest would be NY. 

When the label above the input fields in the editor indicates a county is needed, you can use 
completion to see a list of county codes. Edit > Complete shows the list. If you type something first, 
the the list will be restricted to codes that begin with what you have typed. Use the up and down 
arrow keys to select a list entry, then press return to choose the selected entry. 

In addition to the sent exchange fields for logged QSO, SkookumLogger also guesses the Morse 
Sent Exchange Template, associated with the & token in CW messages. The Morse Sent Exchange 
Template field updates if you change a value in a sent exchange field. You can customize the 
template, but customizations will be lost if you subsequently change an exchange field value. You 
might want to customize, for example, by using the | character to modify spacing. Changes that you 
make in the editor are saved in the log document and do not affect Exchange settings values. 

The template recognizes all of the Message Tokens listed in Messages settings except the sent 
exchange token (&) and the message-n token({n). In general you should use tokens in the template. 
In addition to the tokens, the template may contain any character recognized by WinKeyer. 
Unrecognized characters are ignored when sending a message. Do not 5NN or, worse, ENN in the 
template; SkookumLogger prepends the report to the sent exchange message as prescribed by 
contest rules. 

Morse Messages Editor 
See Messages editor. 
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Data Messages Editor 

The Data Messages Editor customizes basic message content for data modes. Customizable menu 
item titles are changed using the Morse Messages Editor. Changes that you make with this editor 
are saved with the current log and do not affect other logs. 

Choose Window > Editors > Data Messages Editor to open the editor. The editor is similar to the 
Morse Messages Editor, with the CRLF token available instead of the half-space token. The 
example window shows how CRLF is used to cause line-spacing at the receiver. 
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Morse Speed Editor 
The Morse Speed Editor is a small window for setting keyer speeds and 
speed step size. 

Choose Window > Editors > Morse Speed Editor to open the editor. 

The labels Run and Pounce change to Radio 1 and Radio 2 in the 2T2R 
operating mode. 

Radio Frequency Editor 
You can set the radio’s frequency directly from 
SkookumLogger, using Window > Editors > Radio 
Frequency Editor, including different frequencies 
for transmit and receive, whenever split is 
supported via CAT control for a radio type. This is 
most often useful for working split in phone 
contests that enjoy worldwide participation by 
operators limited to different phone segments by 
their national regulatory agencies.  

If the entered frequency is less than 1000, it is 
treated as an offset from the band edge for the current band. When you do not change the 
transmit field, SkookumLogger assumes you want to transceive on the receive frequency. When the 
transmit and receive frequencies do differ, SkookumLogger shows the TX offset value in the Log 
window in yellow to remind you. You can use the same editor to set frequencies when radio type is 
set to Phantom; when you are not using CAT control, this allows you to set the frequency for the log 
manually. 

Also see the Frequency text command. 
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Tool Windows 
Tool windows are generally passive displays for showing information during a contest without 
needing take keyboard focus. Use Window > Tools > to open a tool window. 

Rate Tracker 
The Rate Tracker tool has four groups of 
bar meters giving you various measures of 
how quickly you are logging new QSOs. 
Each of the groups has a number entry 
field for setting the maximum value of the 
meters in the group. 

The Minutes Elapsed Since Last QSO bar 
is colored green when the value is less 
than the Warn level, yellow when the 
value is between Warn and Alert, and red 
above Alert.  

The bars in the QSOs Per Hour and the 
QSO Points Per Hour groups are colored 
red when the value is less than the Alert 
level, yellow when the value is between 
Alert and Warn, and green above Warn. 
The Current meter values are computed 
using the value of Rate averaging interval 
in Logging settings. 

The Cumulative QSOs Per Hour bars show 
rates per band. Some contesters use 
these bars to determine if they are 
spending too much time or not enough 
time on a band. 

Having the Rate Tracker window open will give you a feel for how many QSOs and points you are 
making in a time period, and how long has elapsed since the last QSO logged. If rates slow you 
may decide to change strategy in some way, such as changing bands.  

Of course not all contest events are purely about QSO rate - multiplier searching in some events 
might be an important activity — in which case the QSO points rate will be more useful to monitor 
than the raw QSO rate.  
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Time Tracker 
The Time Tracker tool displays, umm, time information for your 
log. 

All contests have a beginning and end. Time Tracker shows the 
beginning as Start date, and determines the end by adding the 
Contest duration to the start date. SkookumLogger presets 
these fields for new logs, but you should always check them for 
a new log before you begin making QSOs. Some contests limit 
the amount of operating time to less than the duration. In this 
case, the Maximum on time field shows the limit, the limit may 
depend on your entry category.  

The Log Due date is obtained from the WA7BNM 8-day 
calendar. When the current date is outside the dates covered by 
the calendar, the date is shown as, perhaps optimistically, as a 
distant future date. 

Some contests, typically USA QSO parties, have one or more  
breaks in the middle. SkookumLogger handles these internally 
using a list of mandatory break periods. 

The Suspect QSO (SQ) flag is set for QSOs logged outside the 
contest period. The Do not test for Suspect times option in 
Logging settings disables this test. 

“On time” is the accumulated time during which you are making 
QSOs during the contest period. “Off time” is the accumulated 
time during which you were not making QSOs. SkookumLogger 
detects the beginning of an off time by comparing the 
difference between the current time and the time of the most recent QSO against the Minimum off 
period field, shown when you expose the Off times panel. Some contests specify this value, 
otherwise SkookumLogger sets it to 10 minutes. The value affects rate tables presented in your 
statistics report. Shorter off periods generally “improve” your rates. The Begin time of an off time is 
the most recent QSO time. When you log the next QSO, the off period ends and the End time of 
the off time is set to that QSO’s time and SkookumLogger resumes accumulating on time. The table 
of all off times is reported in the Cabrillo header. 

You can create a new log for a contest any time before the end of the contest. When calendar data 
is not available for a new log, the start date is set to the current date and the duration is set to two 
days. You can edit the Start date, Contest duration and Maximum on time items. Use the Apply 
Changes button to save the changes and update the current log. 

Changing the Time Category item in your Cabrillo settings sheet affects the Maximum On Time 
value appropriately. The Not Applicable choice returns the value to the default for Single Operator 
entrants. 
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 When you aren’t familiar with the start date and off time requirements for a contest, use Help > 
WA7BNM Resources > Contest Details for Current Log or Help > WA7BNM Resources > Contest 
Rules for Current Log to open a relevant page in your default web browser.  

How Start Date and Duration are determined 

When you start SkookumLogger, a table of contest information is downloaded from the internet 
and stored on your computer. The table contains data from the WA7BNM 8-day Calendar. This is a 
service provided by WA7BNM. When you make a new contest log, SkookumLogger consults that 
table to determine the start date, duration, and other information. When the new contest isn’t 
present in the table, SkookumLogger sets the start date to the current date and the duration to two 
days. Use Time Tracker to modify those data as needed. 

Score Breakdown 

The Score tool shows a per-band breakdown of QSOs, QSO points, multipliers, duplicates, and 
suspects. 

The value for a multiplier in terms of QSOs is total QSOs divided by total multipliers, and is 
accurate only when all QSOs have the same point value. 

When you edit a logged QSO, the score and other information may become invalid. 
SkookumLogger has to rescan all of your QSOs to update the information, which can be time-
consuming, so the update is performed automatically as determined by Automatically rescore logs 
smaller than in Logging settings. In any case, you can manually cause an update with the Log > 
Rescore Log command. 
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Status Messages 

The Status Messages tool displays status messages from SkookumLogger. The example shows 
startup messages and log file changes. Uncheck Show at Startup if you don’t want to see the 
messages. In that case, when SkookumLogger thinks you should know right away about a change 
in status, it opens the window for you.  

Note: The checkbox will be ignored if you haven’t change My Call in New Log settings from the 
default. 

Pass Information 
The Pass Information tool window shows the call in the 
QSO entry pane with keyboard focus, with a table of 
symbols indicating the bands where you need that call 
or the multiplier(s) for that call. The ❖ symbol indicates 
needed, _ indicates not needed. You use the information 
to decide whether or not to ask the station to move to 
another band or mode — traditionally termed “passing” 
a station.  

The number of markers in each column depends on 
whether or not QSOs and multipliers are per-mode. In the case of multiple-mode contests, hover 
your cursor over the table to see the help tag defining the mode-ordering of the symbols. 

In the example, K1GQ is a needed QSO on 80m and 40m SSB, and both modes on 10. The 
Country of K1GQ isn’t needed on any band, but the Other multiplier is needed. 

Grid Information 
The Grid Information tool window displays your grid and information about a target grid. The Sent 
grid field is initialized with the Grid value in the Sent Exchange pane of New Log settings. In 
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contests with grid as part of the exchange, Sent grid tracks 
the grid that you set in the Sent Exchange Editor. If the 
Automatically set sent grid option in Logging settings is on, 
your sent exchange grid tracks your computer’s grid using 
the macOS location service. Your Mac will need a good 
wireless connection to the internet, possibly via an iPhone 
hotspot. You may see a “not available” message if you don’t 
have WiFi enabled, or if Location Services is not enabled in 
Security & Privacy system settings. 

The Target grid field is determined from the location for the 
Target Point.  

The Reverse Geocode Lookup pane shows additional 
information about the target location available via an 
internet query. The empty space at the bottom of that pane 
shows potential error messages associated with the lookup. 
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Analysis and Log Aggregation 
SkookumLogger provides a number of features that allow you to analyze your log during and after 
the contest which may assist in understanding how to improve your performance next time. This 
chapter covers these features together with how to export your individual SkookumLogger contest 
logs into other software to aggregate them into a single QSO database for subsequent analysis. 

Using Search Log to Analyze Contacts 
During the contest, the Search feature in SkookumLogger allows you to 
review information about the stations you have worked. The Search field is 
located towards the top right of the main SkookumLogger logging 
window. Clicking the magnifier icon in the search field allows you to list 
and select the log table column to search on. As you type into the search 
field, the log table displays only QSOs that contain what you have typed in 
the chosen column. The numbers to the left of the search field are the 
number of selected QSOs (0) and the number of matching QSOs (14). 

There are many examples of how you can use this search. First it can be of use to quickly find all 
instances of a particular call. Then you can check needed band/modes or, in the case of a 
duplicate, you can tell the station what exchange they gave you in the previous contact. 

A second way to use the search is for contests where the multiplier is based on some unusual detail 
of the received exchange which is not covered by SkookumLogger’s standard country, zone or 
multiplier tables. One example of this is the number of Club Stations worked in the RSGB Club 
Calls contest. Club stations are logged as C before the club name in the exchange. Therefore 
searching the log for the pattern ‘ C ‘ in the Received field returns the required analysis. 

A final example of how to use the search feature is to search for specific contents in the Notes field, 
in cases where you want to flag particular issues, and have entered a comment or flag of some sort 
in the Notes field of the relevant contacts in the log table. 

The Automatically search option in Logging settings copies what you type into the search field and 
sets the target column to Call. The effect is that the log shows only QSOs with calls that contain 
what you have typed. This is convenient in contests with rovers, although perhaps disturbing the 
first time you use it. 

Rate Breakdown Analysis 
File > Rate Breakdown Report produces a detailed breakdown of QSO rates with multipliers (if 
applicable) over the duration of the contest. The format is HTML and the report will open in your 
default browser. The file, QSOPointsBreakdown.html, can be found in the application support 
folder. Alternatively, use your web browser to save the report in webarchive format in a more 
accessible place where it won’t be overwritten. 

Note: See the note in the next topic. 
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Statistics Report 
File > Statistics Report processes your log to compute rate statistics and other summary 
information, then produces a report in HTML before displaying this in your default browser. The 
processing is time-consuming for large logs and will block the SkookumLogger user interface until 
it completes. The file, StatisticsReport.html, can be found in the application support folder. 
Alternatively, use your web browser to save the report in webarchive format in a more accessible 
place where it won’t be overwritten. 

Note: On Sonoma 14.1, your web browser may show something like this: 

To work around this new security policy, either drag the StatisticsReport.html to your desktop and 
double-click it, or give your web browser full disk access in System Settings -> Privacy & Security -> 
Full Disk Access. 

ADIF Export  
Many contest operators want to aggregate their individual contest logs into a single large database 
of contacts made. This may be for analysis purposes or for award or QSL tracking for example. 
Other macOS general logging programs that do this can import standard Amateur Data 
Interchange Format (ADIF) files. SkookumLogger provides a feature to export individual contest 
log data to ADIF for this purpose. Simply choose File > Export ADIF…. A standard File Save dialog 
will appear and you should choose a name and location to save the file. 

The ADIF exported file may also be used directly by programs such as TQSL for signing and 
uploading contest logs to ARRL’s Logbook of the World (LotW), but in most cases if you are 
aggregating contest logs from SkookumLogger into a general logging database application then 
the latter will also handle LotW interaction.  

Numbers Export 
SkookumLogger provides a means to export all the log table data for a contest in comma 
separated values (CSV) format, facilitating import into spreadsheet software such as Apple’s 
Numbers or Microsoft Excel. Further sorting and analysis is then possible using such software. To 
do this, choose File > Export to Numbers…. A standard File Save dialog will appear and you should 
choose a name and location to save the file.  
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Overview 
In general, you should turn on all your external hardware before starting SkookumLogger, and stop 
SkookumLogger before turning external hardware off. That allows SkookumLogger to keep track of 
which devices you are using and manage them for you at startup.  

You manage devices in windows listed in the Window > External Devices > menu. Some windows 
have a Type chooser when more than one kind of a class of devices (for, example, different 
amplifiers) is supported. Windows that access devices using the RS232 serial protocol have Port 
choosers for selecting the serial port for the device and an Enable checkbox for starting and 
stopping communication with the device. Windows that access devices using the TCP network 
protocol have a Settings… button in place of the Port chooser. 

Note: These general remarks no longer apply to the Radios window. 

Some external devices identify themselves when plugged in and turned on. SkookumLogger 
doesn’t need choosers or an Enable checkbox for them. The YCCC SO2R Box and the XK-24 
Keypad examples of these devices. 

Hint: While SkookumLogger remembers which external device window are open across restarts, 
most are rarely needed once configured. A quick way to open a window without navigating the 
nested menu tree is: 

✦ Use ⌘? to open the Help menu 

✦ Begin typing the window name into the search field 

✦ Use down-arrow to select the desired menu item in the search result list 

✦ Tap return. 

Serial Devices 
Many of the external devices supported by SkookumLogger communicate with the computer using 
the antique “RS232” serial protocol. These devices require a USB-serial adapter to convert the 
electrical connection between serial and USB standards. In some cases, the adapter is built into the 
external device. In other cases you need to provide the adapter yourself. 

macOS automatically discovers USB-serial adapters when they are plugged in. SkookumLogger 
gets a list of those adapters when it starts up, and keeps the list updated while it is running. The 
port names reported by macOS depend on the information provided by the adapters. Some 
adapters have unique ID numbers that become part of the port name and do not change when 
macOS is rebooted. Others do not have unique ID numbers, so macOS assigns a mysterious ID 
based on the location of the device in the USB device tree each time it reboots, and so the device 
name will change if you plug the cable into a different port. 

You can find out if a USB-serial adapter has an ID as follows: 

✦ Open the System Information app (it’s in the Utilities folder inside your Applications folder) 

✦ Choose the USB item in the Hardware group in the sidebar 
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✦ Select a leaf in the USB Device Tree. USB-serial devices usually have “Serial” or “UART” in the 
name 

✦ If the properties for the selected item includes a Serial Number, the adapter has an ID 

Apple is gradually locking down access to macOS internals to improve security. Sooner or later, 
that will break the old way of dealing with USB-serial device “drivers” — called kernel extensions 
(kexts). Apple itself has been quietly replacing kexts with driver kit extensions (dexts) that handle 
some third-party devices. “Quietly” because I have yet to find documentation for which devices 
Just Work. By trial-and-error, I know that FTDI and the USB-serial device inside the YCCC SO2R 
Mini do Just Work. Caveat: the latter device is a widely-used inexpensive product that fails to 
specify a unique ID for each chip (FTDI does this). Also see the discussion by Don Agro. 

TCP Devices 
Communicating with a TCP device requires that you define the TCP IP address and port number for 
the device. You do this by choosing opening the appropriate window in the Window > External 
Devices > submenu, choosing the Type for the device, then tapping the Settings… button. 

The TCP Settings window title shows your device type, with 1 or 
2 appended for amplifiers and radios. The window has three 
fields: 

✦ IP — The network address for the device. This address must 
be reachable from your computer. If the device gets its 
address via DHCP, it may change; when that happens you 
will need to update this setting. Consider defining a static 
address for you device in your router. For example, the IP 
value for my K4 radio is 192.168.136.3. Note: For a K4 with 
R31 or newer firmware, you can use “K4-SNnnnnn.local” as 
the IP address, where nnnnn is the number shown by the 
Radio Serial Number menu item. 

✦ Port — The port number defined by the device for communication with logging software. The 
port number for all K4s is 9200. 

✦ MAC — This setting is disabled unless the device supports wake-on-LAN. For my KPA1500, 
which does support wake-on-LAN, the MAC value is 54:10:ED:D8:C3; 6 hexadecimal numbers 
separated by colons. If you get this format wrong, SkookumLogger will report the error to the 
Status window and wake-on-LAN won’t work until you correct the problem.  

Use the Enable checkbox to start communicating with a TCP device. If something causes a 
disconnect, the Enable checkbox will be turned off.  

Wake-on-LAN works a bit differently when the device is sleeping. You need to tap the Power On 
button to wake up the device. Once awake, you can use the Power On button to turn power off, 
which returns the device to sleep mode. 
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Port and Device Names 
A port name for a serial device is an uninformative combination of letters and digits provided by 
macOS, such as usbserial-A6043VCY. The port name is formed by macOS using the serial number 
provided by the USB-serial adapter chip, A6043VCY in the example. Some chip manufacturers do 
not supply a serial number, in that case macOS creates one based on the location of the adapter in 
the USB Device Tree. As a consequence, the port name for a serial device may change when 
plugged into a different place in the tree. 

Some radios present two serial port names on the same computer USB port. Normally you can use 
either port name in SkookumLogger, with the exception of ICOM radios, where the second port 
may not support CI-V. Generally, use the port name with the smaller last digit in the name for this 
case. 

SkookumLogger remembers the port name associated with each enabled device, so that it can re-
enable the device when starting up. This scheme will fail when the saved port name is not available 
because the port name changed. You will need to determine the new port name and choose that 
in the Port Chooser before re-enabling the device. 

To determine the association between an external device and the port name for the device, watch 
the Status Messages window while you unplug and replug the USB cable to the device. You should 
see a message like “Serial port usbserial-83420 became active”.  

You can, optionally, define a device name that will appear instead of the port name in port 
choosers, using the Port Device Name Editor. 

Port Device Name Editor 
Choose Window > External Devices > Port 
Device Name Editor to create a memorable 
name to be used in place of a port name. The 
Port column contains the port names of every 
serial device that SkookumLogger has seen. The 
names in the Device Name column are initially 
the same as the port names, but you can edit 
cells in that column. For example, I’ve associated 
‘usbserial-A1025HQ3’ with my WinKeyer SMT. 
The names you see in Port Choosers are the 
names in the Device Name column that are 
currently connected. So, if the usbserial-410 port 
isn’t plugged into an external device, it won’t 
show up in port chooser list. Device names that 
you create must be unique. 

Delete Entry can be used to thin out the list. 
Each time macOS reports a newly discovered 
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serial port to SkookumLogger, the port name is added the the table in the Device Name Editor, 
unless it is already there. 
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Port Choosers 
The Port popup list for a serial device shows a list of the RS232 serial ports 
connected to your computer. The names in the list are either port names, or 
device names that you have defined as aliases for port names. Ports in the 
list that are in use (enabled) are grayed out so that you cannot try to use 
them for another device. 

When an enabled port becomes inaccessible in macOS, usually because 
either the cable was disconnected or the device was turned off, the lost port 
disappears from all port chooser lists. 

SkookumLogger remembers the port chooser selection and the Enable state. When starting up, 
SkookumLogger re-enables ports that were enabled when quitting. 

Type Choosers 
The Type popup list for an external device lists supported hardware 
names, such as types of radios. When you choose a list item, 
SkookumLogger shows the expected serial port properties for the 
selected hardware in small text below the chooser.You must ensure that 
the hardware is set to those properties.  

The Type chooser is disabled (grayed out) when the device is enabled.  

When the Type choice contains “TCP”, the Port popup button is replaced 
by a button labeled Settings… that opens the TCP Settings window. 

SkookumLogger remembers the last Type chooser selection when quitting. 

Phantom devices 
For some kinds of devices, such as radios and amplifiers, the device type choosers include a device 
named Phantom. This device type simulates the behavior of a basic real device. Simulation is 
useful, for example, when you don’t have a radio connected to SkookumLogger but you want to set 
frequency and mode for logging a QSO — you would text commands to do this after enabling the 
Phantom radio type. 
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Amplifiers 
Choose Window > External Devices > 
Amplifiers to open the window for managing 
your amplifiers. Amplifier 1 is associated with 
Radio 1 and similarly for Amplifier 2.  

Except for the ACOM 2000A, the Power On 
button can toggle the amplifier power on and 
off, and the Mode button can toggle the 
amplifier between Standby and Operate. For 
the KPA1500, the Tune ATU button starts the 
tune process for the amplifier and the bar 
graph displays amplifier forward power with 
250 W tick marks between 40 and 2000 W. 

The primary role of the amplifier interface is to control drive power based on whether the amplifier 
is in operate mode or standby mode. To do this, SkookumLogger needs to be able to read and set 
the transmit power level of your radio. You can define drive powers for each amplifier type, for 
each amplifier mode, for each contest band, and for each radio mode. The default drive powers 
are 25 W for operate mode and 100 W for standby mode. 

To define a drive power setting, set the radio band, mode and transmit power level, then tap the 
Save Drive Power button. To enable SkookumLogger control of drive levels, turn on the 
Automatically set drive power option. The Track Radio applies to the KPA1500 amplifier. When 
enabled, SkookumLogger sends the radio transmit frequency to the amplifier to select the 
appropriate ATU settings without transmitting. 

The Elecraft K3 or K4 with either the KPA500 or the KPA1500 combination and the AUX cable does 
all of this automatically, and also changes the amplifier band when the transceiver changes bands. 
For these radio-amplifier combinations, you should uncheck the option Automatically Set drive 
power and the 3 options. 

For the KPA1500 with firmware 3.03, SkookumLogger supports automatically choosing per-
frequency-bin ATU memories for up to 32 antennas. When the transmit antenna is changed, 
perhaps due to a radio frequency change, SkookumLogger tells the amplifier to change which 
memory to use. There is no need for keying the radio or for searching for best match. See About 
the KPA1500 Amplifier section in the Antenna Switching chapter. 

If you want to use drive power management without a serial connection to an amplifier, choose the 
Phantom amplifier type. 

Another role of the amplifier interface, for the ACOM 2000A only, is preemptively changing the 
ATU segment within a band when the radio transmit frequency changes to a new frequency that 
would cause a segment when transmitting begins. There is no configuration needed for this role.  

Note:  If you use Automatically set drive power with the ACOM 2000A, you should disable the 
RCU-programmed amplifier option that causes the amplifier to automatically return to OPR mode 
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following any STDBY period initiated by a “soft” fault.  Otherwise, it is possible that the amplifier 
will switch to OPR while an in-process message (such as from an F-key) is delivering RF from the 
transceiver at the level you have previously set for the amplifier’s STDBY mode, thus potentially 
overdriving the amplifier tube grids and triggering one or more faults, including total amplifier 
shutdown.  Alternatively, do not use Automatically set drive power. 
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Radios 
Radios are configured in the Radios window, opened 
via Window > External Devices > Radios. This user 
interface has changed in version 5.1. 

SkookumLogger supports connections to one or two 
radios at a time. You choose the type and enabled 
status for each radio. You control enabled radios via 
commands in the Radio 1 and Radio 2 menus. 

SkookumLogger reads and writes frequencies and 
modes; it is not a full-fledged radio control 
program.You can transmit on only one radio at a time. 
The transmit radio is identified by a red gumdrop in 
the corresponding QSO entry pane. 

The menu bar has a Radio 1 menu, and a Radio 2 
menu when the 2T2R operating mode is on. The top item in these menus is a label identifying the 
radio’s type. Other items on these menu depend on the capabilities of the radio. 

Two buttons, labeled R1 and R2, in the status bar at the bottom left 
corner of the Log window are green when the radio is enabled. 
Clicking a status button toggles the enabled status. Command-
clicking a radio status button also opens the Radios window. 

These options affect both radios: 

Prefer upper sideband in CW mode — Chooses which “sideband” to use when setting the radio 
mode to CW.  

Invert frequency step direction in LSB — Commands that step VFOs or RIT/XIT offset step the 
opposite direction in LSB, optionally Only in SSB mode. 

Change mode when changing frequency — Guess the appropriate mode using the phone sub-
band table when setting radio frequency. 

Radio spot tone toggle special key — A single key shortcut for turning the radio spot function on 
and off. 
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Radio Communication Settings 
SkookumLogger can communicate with radios connected to 
your computer via a serial UART, or via your computer’s LAN. 
Choosing a type in the Radios window opens a settings 
window to establish the properties for the connection. In the 
example the K4 TCP radio type supports a LAN connection 
using the TCP protocol, and the other two connection types 
are unsupported and disabled. For UART connections, you 
must choose the serial port name. For LAN connections, the IP 
address and port are required, some radios may also require a 
user name and password. Settings are remembered across 
restarts, but are not remembered per-radio type other than 
ICOM radios. 

Serial radios are polled to track things like frequency and 
mode. When the radio does not respond for more than about 
15 seconds, SkookumLogger posts an alert to inform you that 
the connection has died, and disables the connection. To 
recover after addressing the cause of the disconnect, open the 
Radios window and click the Enable button.  

ICOM Radios 
Use these settings in your ICOM radio: 

✦ CI-V Baud Rate: Auto 

✦ CI-V Address: Default for radio type 

✦ CI-V Transceive: On 

✦ CI-V USB Port: Unlink from [REMOTE] 

✦ CI-V USB Baud Rate: Auto 

If you make changes to the above, you should power cycle the radio. 

Some ICOM radios have two serial ports. Only the first port can be used for computer control. For 
example, these two port names might appear in the Serial Connection port chooser for an IC-7610: 

	 usbserial-120 

	 usbserial-130 

You should use the port name with the lower number. 

SkookumLogger supports either serial or UDP LAN connections for the IC-705, IC-7610, IC-7850 
and IC-9700. Both connection types support displaying the main receiver scope waveform data in 
the Panadapter window. The UDP connection is much more responsive for this role. 
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Flex Radios 
John, K1JSM, provided the information below. Please do not contact John if you have issues. 

Using a Flex radio with SkookumLogger requires communication between SkookumLogger and 
third-party software, instead of communicating with real hardware. SkookumLogger assumes the 
third-party software is SmartSDR for macOS, available on the App Store, and that SmartSDR is 
running on the same computer as SkookumLogger. To configure the connection: 

✦ In the SkookumLogger Radios window, choose Flex > SmartSDR in the Type dropdown list. 

✦ In the SkookumLogger Radios window, click the Settings… button, enter 127.0.0.1 for the IP 
and 5001 for the port. 

✦ In the SmartSDR CAT Control window, choose Kenwood TS-2000 CAT in the Type dropdown 
list, and set Port to 5001. 

✦ Enable the connection in each application. 

Radio 1 in SkookumLogger corresponds to CAT Control 1 in SmartSDR, and similarly for Radio 2. 
Each radio should use a different port. 

See Section 4 in the SmartSDR for Mac manual for more information. 

Using xCat 

As of SmartSDR version 2.3.06, there is a significant lag between changing frequency in SmartSDR 
and having the new frequency show in SkookumLogger. A workaround is to use the xCat 
application from Tom, DL3LSM. To configure this connection: 

✦ In the SmartSDR Radio > CAT Control window, uncheck enabled. 

✦ Open the xCat application, version 2.0 as of 1/1/2023, and add Slice A data.  

✦ Click the Edit… button and set the properties in the Edit CAT Port window.  
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✦ Open the SkookumLogger Radios window and set or confirm that the Radio 1 type is TS-2000, 
that the IP address is 127.0.0.1 and that the Port is 5002, to match the corresponding properties 
in xCat.  
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Test by changing frequencies in SmartSDR. SkookumLogger entry window should follow frequency 
changes almost instantly. Another test: open an activity window in Skookum, select a band, click on 
a spot and the radio should be immediately tuned to that spot’s frequency and mode. 
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CW Keyers 
The primary device for sending CW with SkookumLogger is a version 2 or version 3 K1EL 
WinKeyer. If your WinKeyer model has two KEY outputs, SkookumLogger can use it for 2T2R 
(SO2R) operation on the CW mode. The settings for a WinKeyer are adjusted in the Window > 
Morse Keyers window. 

Any keyer not sold by K1EL and claiming to be a WinKeyer or support the WinKeyer protocol is a 
software emulation. I’ve yet to encounter an emulation that wasn’t imperfect in one way or another. 
SkookumLogger supports two emulations, one in the YCCC SO2R Box+ and the other in the YCCC 
SO2R Mini. SkookumLogger has dedicated work-arounds for the defects in these emulations, but 
they still remain inferior to a true K1EL device. The CW settings for these emulations are adjusted in 
the Window > Morse Keyers window. The only reason to use these emulations if you have a real 
WinKeyer is to simplify the many physical connections needed for SO2R. 

Note: The YCCC SO2R Mini keyer needs corrected firmware. 

Note: JH5GHM has designed a substitute for the YCCC SO2R Mini called the Neo, which can be 
used by SkookumLogger in place of the Mini. The Neo has a different physical shape, status LEDs 
and other improvements, along with different firmware. 

You choose between a WinKeyer and an emulation with Use SO2R keyer in the Morse Keyers 
window. You choose which emulation to use in the YCCC SO2R window. You can enable a real 
WinKeyer and one of the emulations at the same time, then alternate between them with the Use 
SO2R keyer option. 

Each keyer setting has a help tag that describes its meaning and range of values. SkookumLogger 
remembers keyer property settings and applies them when you choose the active keyer. 

SkookumLogger associates the KEY 1 WinKeyer output with Radio 1 and the KEY 2 output with 
Radio 2. 

The Ratio and the Sidetone settings are not applicable to the YCCC SO2R keyers. For the SO2R+ 
Box, the range and resolution of the PTT Lead Time and PTT Tail Time settings are different, as 
described in the help tags.  

If you have a WinKeyer USB, the four buttons on the top of the keyer play the F1 … F4 messages. 

If you are using the SO2R+ Box in 2T2R mode, then you might also be using Alternating CQ mode. 
If so, you may notice that that last character of your CQ message is truncated because transmit 
focus is changed before the message is completely transmitted. To prevent truncation, add a space 
at the end of your CQ message. 

WinKeyer Mini  
This device, unlike WinKeyer USB, does not have a potentiometer on the front to adjust the speed 
of the CW. When using the WinKeyer Mini in SkookumLogger, you must use the application’s CW 
speed controls to change the speed. 
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WinKeyer Characters 
The spacing between characters and words in your CW messages can be fine-tuned using features 
of your WinKeyer: 

✦ To change the duration of the word space, change the Contest Spacing option in the Keying 
group in the Morse Keyers window. The standard duration for a word space is 7 units. Contest 
spacing shortens the duration to 6 units. This spacing was popularized by K1EA in his CT 
contest software, and is also known as “CT” spacing. 

✦ To fine-tune the spaces between characters or words, insert the vertical bar character (|) in your 
message definitions. The vertical bar character is the WinKeyer gap character. Each vertical bar 
adds a key-up delay of half a unit. 

A unit is the duration of the key-down portion of a dot, equal to 1200/speed in milliseconds, with 
speed in words per minute. The duration of a dash is 3 units. The duration of the space between 
dots and dashes forming a Morse character is 1 unit. The duration of the space between Morse 
characters is 3 units. 

You can use any of the characters recognized by the WinKeyer in Morse messages; unrecognized 
characters are ignored. You can use any of the recognized characters in Keyboard Mode as well, 
except that characters defined as Special Keys take precedence unless you enable Ignore Special 
Keys in Keyboard Mode in the Special Keys pane of Messages settings. 

Keyer Speed 
The current keyer sending speed for the QSO entry with transmit focus is displayed at the right 
edge of the entry pane. Changing transmit focus changes speed. 

You can change the speed with the keyer speed pot, with Messages >Morse > Step Speed Up and 
Messages >Morse > Step Speed Down, and with the Morse Speed Editor. The speed step size is 
defined in the Morse Speed Editor. 

The Messages >Morse > Set Pounce WPM command is hidden in 2T2R and disabled unless 
Pounce has transmit focus. The command searches the activity table for the current band for a 
match to the call in the Pounce call entry field. If a match is found and the activity specifies WPM in 
the Info column, your WinKeyer is silently set to that speed. The temporary override of Pounce 
WPM changes the color of displayed WPM The original speed is when you change transmit focus. 

The SO2R Box keyer SPEED pot behavior is different from a real WinKeyer. The Pot Minimum and 
Pot Range settings are ignored, instead the minimum is 15 WPM and the maximum is 45 WPM. 

The SO2R Mini does not have a speed pot. For either emulation, you can set speed to any value 
between 5 and 99 WPM using the Morse Speed Editor window or the Step Speed commands in 
the Messages >Morse > menu. 
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Antenna Switching 
SkookumLogger can control your antenna relays using a YCCC Master Of Antenna Switching 
(MOAS II) device. The technical documentation is the MOAS II Programming manual V1.0 linked at 
the end of the Downloads section at the MOAS II site. You may want to skim this document to learn 
about capabilities and terminology. The user interface for switching controls is a combination of 
menu items in the Radio menus, displays in the Map windows, and the XK-24 keypad. 

SkookumLogger reads a JSON file named AntennaConfiguration at startup to define your 
antennas, how they are related to your rotators, and how they are switched. This document 
describes the expected content of that file. 

A default configuration file is built into  SkookumLogger. The content of that file is listed below as 
an example. You can create your own configuration file with a plain text or JSON-aware editor and 
place it in the SkookumLogger support folder to override the default configuration. 

GQAntennaTest is an app for testing a configuration file outside SkookumLogger, where it can 
present details about issues that it may discover. Contact me for a copy of that app. 

SkookumLogger supports one MOAS, two radios, three rotators and 63 antennas. 

Configuration File Specification 
The configuration file is a plain text file that must conform to the JSON syntax. 

About JSON 

This is a brief description of the JSON syntax. Consult the internet for more definitive information. 

A JSON file contains a group of key – value pairs. A key is case-sensitive string with no spaces. A 
value is a string, a number, a boolean (true or false), a list (array), or a group (dictionary). Pair 
elements are separated by a colon. Each pair must end with a comma except the last pair in a 
group. The order of of pairs within a group does not matter. 

All strings must be wrapped in double quotes (but not curly quotes). Lists are wrapped in [ and ]. 
List elements are separated by commas. Groups are wrapped in { and }. 

In the following, keys appear in bold type, omitting the required quotes. 

Miscellaneous Top-level Pairs 

The optional Comment key has a string value. These pairs are ignored when loading the 
configuration. 

The required MOASSerialPortName key  has a string value. The MOAS port name will always begin 
with “usbserial-“ followed by 8 letters and digits. 

The optional HotSwitchDelay key has a number value, between 0 and 9999 ms. The default is 0 
ms. 

The required Antennas key has a list value. Each list element is a group describing a single physical 
antenna. 
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Antennas List Group Pairs 

The required AntennaID key has a unique number value between 0 and 63. 

The optional KPA1500AntennaID key has a unique number value between 1 and 32.  

The optional KPA1500AntennaPort key has a number value of 1 or 2. 

The required AntennaName key has a unique string value that appears on menus and the 
SkookumLogger maps. 

The optional KeyID key has a number value between 1 and 24 that associates the antenna with a 
XK-24 keypad key. 

The optional RotatorID key has a number value 1, 2, or 3, associating a rotator with the antenna. 
The presence of this key identifies the antenna as rotary. 

When RotatorID is present, the optional MainLobeOffsetFromRotatorBearing key has a number 
value in degrees. 

When RotatorID is not present, the required MainLobeBearing key has a number value in 
degrees that specifies the direction of the antenna pattern main lobe. For dipoles this is the 
broadside direction for the fundamental (halfwave) band.  

The optional ReceiveOnly key has a boolean value that treats the antenna differently from TX 
antennas. The RotatorID key is ignored and the MainLobeBearing is required. 

The optional IsSteppIr key has a boolean value that, for SkookumLogger, identifies the antenna is 
to be associated with a radio when selected for use with that radio. Then, SkookumLogger sends 
frequency change information for that radio to the SteppIr controller. 

The optional ConflictsWithOtherAntennas key has a list value containing other antennaID 
numbers that cannot be selected at the same time this antenna is selected. Each antenna always 
conflicts with itself. 

The required BandSegments key has a list value. Each list element is a group describing bands 
supported by the antenna. 

BandSegment Group Pairs 

The optional IsDefault key has a boolean value that identifies the antenna as the default choice 
for the band of segment. 

The required BandName key has a string value that is one of the band names supported by 
SkookumLogger or “Any”. The SkookumLogger band names are: 160m, 80m, 40m, 30m, 20m, 17m, 
15m, 12m, 10m, 6m, 4m, 2m, 125cm, 70cm, 33cm, and 23cm. “Any” supports dummy loads. 

The optional Radio1Only and Radio2Only keys have boolean values that flag a band segment as 
useable for only one of the two radios. This supports separate dummy loads for each radio. 

The required PatternTypeName key has string value that identifies the characteristics of the 
azimuthal antenna pattern for drawing on the SkookumLogger great circle maps. The recognized 
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values are Omnidirectional, Unidirectional, Bidirectional, DipoleHarmonicA, DipoleHarmonicB, and 
DipoleHarmonicC. Case matters. 

The three DipoleHarmonic patterns apply for half-wave dipole operated on a higher frequency, A 
for an 80m dipole used on 15m, B for a 40m dipole used on 15m, and C for a 40m dipole used on 
6m. All of these patterns are four-lobe cloverleafs with a null in the direction specified by the 
MainLobeBearing value, with slightly different lobe orientations and lobe beamwidths. I estimated 
the lobe orientations and beamwidths using miniCocoaNEC for dipole a 60 high over average 
ground to generate the azimuth pattern at the elevation angle for the first peak in the elevation 
plane. Lobe beamwidth is the full angle between points 5 dB (one S-unit) down from the lobe 
peak. The values are built into SkookumLogger. 

The MainLobeBeamwidth key is required for Unidirectional and Bidirectional patterns, with number 
value in degrees. 

The required Radio1Relays key has a list value. The list elements are MOAS relay numbers 
between 0 and 63. 

The optional Radio2Relays key has a list value. The list elements are MOAS relay numbers 
between 0 and 63. 

The optional Radio1AlternateRelays key has a list value. The list elements are MOAS relay 
numbers between 0 and 63. See Alternate Relays. 

The optional Radio2AlternateRelays key has a list value. The list elements are MOAS relay 
numbers between 0 and 63. See AlternateRelays. 

Default Antenna Configuration 
{ 
"Comment" : "MOASSerialPortName required, begins with usbserial- for the FTDI UART", 
"Comment" : "HotSwitchDelay optional, number between 0 and 9999 ms", 
"Comment" : "Antennas required, a list of groups", 
"Comment" : "Antenna list element -- a group", 
"Comment" :   "AntennaID required, between 0 and 63", 
"Comment" :   "AntennaName required, will appear on menus", 
"Comment" :   "KeyID optional, between 1 and 24", 
"Comment" :   "MainLobeBearing required for non-rotary directional antennas, degrees", 
"Comment" :   "RotatorID required for rotary antennas, between 1 and 3", 
"Comment" :   "MainLobeOffsetFromRotatorBearing optional, degrees, for rotary antennas", 
"Comment" :   "ReceiveOnly optional true, omit for transmit antennas", 
"Comment" :   "ConflictsWithOtherAntennas optional", 
"Comment" :   "BandSegments required, a list of groups", 
"Comment" :      "BandSegment list element -- a group", 
"Comment" :        "IsDefault, optional true, omit unless antenna is the default for this 
frequency segment", 
"Comment" :        "BandName required, string", 
"Comment" :        "PatternTypeName required, string one of Omnidirectional, 
Unidirectional, or Bidirectional", 
"Comment" :        "MainLobeBeamwidth required except for Omnidirectional, full angle 
degrees", 
"Comment" :        "Radio1Only optional, true if segment is available only for radio 1", 
"Comment" :        "Radio2Only optional, true if segment is available only for radio 2", 
"Comment" :        "Radio1Relays optional, list of values between 0 and 63", 
"Comment" :        "Radio2Relays optional, list of values between 0 and 63", 
"Comment" :        "Radio1AlternateRelays optional, list of values between 0 and 63", 
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"Comment" :        "Radio2AlternateRelays optional, list of values between 0 and 63", 

"MOASSerialPortName" : "nada", 

"Antennas" :  
    [ 
        { 
        "AntennaID" : 1, 
        "AntennaName" : "40m Receive Vertical", 
        "ReceiveOnly" : true, 
        "BandSegments" :  
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "40m", 
                "PatternTypeName" : "Omnidirectional" 
                 } 
            ] 
        }, 
        { 
        "AntennaID" : 2, 
        "AntennaName" : "Tribander", 
        "RotatorID": 1, 
        "BandSegments" :  
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "20m", 
                "PatternTypeName" : "Unidirectional", 
                "MainLobeBeamwidth" : 60 
                 }, 
                 { 
                "IsDefault" : true, 
                "BandName" : "15m", 
                "PatternTypeName" : "Unidirectional", 
                "MainLobeBeamwidth" : 55 
                 }, 
                 { 
                "IsDefault" : true, 
                "BandName" : "10m", 
                "PatternTypeName" : "Unidirectional", 
                "MainLobeBeamwidth" : 50 
                 } 
            ] 
        }, 
        { 
        "AntennaID" : 3, 
        "AntennaName" : "80m Dipole", 
        "MainLobeBearing" : 50, 
        "BandSegments" :  
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "80m", 
                "PatternTypeName" : "Bidirectional", 
                "MainLobeBeamwidth" : 100.0 
                 } 
            ] 
        }, 
        { 
        "AntennaID" : 4, 
        "AntennaName" : "40m Dipole", 
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        "MainLobeBearing" : 50, 
        "BandSegments" : 
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "40m", 
                "PatternTypeName" : "Bidirectional", 
                "MainLobeBeamwidth" : 80.0 
                 } 
            ] 
        } 
    ] 
} 

About the KPA1500 Amplifier 
This Elecraft product has two output ports labeled ANT 1 and ANT 2. The internal antenna tuner 
remembers settings per frequency bin and per port. Firmware version 3 introduced the ability to 
remember settings for up to 32 virtual antennas. The virtual antennas are described in the antenna 
switch configuration file by KPA1500AntennaID and KPA1500AntennaPort. Each transmit antenna 
in the file may optionally include these key-value pairs. The antenna ID value must be unique 
across all antennas and between 1 and 32, and should not be used for receive-only antennas. The 
antenna port value should be 1 or 2; if not specified then the port is set ANT 1. 

SkookumLogger uses these two key-value pairs when opening a TCP or serial connection to the 
amplifier, to establish the set of virtual antennas and their ports. Once configured, changing the 
current transmit antenna or band also changes the amplifier ATU settings. 

About the XK-24 Keypad 
The XK-24 USB keypad has 24 keys, each with a blue backlight, a red backlight, and a user-
customizable label. SkookumLogger automatically discovers the device at startup. The Window > 
External Devices > XK-24 Keypad window has an array of 24 menus for associating key presses 
with SkookumLogger functions. These are the functions relevant to antenna switching: 

Select Antenna for Key ID — Select the transmit antenna associated with the key’s ID in the 
configuration file. Press a key and release within one-half second to select the antenna for 
Radio 1. Press and hold for more than one-half second to select the antenna for Radio 2. 

Select Receive antenna for Key ID — Select the receive antenna associated with the key’s ID 
in the configuration file, for Radio 1. 

Select Best Antennas — Choose the transmit and receive antennas with main lobe bearings 
closest to the Radio 1 target station bearing. 

Rotator > Set Rotator n to Target Bearing — Turn rotator 1, 2, or 3 to the Radio 1 target 
bearing. 

When a key is pressed and released, the XK-24 Keypad displays the Key ID. 

When a transmit antenna is selected for Radio 1, the blue backlights for other Radio 1 transmit 
antennas are turned off and the blue backlight for the selected antenna is turned on. If the 
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selection causes a MOAS conflict, the blue backlight blinks, indicating that Radio 1 has no transmit 

antenna. The red backlights behave similarly for Radio 2. 

About GQAntennaTest 
This test app reads a configuration file and has a simple window that displays antenna choices and 
status, input fields for setting radio frequencies, and a button for a Swap TX Antennas function. The 
menu bar has Radio 1 and Radio 2 menus which display TX and RX antennas available for the 
current frequencies and choose which antennas are selected. 

Terminology: 

Select means enable a specified set of antenna relays. 

No Antenna means no TX antenna relays are selected, typically due to a conflict. 

Conflict means that MOAS has rejected a selection request, as, for example, trying to use the same 
antenna for both radios. 

Loading a Configuration 

After starting GQAntennaTest, use File > Open to load a configuration file. If the syntax of the file is 
incorrect, macOS will display this unhelpful alert: 

The best way to find syntax errors is to copy the text of the configuration file and paste into an 
online JSON validation site. http://json-validator.com is ugly but effective. Indenting is unnecessary 
but helpful. BBEdit has a JSON mode that detects some types of errors, handles indentation, and 
understands how to edit plain text. 
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When loading the file, GQAntennaTest confirms that no required keys are missing, and that no keys 
are unknown. Optional keys can be omitted. After loading, Several sanity tests are run: 

All BandSegment.BandName and BandSegment.PatternTypeNames values are valid. 

All BandSegments with IsDefault value true are for different bands. 

Antenna.MainLobeBearing is specified for all antennas except rotary antennas and 
Omnidirectional antenna patterns. 

BandSegment.MainLobeBeamwidth is specified when the BandSegment.PatternTypeName is 
either Unidirectional or Bidirectional. 

You can load the same or a different configuration file without restarting the app. 

Startup 

After loading a configuration, the test app attempts to set up and activated the MOAS. If only a 
“loaded” configuration message appears in the status box, either the MOAS is not powered on, the 
USB cable is not connected, or the port name is wrong in the configuration file. 

Behavior 

When activation succeeds, the test app sets initial frequencies for the two radios, resulting in initial 
TX antenna selections. You can choose various antennas from the Radio 1 and Radio 2 menus, and 
enter frequencies in kHz to see how the configuration reacts. 

2T2R Interlock 
To guarantee that the radios cannot transmit at the same time, connect the radio KEY OUT lines to 
MOAS TX inputs 1 and 2, and the corresponding MOAS INHIBIT outputs to the radio inhibit inputs.  

Antenna Hot-switch Prevention 
To guarantee that an in-use antenna won’t be changed while transmitting, connects the radio KEY 
OUT lines to the MOAS TX inputs 1 and 2. MOAS will delay changing the TX antenna while 
transmitting until after the TX input has been high (not transmitting) for the number of milliseconds 
specified by the HotSwitchDelay value. For example when using QSK, to prevent switching between 
code elements and letter spaces and to allow switching during word spaces, set the delay to 200 
ms. The duration of a word space with CT spacing is 240 ms at 30 WPM. 

Conflicting Antennas 
The two radios cannot select the same antenna; this is a conflict condition detected by MOAS. You 
can add other conflict conditions that prevent selecting other antennas when an antenna is in use. 
The outcome of a conflict is to select “No Antenna” (no relays) for the radio that caused the conflict. 

Frequency Changes 
The BandSegment groups for an antenna determine the bands that the antenna supports. When a 
radio frequency change is a band change, the app creates a list of all antennas with segments that 
contain the new band, and updates the radio menus. Then an antenna for the radio is selected: 
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first, select the previous antenna for the new band, if not found select the default antenna in the list, 
if not found select the first antenna in the list. 

Dummy Load 
When a segment band name is “Any”, the antenna (typically a dummy load) will always appear on 
the menu. If it is the only item on the menu, then it will be selected by the above rule when a radio 
changes to a band with no antennas. Use the Radio1Only and Radio2Only keys to create two dummy 
loads that do not conflict. 

Receive Antennas 
The antennas listed in the TX Antennas menu may be used for both transmitting and receiving. The 
antennas listed in the RX Antennas menu have the ReceiveOnly value equal to true. These antennas 
do not conflict with TX antennas or other RX antennas. Instead, whichever RX antenna was most 
recently selected is used for both radios. This handles my receive antenna, which has eight 
directions switched by MOAS, one direction at a time, and will work for remotely-switched 
beverages that share a common feed line into the shack. 

Swap TX Antennas 
This function interchanges the two radios’ transmit antennas, only if swapping would yield usable 
antennas on both radios. If not, nothing changes.  

Alternate Relays 
An alternate set of relays for a TX antenna segment is used to select a different antenna for a radio 
while the other radio is transmitting. Radio1AlternateRelays applies when radio 2 is transmitting, 
and Radio2AlternateRelays applies when radio1 is transmitting. If the array of relay IDs is empty, 
“No Antenna” will be selected. If the pair is not present in the segment configuration, the selected 
antenna will not be switched. 

Using the Configuration File with SkookumLogger 
Name the file AntennaConfiguration.json and place it in the Application Support folder. If you edit 
the file, you will need to restart SkookumLogger to reload the file. 

SkookumLogger does most of the sanity testing that is performed by GQAntennaTest, but displays 
issues only to the debug log. 

Default Antenna Configuration 
The default configuration describes four antennas, a receive-only vertical for 40m, a tribander for 
20m, 15m and 10m, and dipoles for 40m and 80m. The tribander is associated with Rotator 1. 
{ 
"MOASSerialPortName" : "nada", 
"Antennas" :  
    [ 
        { 
        "AntennaID" : 1, 
        "AntennaName" : "40m Receive Vertical", 
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        "ReceiveOnly" : true, 
        "BandSegments" :  
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "40m", 
                "PatternTypeName" : "Omnidirectional" 
                 } 
            ] 
        }, 
        { 
        "AntennaID" : 2, 
        "AntennaName" : "Tribander", 
        "RotatorID": 1, 
        "BandSegments" :  
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "20m", 
                "PatternTypeName" : "Unidirectional", 
                "MainLobeBeamwidth" : 60 
                 }, 
                 { 
                "IsDefault" : true, 
                "BandName" : "15m", 
                "PatternTypeName" : "Unidirectional", 
                "MainLobeBeamwidth" : 55 
                 }, 
                 { 
                "IsDefault" : true, 
                "BandName" : "10m", 
                "PatternTypeName" : "Unidirectional", 
                "MainLobeBeamwidth" : 50 
                 } 
            ] 
        }, 
        { 
        "AntennaID" : 3, 
        "AntennaName" : "80m Dipole", 
        "MainLobeBearing" : 50, 
        "BandSegments" :  
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "80m", 
                "PatternTypeName" : "Bidirectional", 
                "MainLobeBeamwidth" : 100.0 
                 } 
            ] 
        }, 
        { 
        "AntennaID" : 4, 
        "AntennaName" : "40m Dipole", 
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        "MainLobeBearing" : 50, 
        "BandSegments" : 
            [ 
                { 
                "IsDefault" : true, 
                "BandName" : "40m", 
                "PatternTypeName" : "Bidirectional", 
                "MainLobeBeamwidth" : 80.0 
                 } 
            ] 
        } 
    ] 
} 
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Antenna Rotators 
Rotators are configured in the Rotators window, opened via Window 
> External Devices > Rotators. 

SkookumLogger can control up to 3 rotators. Commands in the 
Rotator menu set rotator bearing:  

✦ Rotator > Set Rotator x to Target Bearing turns rotator x to the 
bearing for the target, where x is 1, 2, or 3. 

✦ Rotator > Set Rotator x to Target Long Path Bearing turns rotator x 
to the long path bearing for the target. 

✦ Rotator > Automatically Turn Rotator x turns rotator x to the bearing 
for the target whenever the target changes. 

✦ Rotator > Stop Rotator x halts rotating of rotator x. 

✦ Rotator > Stop All Rotators halts all rotators. 

These commands are hidden when the corresponding rotator is not enabled. The target bearing is 
determined by the call in the active QSO entry pane. When the target isn't defined, the Set Rotator 
x commands are disabled. 

Clicking with various modifier keys on a point in a Map window can also control rotator bearing.  

The bearing text command applies for Rotator 1. 

To connect to such a device, choose Window > External Devices > Rotators and select the correct 
rotator Type and Port. Check the Enable option for the Rotator and where supported, the bearing 
will be displayed under the checkbox. 
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SteppIr Controller 
SkookumLogger can interface with the “Data In/Radio” serial port on an SDA 100 controller in 
order to automatically adjust the antenna to the transmit frequency of Radio 1. The optional 
Transceiver Interface for the SDA 100 is required. To enable this feature: 

✦ Connect your computer to the Data In / Radio port through a USB-serial adapter and a 
crossover RS-232 cable with only RXD, TXD, and GND pins wired. 

✦ Set up the SDA 100 Transceiver with Din = 38400 and Mode = 9000D. 

✦ Enable the SDA 100 Autotrack mode. 

✦ Choose Window > External Devices > Antennas. 

✦ Select the SDA 100 serial port in the SteppIr Port chooser and check the Enable SteppIr option 
in the Antennas window. 

When Radio 1 changes transmit frequency and the new frequency differs from the previous 
frequency by more than 9 kHz, SkookumLogger sends the new frequency to the SDA 100. The 9 
kHz hysteresis prevents unnecessary antenna adjustments if you happen to change transmit 
frequency often across an SDA 100 tuning segment boundary. 
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SO2R Mini Firmware 
The YCCC SO2R Mini is an Arduino-based computer-controlled device that provides computer 
controlled switching of two radios, including audio routing for stereo headphones and a 
microphone, foot switch control of radio push-to-talk (PTT), and CW keying and PTT via an 
emulation of the K1EL WinKeyer by K3NG. Learn more at SO2R Mini Web Site. 

SkookumLogger fully supports the Mini. However, the firmware has several bugs. You can eradicate 
them by updating the Mini firmware. The update procedure that is provided on the SO2R Mini web 
site is unsuitable for macOS. Use these steps to do the update on macOS: 

✦ Install the avrdude app following the instructions at this page. 

✦ Download this hex file, provided by JH5GHM. 

✦ Connect the Mini USB cable to your mac. 

✦ Determine the port name for your Mini using SkookumLogger. It will be like usbserial-1420. 

✦ Disable the Mini in SkookumLogger if it is enabled. 

✦ Open Terminal and change directory (cd) to the the folder containing the downloaded hex file. 

✦ Enter this command, replacing "usbserial-1420" with the port name for your Mini: 
avrdude -c arduino -p atmega328p -b 57600 -P /dev/cu.usbserial-1420 -U 
flash:w:k3ng_keyer.mini.hex 

Neo owners can apply the same procedure using this hex file, changing k3ng_keyer.mini.hex to 
k3ng_keyer.neo.hex in the command, and holding the upload button while running the command. 
The upload button is on the bottom of the Neo. 
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SkookumNet 
SkookumNet is the name of a service that SkookumLogger creates for interconnecting different 
computers running SkookumLogger on your local network. When a member of SkookumNet logs a 
QSO, that QSO is added to the logs of all other members. Similarly, when a member of 
SkookumNet creates an activity, that activity is added to the activity tables of all other members. 
SkookumNet also handles editing of logged QSOs, and deletion of logged QSOs and of activities. 
All network members must be running the same version of of SkookumLogger. 

To participate in the network, 
Choose Window > 
SkookumNet, then click the 
Join SkookumNet button. The 
window title will change to 
show your Host name, which is 
defined by Local hostname in 
your System Sharing settings. 
To stop participating, click the 
Leave SkookumNet button. To 
resume participation, click the 
same button again. You can 
close and reopen the window 
without affecting whether or 
not you are participating. 

Members of the network are 
listed in the table at the 
bottom of the window. If a 
member’s log is inconsistent 
with others, its name in the 
Host column is adorned with a 
icon and colored. Hover over 
the name to see a tooltip 
explaining the issue. There are 
two cases: different contest 
rules and different log 
content. 

In the case of different contest 
rules, The icon is ✖︎ and the 
color is red. To resolve the 
problem, leave the network on 
the offending host, load the 
correct contest and, if 
necessary, adjust settings in Time Tracker. Then rejoin SkookumNet. 
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In the case of different log content, the icon is ↓↑ and the
color is orange, and the tooltip suggests merging the logs 
as described below. Peers must remain joined during this 
operation. 

Partner Mode 
When you enable Partner Mode, anything that you type into 
your Run call field appears as prompt text next to the Run call 
field of all SkookumNet members. Two operators listening to 
the same frequency can help each other copy call signs 
without need for intercoms or shouting.  

Log > Grab Partner Call copies the prompt text into the call field of the active QSO entry pane. 

To set the partner station to the same band and mode as another member, select a QSO in the log 
table that was made by that member — identified in the Station column — and choose Log > Set 
Radio from QSO. You can skip the select-a-QSO step if you want to “net” to the most recently-
logged QSO. 

To prevent accidentally logging QSOs on the partner computer, enable Refuse to log any QSOs in 
Logging settings. 

Gab 
The single line text field near the top of the SkookumNet window is the Gab input field, while the 
larger resizable text field below shows gab messages from all network members. 

Type into the single-line Gab input pane and tap return to send what you have typed to all 
SkookumNet members. Use Log > Toggle Gab to quickly alternate between the gab entry field and 
your Log window. Use Gab for alerting others about a pass, or perhaps for posting a limerick. 
When a gab message is posted, the gab message is highlighted with your Buddies color for 30 
seconds. 

Merge 
The Merge features synchronizes the logs of all SkookumNet members. To merge, tap the Merge 
Logs button on the computer for the member with the largest number of QSOs. 

First, the log of each of the other members is merged into the log that started the merge. When 
each merge is completed, the outcome is reported in the Status Messages window. When 
members have been merged, their logs are replaced by the updated primary log. Merging blocks 
keyboard input while underway to prevent changing the logs while merging. A progress indicator 
spins next to the Merge Logs buttons while the merge is underway. Merging can be time-
consuming; for example, merging two I47P WRTC logs with 4290 QSOs takes about 50 seconds on 
M1 MacBookPro and M1 MacStudio. 
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To replace the log on a member without the merge overhead: 

✦ Clear out the log to be replaced using Log > Reset Log. 

✦ Tap Merge Log on the primary host. 

Merging a log with no QSOs into the primary log is very fast. Use this approach when you add a 
new member to the network during a contest and you are certain that no QSOs were made with 
the new member while it was not connected to the network. 

Member Information 
The table at the bottom of the 
SkookumNet window shows 
the Run and Pounce transmit 
frequencies and modes for all 
members in the network. Resize 
the window or drag the splitter 
dot to see more than two members.  

A checkmark indicates which QSO entry pane has transmit focus. When you send a CW message 
that includes the QSY Frequency token, SkookumLogger uses the frequency (in kHz) for the pane 
with transmit focus in the selected row in the table. 

The Q/h and QP/h columns show the QSOs per hour rate and the QSO points per hour rate, 
respectively, for the last ten QSOs made by each host. 

Technical Details 
SkookumNet uses zero-configuration (Bonjour) networking via Multipeer Connectivity. Members of 
the network are equal peers with reliable (TCP) communications; there is no master computer, and 
there is no unreliable broadcasting (UDP). Although the default limit to the number of peers is 
eight, SkookumNet has not been tested with more than four members. 

Merging combines unique QSOs from all logs into a master log, then replaces the logs on each 
network member with the master. Each QSO has a UUID created by the computer that created the 
QSO. Two QSOs in different logs are the same when their UUIDs are equal. 

In addition to the member information above, each peer keeps track of a hash of all of its QSOs. 
Upon receiving any QSO-changing message (add, change, delete, replaceAll) a peer computes a 
new hash and sends a peer information message with the updated hash value. 

When a peer receives an information message from another peer, it compares its hash with the 
hash in the message and notes the current time if the hashes differ. If the mismatch persists for 
more than 10 seconds, the host is colored orange and gets the sync icon and tooltip. The host 
returns to black (no icon or tooltip) once the peers agree on a hash (e.g., after merging). 

The 10 second buffer avoids spurious blips where, for example, a QSO add message has been 
logged and sent to a peer, but the information message with the hash value that includes that QSO 
hasn't been received from the peer yet. 
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Broadcasts 
SkookumLogger has several output-only features for sending information to other apps. 

Distribute Score 
WA7BNM has created a Score Distributor web site that forwards information from your log to a 
collection of sites called online scoreboards that display received information in a web browser. 
You can learn more about the Score Distributor here. 

In SkookumLogger 2.6.4 or newer, to periodically send your log information to the distributor 
during a contest, enable Distribute Score in Logging settings. Of course, this feature requires an 
internet connection. 

SkookumLogger sends your class and score to the scoreboards. It does not send QSO or multiplier 
totals, or any breakdown counts. Some may regard this as a limitation. I regard it as a feature; why 
give your competitors information they can use to help them beat you? 

This is an optional feature that defaults to OFF. However, if you watch an online scoreboard, you 
should also be a good citizen and share your log information. 

See Score XML Document for an example. 
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Audio Recording 
SkookumLogger has three kinds of stereo audio recorders: 

✦ The QSO recorder creates a short audio file each time you log a QSO. 

✦ The Snippet recorder begins recording when you turn it on and stops when you turn it off. 

✦ The Event record automatically runs between the start and end dates of a contest. 

You can run one or more of these recorders at the same time. When at least one recorder 
is running, a bullseye recorder icon at the lower right corner of the Log window. You can 
click this icon to open the Audio Recording window.     

The set of recorders is enabled by Enable audio recording in Logging settings. The recording icon 
is hidden when this setting is off. You may need to enable access to “Microphone” for 
SkookumLogger in System Settings > Privacy and Security. 

The audio file type is m4a (Apple Lossless, ALAC), a stereo format native to macOS and usable by 
any sound player that runs on macOS. A one-hour recording creates approximately a 500 MB file. 

Window > Audio Recording opens the window for 
interacting with the recorders. 

Audio Source determines which audio input on 
your Mac is used. In the example, I used Audio 
MIDI Setup to assign K4 Audio In as the name of 
my radio’s USB Audio Codec. 

Some of the items in the Recorder boxes are 
disabled when the Enable audio recording setting 
is off. The Open … buttons are always available for 
accessing existing recordings. Opening a folder 
shows the folder in Finder. Opening a recording 
opens the audio file in your default audio file, 
which QuickTime Player unless you have defined 
a different default. 

QSO Recorder 
Choose Enable to make a recordings each time 
you log a QSO. The recording begins Leading 
Seconds before to Trailing Seconds after you 
logged the QSO. You can change these values 
while Enable is on. The file names for these 
recordings constructed from the QSO record, like 
this: 
20230818-161442-JE6RPM-K1GQ-20m-CW 

The date and time are UTC. 
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Note: This recorder assumes the audio source corresponds to Radio 1. 

Open Recordings for Selected QSOs opens recordings for each of the QSOs that are selected in 
your log table. 

Snippet Recorder 
A snippet can be made at any time, starting when you turn on Record Snippet and ending when 
you turn it off. The file name is constructed from the start time, like this: 
snippet-20230823-152918 

Open Latest Snippet Recording sorts on the names of all of your snippet files and opens the last 
one in the sort. For a snippet that you want to save, copy the recording to another folder and 
rename it appropriately. When the contents of the snippets folder becomes unmanageable, delete 
all the snippet recordings. 

Event Recorder 
Record Event enables continuous recording for the duration of a contest, beginning at the start of 
the contest and ending when the contest ends. If the contest has mandatory off periods, recording 
is automatically paused and resumed. You can manually pause and resume with the Pause button. 
Normally there will be one event recording file for contest, named like this: 
20230823-150000-03Z Medium Speed Test 

If you turn Record Event off, then back on during the same contest, an additional event recording 
file will be created with “-n” appended to the file name, where n is an integer. 
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WRTC 2022, K1GQ 
Note: This chapter is now a template to be updated when WRTC 2026 rules are published. 

How to set up special behavior required by the WRTC 2022 rules. The entrants use two stations 
connected via SkookumNet. 

Preparation 
1. For each computer (Assumes macOS 13 Ventura) prepare system settings: 

1.1. In System Settings/Network: 

1.1.1. Select Wi-Fi and set to Off. 

1.1.2. Select Ethernet, click Details… button: 

1.1.2.1. Configure IPv4: Manually 

1.1.2.2. IP Address: 192.168.73.1 (radio A) and 192.168.73.2 (radio B) 

1.1.2.3. SubNet Mask: 255.255.255.0 

1.2. (optional) In System Settings/General/Sharing, click the Edit… button in the Local 
hostname box to set Station Names for each computer, for example, A and B. 

2. Install HamConnect on one computer. 

3. For each computer prepare SkookumLogger and SkookumNet: 

3.1. Create a new World Radiosport Team Championship 2022 log. 

3.2. Choose the operator for this computer from the Log > Operator > menu. 

3.3. Download the Countries Database, File > Download Countries Database (needs internet 
connection). 

3.4. Change the Great Circle Map if necessary. 

3.5. Review the Cabrillo Header and Soapbox items in the Log Settings Sheet. 

4. Restart SkookumLogger on each computer. The table at the bottom of the SkookumNet window 
should have an row for each computer. Send a Gab message on each of the computer to 
confirm the network is functioning. 

Things That Are Preset When the Log Opens 

✦ DX Cluster is disconnected. 

✦ SkookumNet is joined (connected). 

✦ SCP and Exchange database are disabled. 

✦ IARU Society pre-fill is disabled. 

✦ Score distribution is enabled. 

✦ Some Cabrillo Category items are wired: 
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self.category.assisted = @“Non-Assisted"; 
self.category.band = @“All”; 
self.category.mode = @"Mixed"; 
self.category.hostCall = @"I4WRTC"; 
self.category.operator = @"Multi-Op"; 
self.category.overlay = @"None"; 
self.category.power = @“Low"; 
self.category.station = @“Fixed”; 
self.category.time = @"Not Applicable"; 
self.category.transmitter = @“Two”; 

Operator list is set to JH5GHM and WA1Z. 

Things to do in the 15 Minutes Before the Contest Starts 
For each computer: 

1. Log > Reset Log if the log has any QSOs. 

2. Change the sent Call to the call provided by the referee, in Window > Editors > Sent Exchange 
Editor. 

Things to do After the Contest 
1. If the two logs have different QSO counts or scores, choose the Merge Logs button in the 

SkookumNet window on either computer. Merging will take a minute or so; wait for the 
indefinite progress indicator to the right of the Merge button to disappear before proceeding. 

2. Sort the log on the SQ column and fix any obvious typos, like zone appended to call with empty 
Info field. 

3. Optionally, In Log > Cabrillo Settings… change Host Call to the call provided by referee or the 
referee’s call. 

4. Optionally, uncheck the Mark suspect QSOs as X-QSO option in New Log settings. You may 
want to do this if a QSO is marked suspect because SkookumLogger thinks the society code is 
wrong. 

5. File > Export Cabrillo…, then copy the file to referee-provided USB flash drive. 

6. File > Statistics Report for yourself. 

Other Notes 
If the ethernet switch fails, you can directly connect the two computers with one ethernet cable; a 
crossover cable is not required. 

Technical Details 
Merging during the contest 

When the two logs have different QSO totals, you can opt to do the merge procedure. Normally, as 
long as SkookumLogger is running on each computer and SkookumNet is working, every QSO 
added, edited, or deleted appears identically in both logs. The only reason I can think of to merge 
during the contest is that the logs got so badly out of sync — probably because one computer was 
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offline while the other made many QSOs — that duplicate checking is seriously degraded. Be sure 
to shut down SkookumLogger on the referee computer while you do this. 

Score Broadcasting 

The score is broadcast every 5 minutes between the beginning of the contest and the end of the 
contest + 5 minutes. The score document is sent to http://scoredistributor.net via an http POST. 

Score XML Document Example 
<dynamicresults> 

<contest>WRTC</contest> 
<call>I2WIJ</call> 
<class ops="MULTI-OP" mode="MIXED" power="LOW" bands="ALL" transmitter="TWO" 
assisted="NON-ASSISTED"></class> 
<score>173863</score> 
<timestamp>2023-06-02 18:19:06</timestamp> 
<opcall>WA1Z</opcall> 
<opcall>JH5GHM</opcall> 
<station>Fixed</station> 
<soft>SkookumLogger</soft> 
<version>3.16.10</version> 
<optime>00:00</optime> 
<breakdown> 

<qso band='total' mode='ALL'>431</qso> 
<mult band='total' mode='ALL' type='country'>107</mult> 
<mult band='total' mode='ALL' type='state'>20</mult> 

</breakdown> 
</dynamicresults> 
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Alternative Keyboards, W2RU 
For my main contest operating position, I have used various Apple wide aluminum keyboards over 
the years — first with a 27” iMac and now for the past few months with a base model M1 Mac Mini 
running Sonoma. As many of you know, these keyboards require only a very gentle touch when 
typing with them. 

During the February 2024 ARRL DX CW weekend, I noticed while Running that I had developed a 
tendency to let the middle finger of my right hand drop onto my keyboard, especially when I was 
relaxed. My touch-typing “home position” puts that finger on the “K” key and I found — often after 
the fact — that callsigns I was entering were containing spurious instances of the letter “K”. 

In April, while loitering at the Apple display area in a nearby Best Buy store, I spotted an after-
market keyboard I had not seen before. It turned out to be a Logitech MX Keys for Mac (aka MX-3), 
which I had never heard of. After playing with the demonstrator for a few minutes on the display 
table, I immediately ordered one!  In particular, it seemed to require just enough additional 
pressure on the keys to effectively eliminate my problems with spurious “K”s in entered text.  

Unfortunately, the introduction of the MX-3 into my operating position occurred at the same time I 
was switching from my obsolete iMac that was maxed out on OS upgradeability at Catalina to my 
new M1 macMini running Sonoma. And later in the conversion process I added Keyboard Maestro 
to my active utilities. (Never change two — much less three — items of your station configuration at 
the same time!)  Consequently, it took me longer than it should have to decide whether the MX-3 is 
a winner or not. Spoiler alert:  It definitely is!  

The “-3” signifies that it can be dynamically switched (by a single F-key press of F13, F14, or F15) to 
any of three active Macs. I have only one Mac within range at my operating position, so I have not 
tested this feature. 

Note: This is a wireless keyboard for entering data even though its internal battery is recharged 
through a USB-C port on the rear panel. (The inability to use the keyboard as a wired keyboard for 
data entry is one of only two bones I have to pick with it.)  I’ve left the keyboard powered on (via 
small slide switch, also on the rear panel) since April, and it’s still showing about 40% charge 
remaining despite never recharging it since it originally arrived here. That’s probably evidence of 
how little I’ve been on the air these past few months, since the keyboard goes into a very low 
power consumption mode after a brief interval of inactivity. 

The keyboard’s communications link with the Mac can be via Bluetooth or USB, the latter by 
selecting Logitech’s proprietary wireless link between the keyboard and a companion dongle that 
plugs into a USB port on the mac or an associated port expander.  

✦ Warning #1:  The dongle comes with the keyboard but it is tiny — about the size of my pinky 
fingernail — and if you’re not careful you might accidentally throw it out with the packaging!  
(Although that’s not a problem for me because I have never been known to throw out 
packaging materials — just ask other members of my family!) 

✦  Warning #2:  When using the included dongle, you must also turn on Bluetooth on your Mac 
for the proprietary Logitech comm link to function. Strange but true. 
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I did have some initial set-up problems, but thanks to a tip from a SkookumLogger user with 
superior Logitech keyboard experience I finally got my issue sorted out. (Lack of adequate 
documentation is the second of my two “nits” with this keyboard.)  When running contest logging 
software, most of us invert the F-key preferences so that the “alternate” F-key assignments we use 
in our logging programs do not require that the “fn” key be simultaneously held down. I could find 
no reference on how to toggle the F-key setting in either the documentation provided by Logitech 
or via the macOS System Settings window for a 3rd-party keyboard. It turns out that the (best) way 
to do this with the MX-3 is to Hold the “fn” key and Tap the “ESC” key. (If you have an older 
Logitech keyboard, it may not incorporate this feature and you may need to download, install, and 
use Logitech Options from that company’s Support page.)  In short, I wasted a lot of time and used 
up some friendship “capital” with others because  of Logitech’s "sparse" documentation. 

Through no fault of Logitech or the keyboard, my full acceptance of the MX-3 was further hindered 
by my attempts to set up my own custom keyboard shortcuts in Sonoma for the first time. Between 
contesting and casual DXing, I make full use of all 19 F-keys on the wide keyboards, as well as 
other custom combinations using Cmd, Cmd-Option, or Cmd-Shift with various non-alphanumeric 
keys.  It turns out that Sonoma’s system for letting the user set up custom shortcuts either globally 
or on a per-application basis has some limitations — limitations that in my case led to conflicting 
and “disappearing” shortcuts under Sonoma even though they hadn’t been a problem under 
Catalina. Fully wedded to my longstanding choices for my custom keyboard shortcuts for 
contesting — and reluctant to mess with the muscle memory for these shortcuts that I have 
developed over time — I opted to add Keyboard Maestro for reasons discussed by K1GQ 
elsewhere in this Guide. 

Throughout May and June 2024 I put the MX-3 and my suite of custom shortcuts through three or 
four casual contesting efforts, most recently including 700+ CW contacts during ARRL Field Day. 
I’ve had no disappearing shortcuts since adding Keyboard Maestro, and I think I’ve encountered 
only one spurious “K” in the entire time I’ve been using the MX-3.  

Other “pluses” of the MX-3 for contest logging: 

✦ Unlike the aluminum Apple keyboards, the plastic caps on the Logitech’s keys are “cupped”, so 
there’s a happy tendency for your finger to slide toward the center of each key you wish to 
press, especially if your aim is a bit off and your finger initially comes down onto the key cap off-
center.  

✦ The MX-3 has a fairly deep and flat  “shelf” above the F-key row, and it’s ideal for using small 
Dennison or Avery labels to display names for the commands you are using the F-keys to 
initiate — labeling I never really mastered with my Apple keyboards. This depth more than 
makes up for the not-quite-full-size F-key caps which are an eighth-inch shallower (i.e., toward 
the rear of the keyboard) than those on my aluminum Apple keyboards. (Apple’s F-key caps 
their older keyboards are not full-size, either, it should be noted.) 

Bottom  line: I find Logitech’s MX Keys for Mac to be a wonderful replacement for Apple’s wide 
aluminum keyboard. 
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Logitech MX-3 Set-up 
Some SL users prefer the Logitech MX Keys for Mac (with 19 F-keys and numeric keypad, aka MX-3) 
because key activation requires a bit more fingertip pressure than Apple’s aluminum keyboards do. 
This is a wireless keyboard for entering data even though its internal battery is recharged through a 
USB-C port on the rear panel. (With normal intermittent usage, a single battery charge may last for 
months.) 

Initial set-up of the MX-3 involves the following: 

✦ Decide whether you want the MX-3 to communicate with your Mac via Bluetooth or USB. The 
latter employs Logitech’s proprietary wireless link between the keyboard and a supplied 
companion USB-A dongle that plugs into a USB-A port on the Mac or an associated port 
expander. Note:  When using the included dongle, you must also turn on Bluetooth on your 
Mac for the proprietary Logitech comm link to function.  

✦ The MX-3 can be dynamically switched between and used with three active Macs. Follow 
Logitech’s instructions for associating it with your logging computer by pressing either F13, 
F14, or F15 upon initial powering and completion of the comm link handshaking. 

✦ If you wish to use the Logitech F-keys as standard function keys without needing to 
simultaneously hold the “fn” key down, following initial pairing with your Mac hold the “fn” key 
and Tap the “ESC” key. (Alternatively, download, install, and use Logitech Options from that 
company’s Support page.)  

As with Apple keyboards, you will need to verify that any custom keyboard shortcuts you create — 
whether global or SL-specific — do not conflict with other, pre-existing shortcuts by rigorously 
perusing the full shortcut “tree” available under Keyboards in macOS System Preferences or 
System Settings. For some key combinations, you may find it necessary to employ a 3rd-party 
software utility, such as Keyboard Maestro, or choose a different key combination. 
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Using 1T1R, K1GQ 
Traditionally, operators in a contest are either operating in Run mode (calling CQ on a frequency) 
or S&P mode (where you “trawl” the band. searching for new stations to work). You would do this 
by locking transmit focus to keyboard focus using the 1T1R Transmit focus follows keyboard focus 
option and toggling keyboard focus to choose between Run mode or S&P mode. 

An advanced technique is to interleave the two, so that you use gaps whenever calling CQ doesn’t 
return any replies to search for and “pounce” on stations calling CQ elsewhere on the band. To do 
this, use Activity > Set Pounce to prepare the Pounce QSO Entry pane. 

I use a K4, with the subreceiver dedicated to diversity reception. My station can change bands in a 
second or so with one keyboard command or mouse click. So, my operating style treats HF 
contests as one big band — watching Activity tables and changing bands often. 

The 1T1R choice in OpMode settings applies when you are operating with a single radio (one 
transceiver — 1T) without a subreceiver (one receiver — 1R). The QSO entry boxes are labeled Run 
and Pounce. You use the Run QSO entry fields when making contacts with stations that answer your 
CQs. You use the Pounce QSO entry fields when making contacts with stations whose CQs you 
have answered. Note that SkookumLogger does not require that you always log QSOs this way, but 
it is necessary if you want to use run/pounce context-dependent features described below. 

So, it is important to efficiently manage which QSO entry pane handles what you type with your 
keyboard. This is called keyboard focus. The two QSO entry boxes independently keep track of 
radio frequency and mode, so it is also important to efficiently manage which entry pane is 
controlling your radio. This is called transmit focus. 

There are several commands (menu items) that manage which QSO entry pane has keyboard 
focus. I use Log > Toggle QSO Entry Focus (F12). This command transfers keyboard focus from 
wherever it may be (as long as SkookumLogger is the active application) to the most-recently-
focused field in the “other” QSO entry pane. 

To manage transmit focus, I turn on the Transmit focus follows keyboard focus option in the 1T1R 
tab of OpMode settings. 

The QSO entry pane with transmit focus automatically tracks radio frequency and mode. 
Sometimes I find myself tracking the radio with the “wrong” entry pane. For example, I abandoned 
my CQ frequency and started tuning to find another one, then trip over a CQ that I want to answer. 
In this case, I use Log > Copy Run to Pounce to copy the radio information from Run to Pounce, 
then switch focus to Pounce. A second common case is tuning with Pounce focused and finding a 
frequency where I want to CQ. For this case, I use Log > Copy Pounce to Run, then switch focus to 
Run. 

You don’t want to be using your mouse to choose these commands via menu items. Instead, learn 
the keyboard shortcuts, which are displayed in the menu items. Furthermore, you don’t want to be 
using shortcuts that involve multiple keys when using a MacBook or Apple wireless keyboard that 
don’t have page up keys; see Changing shortcuts. 
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When running, I want to begin a QSO by typing a call and playing the His Call + Exchange 
message. To end the QSO after typing the received exchange, I want to play the Acknowledge + 
Log QSO message. When pouncing, I want to begin a QSO by playing My Call, and end the QSO 
after typing the received exchange by playing Exchange + Log QSO. Since I am careful to manage 
focus properly, I can have SkookumLogger choose which messages to send when beginning and 
ending Run and Pounce QSOs. In the Special Keys tab in Messages settings, I assign semicolon as 
the key for the Begin QSO message, and apostrophe as the key for the End QSO message. Then I 
start either kind of QSO by tapping semicolon, and finish either kind of QSO by tapping 
apostrophe. 

Sometimes I need to resend the other station’s call when finishing a QSO. For that purpose, I assign 
the left square bracket key as the special key for the Messages 5 + 3 + Log message. So, while 
routinely making QSOs, I am either typing information into QSO entry fields or tapping semicolon, 
apostrophe, or left square bracket. 

I interleave Run and Pounce QSOs using Activity tables as follows: 

✦ Double-click on an activity table row to copy the activity to Pounce and focus Pounce. 

✦ Tap semicolon to answer the station’s CQ. 

✦ If the station responds, complete the QSO. Otherwise, possibly tap a CQ message function key 
— SkookumLogger automatically changes transmit focus to Run before playing a message with 
“CQ” in the label. Tap Log > Focus Pounce QSO Entry to return to Pounce to continue calling. 

When Pounce has focus and I discover a good frequency for CQing, I use Messages > Copy 
Pounce to Run + CQ to grab the frequency and start a CQ with one keystroke. One other command 
that I use frequently is Messages > Beacon CQ. This command focuses Run if necessary, and starts 
sending the F1 CQ message. 

There are two reasons that I do not use the 1T2R configuration, even though I have a radio with a 
subreceiver: 

✦ I have tried and failed, more than once, to train myself to make QSOs efficiently while listening 
to more than one audio stream. 

✦ I enjoy completing difficult contest QSOs, which often involves digging out weak signals with 
QRM and QSB. Using my subreceiver in diversity mode contributes to success in that endeavor; 
diversity mode is incompatible with the 1T2R subreceiver frequency management scheme. 
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Using 1T2R, W2RU 
Much has changed in SkookumLogger since this entertaining story was written in 2015, but the 
article remains informative.  

Ever since Linda and I brought our first carload of possessions to our new Virginia home early last 
year, my 25-year-old Kenwood TS-950SDX and a 40-y/o Heath SB-220 amplifier have formed the 
basis of my primary station down here. Later, as the first of two “real” operating desks became 
reality (thanks to the conceptual and construction talents of Colden and Ryan in my absence) and a 
40-foot tower with a Cushcraft A-3 tri-bander was erected, I added some remote manual switching 
for the TX antennas (160 inverted-L, 80 & 40 dipoles, Cushcraft A-3) and for the 4-way 
DXEngineering Beverage system so generously donated by Bill. Thanks to shoulder pain caused 
by my neck problems that were first diagnosed earlier this year, I’ve ended up with a “boat anchor” 
manual band-switching operating position that has all the important controls directly in front me. 
When I sit at the desk, I feel like I’m living an ad from the front pages of a 1950s-era QST. 

And while Bill has not exactly been overjoyed at having to make SkookumLogger work with such 
an obsolete beast as the 950SDX, he has been “tolerant” of my having only that rig at my disposal 
for contesting in VA for the past 18 months. With his perseverance, and thanks to some productive 
debugging-at-a-distance sessions, we have gotten most of the bugs out of SkookumLogger’s 
communications with the rig — a pretty amazing feat, considering he has never had an actual 
TS-950SDX at hand to work with. 

In recent weeks I had every intention of getting the W2BC automatic bandswitching station 
relocated, installed, and working in time for the 2014 CW SS. But at the same time I was bringing 
the 87A, K3/P3 combo, and all the Ameritron RCS-12/10 antenna switching gear south in my car a 
week ago, my VA neighbor Tim was driving a 24-foot rental truck filled with some of our “other” 
stuff from Old Forge to Circle Creek for us. As a result, getting the truck unloaded and most of its 
contents properly dispersed throughout the house during the first half of this past week left me 
little time or enthusiasm for setting up the better station by Saturday. 

Another reason I couldn’t muster much enthusiasm for SS preparations this year was that I am now 
(at least temporarily) in the “wire & tri-bander” set for the first time in many decades, and I was not 
looking forward to the “come-down” in response rate to my CQs that would likely mean. A side bet 
on a “bottle of fine wine” with WA1Z briefly buoyed my spirits (oh, stop it, Bud) but no sooner had 
we made the bet than Bob and I both started back-pedaling from _any_ commitment, no matter 
how small. 

Some time Friday morning I began to reconsider my decision to run (or S&P) with my boat anchors 
and manual band-switching back-up station, and I began assembling the W2BC configuration of 
K3, P3, 87A, and an Ameritron RCS-12 (or RCS-10, I’m never sure which) automatic antenna 
bandswitching system. I installed the power transformer in the 87A, unpacked and interconnected 
the K3 and P3, and began to think about what I needed to do to get the Ameritron bandswitching 
stuff set up. At that point, I gave up dreams of an automatically bandswitched station, since to do 
that I would have to disconnect or dismantle many parts of my manual station and irrevocably 
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switch to the “primary” station with zero spare time for fixing any problems that might crop up and 
zero ability to go back to the boat anchors. 

With that as prologue, I operated for 10 of the first 10-½ hours of the contest, taking a single 35-
minute time out in mid-evening. I didn’t go near the rig again until some time late Sunday 
afternoon. SkookumLogger says I logged a total of 15-½ hours on-air time. I worked about 780 
stations in all 83 sections. My last three sections were VI, WVA (!!!), and NT. I used up a bunch of 
time Sunday evening “trolling” on 10 and 15 meters for VY1EI, only to be called by VE8EV. My sole 
WVA QSO was with Pete, N4ZR, who had a grand total of 10K points! I feel honored that he found 
me during his brief S&P sojourn on whatever band I was on at the time. 

Although it is one of the few high-end transceivers never tested by Rob Sherwood, the SDX’s Main 
Receiver is pretty decent. In addition, mine has been enhanced with the addition of an IRCI (?) 
roofing filter that I installed some years back. In contrast, the rig’s Sub Receiver was sub-par even 
when it was fairly new, back in 1990! It uses a single-conversion scheme with a 10.7-MHz i.f. and a 
very sloppy 500-Hz crystal filter at that frequency. It suffers badly from intermod on active bands, 
such as 40 meters was on Saturday and Sunday evenings. Audio Gain for the Main and Sub 
receivers is handled with two completely separate front panel pots on the right-hand side of the 
transceiver front panel, one pot above the other. (i.e., there is no Balance control option.) There 
may be multiple ways of handling split frequency control on this ancient rig, but the only one I’ve 
spent any time with — and the only one that Bill has implemented for my SO2V fantasies — puts my 
Run frequency on VFO A with the “big” knob, and lets me tune the Sub Receiver with the small “Tx 
VFO / Sub" knob to the right of the Main Tuning knob. 

Nonetheless, I have become moderately adept at using SO2V on the Kenwood. I’m probably better 
at it on the Kenwood than on the K3 at this point — mostly because I haven’t used my K3 in a 
contest in many, many months! Which only confirms what we all know: When the contest starts, 
stick with what’s familiar. 

Here’s what I do for UNassisted SO2V: 

✦ Make sure that communication between your transceiver and your logging program (probably 
an RS-232 protocol) is at the highest speed reliably supported by both devices. 

✦ Make sure you’re using stereo headphones, and make sure you have a spacial demarcation 
firmly in mind for Main vs. Sub audio streams. In the case of the 950SDX, the SubRx frequency 
display is to the right of the Main frequency display on the front panel, and the SubRx control is 
to the right of the Main Tuning knob, so I make sure that SubRx audio is my _right_ ear. This 
required that I modify an old Radio Shack headphone extension cable to swap Left and Right 
channels so that the headphone cord hangs down off my left ear (since the headphone jack on 
the Kenwood is on the left edge of the front panel). 

✦ If you have a modern rig like a K3, decide whether you prefer separated audio or want your 
main channel audio blended into both ears. I don’t get that choice on the Kenwood, and it’s a 
disadvantage to not have it. Many times, when trying to copy a “Q” station this weekend I had to 
turn off my SubRx in order to put main channel audio in both ears for better detection. 
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✦ In SkookumLogger Wizardry (under Preferences), select “Pounce tracks SubRx”. This is key to the 
entire SO2V experience. 

✦ Pick a Run frequency off the beaten path so you’re not having to constantly find a new one. I 
usually go to the high end of the contest activity on any band — even though Hank may express 
incredulity at the resulting RBN spots. 

✦ When the Run rate has slowed appropriately, turn on the SubRx. With SkookumLogger, this can 
be done directly from the front panel of the rig or via the extra F-keys on extended Apple 
keyboards (or other self-assigned key combinations on smaller keyboards). I use F13 on the 
wide aluminum Apple keyboard (thank you, Bob!) to turn SubRx off, and F15 to turn it on. 
(Again maintaining that Left / Right demarcation.) 

✦ Adjust the SubRx Audio Gain to your preference. (I like to keep it a bit lower than the audio 
level coming out of the Main Rx channel.) 

✦ While CQing, tune the SubRx knob through the contest activity, and stop at each loud signal 
you hear. 

✦ In the dead air between CQs, find out whom you’re listening to, and whether it’s a needed QSO 
by pre-typing the station’s call and any copied exchange info into the call field. (In 
SkookumLogger this will actually be in the Run pane, but a Wizardry option allows automatic 
transfer of what’s in the Run pane to the Pounce pane at the appropriate time. Also, in 
SkookumLogger Wizardry it will be necessary to disable the option that says “Typing stops 
beacon CQ”.) 

✦ In between CQ transmissions, if you wish to work the station you have tuned in via the SubRx, 
tap F12 (in SkookumLogger, at least). 

✦ Do not send your call (F4) until and unless you hear audio switch channels in your 
headphones!!!!!! (At least, that’s true for the Kenwood. And, since the Kenwood exhibits some 
ridiculously long “lags” between the time F12 is tapped and the time the VFOs switch, this is an 
extremely important step with this boat anchor.) 

✦ As a result of tapping F12, whatever call you have temporarily logged in the Run pane will be 
duplicated in the Pounce pane, and focus will be automatically transferred to the Pounce pane. 

✦ Assuming you are successful, finish entering the other station’s information in the Pounce pane 
fields. When you have confirmation of a “good” contact, tap Enter to log the QSO. 

✦ Tap F12 again to return to your Run frequency. You should hear audio flip between channels in 
your headphones, and you should again wait for that flip before doing anything else. 

✦ Once audio has flipped, tap F11 (in SkookumLogger) to clear the Run pane of any leftover 
information. (Or select the SkookumLogger Wizardry option that says “Clear Run fields when 
focusing Run from Pounce”.) 

✦ Tap F1 to resume CQing on your Main frequency. 

✦ Resume tuning with the “Tx VFO / Sub” knob until you find another loud signal to analyze in 
between CQs. 

Version 5.4	 Page 185



SkookumLogger Guide

✦ If you are UNassisted, you can still populate your Activity Tables in SkookumLogger with your 
own contacts by selecting the proper options for those Tables. This may help you decide to 
continue past a loud signal that you hear between your own dots and dashes as you’re CQing. 
You can also fill your Activity Tables with calls you didn’t successfully work yet, then go back to 
them at a later time. (I didn’t use this feature this weekend, and I have no idea whether mouse-
clicking will work with the Kenwood in SO2V operation.) 

The biggest fault I found with SO2V operation of the TS-950SDX this weekend was the extreme 
variability in the response of the Kenwood to tapping the F12 (S vs. P) key. As Bill has come to 
believe, the Kenwood computer interface is a bit unpredictable. Interestingly, RIT (or XIT) Up / 
Down commands execute flawlessly from the keyboard, with only tiny delays when I’m transmitting 
… but F12 commands seem to send the 950SDX into a tizzy. When they are responding properly 
and promptly, however, SO2V on this boat anchor is a joy — and one of the miracles of the modern 
world. 

The Kenwood TS-950SDX has a “Swap” button (not its real name) that allows you to swap certain 
_knobs_ on the rig; in particular, I believe it may be possible to tune the SubRx with the Main 
Tuning knob. But I didn’t dare try it, in fear of upsetting the apple cart. 

I’ve probably left out a detail or two, but I’ve tried to think the process through as it occurred this 
weekend. Very seldom did I lose my (carefully chosen) Run frequency — probably because of the 
relative dearth of low-band activity that has been previously hashed over. 

Post Script: Since the bet I had with Bob for a bottle of fine wine went by the boards prior to the 
start of the contest, when I was in town today getting my annual flu shot I stopped at one of the 
grocery stores and used the same money I was going to use on Bob’s bottle of wine for six bottles 
of not-so-fine-wine to be consumed in Bob’s honor, right here at home in VA! (Not all at once, of 
course …). 
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2T2R Keyboard Setup, WA1Z 
I am using the large USB Apple Keyboard that provides 19 F-Keys. Being a touch-typist with years 
of experience with PC-type keyboards, I initially found the Apple keyboard F-keys incredibility 
difficult to use. The first twelve F-keys are bunched together with no spacing making it very difficult 
for me to locate the appropriate key without looking down at the keyboard. Most PC-type 
keyboards space-out F-keys into blocks of four. In contests over the years, I’ve relied on that 
spacing to locate F1 and F4 keys (and then by extension, 2, 3, and 5 keys) without having to look. I 
am slowly re-educating myself to accept the lack of spacing on the Apple keyboard and I’m finding 
that I am improving in my ability to hit the right F-key from F1 through F5 without having to look. 

When I started doing SO2R with SkookumLogger, there were additional default F-Key assignments 
that fell within the "Massive Block of Twelve" that I found difficult to locate in the “heat of the 
battle.” Appropriately, Bill is keeping in mind the lowest common denominator with regard to F-key 
general availability in the Apple keyboard market. However, because of my own limitations, two 
very important keys, F9 and F12 (see details about these below), are almost impossible for me to 
find quickly — even when looking. Below is a write-up of what I did to take advantage of the higher-
numbered F-keys beyond F12 (that do have some physical spacing) and Mac OS X’s “App 
Shortcuts” facility to reassign the default shortcuts in a way that improved my ability to manipulate 
SkookumLogger and the YCCC SO2R box during a contest. 

There are three fundamentally important SO2R-related control points that are available either by a 
menu item or combination of menu item and F-Key: 

✦ Log > Toggle Transmit Focus controls which of the two radios should be the “active” Transmit 
Radio (the radio that will transmit the next message you want to send by whatever means 
SkookumLogger provides). This once had F9 as the default shortcut. 

✦ Log > Toggle QSO Entry Focus controls focus of the two QSO Entry Fields (labeled Radio 1 and 
Radio 2) independent of the currently-designated Transmit Radio. This allows for the ability to 
enter QSO data being received on the non-Transmit Radio. This also has a default shortcut of 
F12. 

✦ Three menu items, 2T2R > Listen to Both Radios, 2T2R > Listen to Radio 1 and 2T2R > Listen to 
Radio 2 control the audio routing from the two radios. Bill elected to provide no shortcut for 
these menu items. 

The Apple keyboard F13…F15 keys comprise their own bank of three above the fn, Home and 
Page Up keys, followed by F16…F19 which are positioned nicely above the numeric keypad. 

I first set out to reassign “Toggle QSO Entry Focus” and add F-key assignments to the three “Listen 
to …” audio menu options. My left hand (as I imagine for most folks) is the predominant 
manipulator of F1 through F4 keys. These are the keys most used in sending messages. I wanted to 
move SO2R control as far to the right as possible so I could use the right hand. The four keys F16 
through F19 above the numeric keypad proved to be a perfect choice. I reassigned the F-keys as 
follows: 
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F16 - “Listen to Radio 1” This is my “left” radio 
F17 - “Listen to Both Radios” 
F18 - “Listen to Radio 2” This is my “right” radio 
F19 - “Toggle QSO Entry Focus” 

I chose F19 for “Toggle QSO Entry Focus” because it is on the far-upper-right-hand edge of the 
keyboard and is quite literally hit several thousand times in the course of a full-bore contest effort. I 
rest my pinky finger on the edge of the keyboard for positioning my hand and hit F19 with my ring 
finger. When I want to control the audio routing (far less often), it’s a minor hand-slide adjustment 
to line up my pointer, middle and ring fingers over F16, F17 and F18, respectively, to control audio. 
All subtle, limited and fast movements. 

So far, I haven’t mentioned “Toggle Transmit Radio.” For CW contesting, I’ve found the four 
assignments listed above are all you need. You almost never need to actually select “Toggle 
Transmit Radio” in a CW contest because Bill has gone out of his way to actually automate when 
“Toggle Transmit Radio” is required. In short, SkookumLogger is intelligent enough to analyze 
which Radio has QSO Entry Focus and know which radio should transmit when the operator 
actuates a Message. Bill can do this because SkookumLogger has full control over CW generation 
(outside of direct CW transmission from an unconnected keyer that SkookumLogger can’t “see”). 

For SSB contesting, there are practical limitations with VOX and PTT footswitch control that 
SkookumLogger has no ability to monitor making “Toggle Transmit Radio” a function the operator 
needs to manipulate more often. I have yet to do a SSB contest SO2R with SkookumLogger as of 
this write-up, but I have decided I am going to try assigning this: 

F15 - “Toggle Transmit Radio” 

F15 is on the right edge of its own “Bank of Three” with a space between it and F16. I’m theorizing 
that F15 is separated far enough from F19 that it will require separate two fingers to control them 
(and not close enough to hit one when I mean to hit the other). We’ll see how this works out this 
weekend in HADX and NAQP SSB contests. 

Another alternative assignment bank could be this: 

F13 - “Listen to Radio 1” This is my “left” radio 
F14 - “Listen to Both Radios” 
F15 - “Listen to Radio 2” This is my “right” radio 
 
F16 - “Toggle Transmit Radio” 
F19 - “Toggle QSO Entry Focus” 

But this involves more wrist movement in my right hand. 
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Practice Mode Videos, JH5GHM 
Katsuhiro is a major contributor to the design and coding for both the operating modes and the 
Practice Mode features in SkookumLogger. He typically does practice sessions daily, preparing for 
guest-operating at stations like JA6GCE as JH6RPM, and at others around the world. He has been a 
team leader at every WRTC since 2014, using SkookumLogger.  

Katsuhiro has posted many videos at contestworkshop. These show his practice sessions, along 
with illustrating his contest station design and custom equipment. Be sure to use headphones 
while listening to the SO2R and 2BSIQ videos to understand how Katsuhiro configures audio 
switching. 
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Example Window Layouts, GØDVJ 
The following screenshots show a range of simple to complex SkookumLogger window layouts for 
illustration only. Most were obtaining using previous versions of SkookumLogger. They 
demonstrate how you can customize the layouts according to the contests you are doing, the 
devices you have connected to SkookumLogger, and the approach to contesting that you take. 
What you choose to display, and how, will also depend on your monitor’s screen size and 
resolution.  

These examples are not designed to be visible in all detail but rather to give an idea of how the 
various optional windows can be used and arranged. Everyone will have their own personal 
preferences for layout of course.  
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RSGB 80m Club Championship SSB contest 

Here we have almost the simplest logging layout for someone perhaps starting out in a contest 
such as the RSGB CC series which have no multipliers, and so a good score is all about the rate of 
working any stations.  

The Rate window is set alongside the Log window and all the sent info has been hidden from the 
table of logged contacts. The blue globe icon under the contest name is dimmed and so there is 
no cluster connection and therefore the user has chosen not to open any activity windows either.  

The Score window has been placed tidily in the bottom right corner of the logging window. Of 
course the only mandatory window needed to log QSOs with SkookumLogger is the Log window; 
however this example demonstrates that for a contest type where there is no multiplier or bonus 
scoring, the rate at which you work contests becomes most important in achieving a good score - 
hence the two additional windows shown. 

The radio is connected but there are no other devices being managed by SkookumLogger in this 
example. This is a very compact layout which would fit easily on the smallest notebook Mac screens 
at low resolution with room to spare.  

The next development from this layout might be to add the 80m Activity window and connect to 
the DX Cluster to assist with S&P activity. 
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RSGB 80m Club Championship with RTTY/PSK63 decode window RSGB Club Calls 

The RSGB Clubs database is a list of club names and abbreviations, used in RSGB Club Calls 
contests. The list is constructed by manually parsing the source code for an RSGB web page 
containing the relevant information and there is no mechanism available for downloading the 
information. Do not expect frequent updates for this database. 

This example shows a layout where the data decode window is central to proceedings for a single 
band RTTY/PSK63 data session of the RSGB Club Championship. The transmitted text (triggered 
by Function keys and/or Magic Message is shown in red in the table, whilst the decoded received 
data is in black in the same window.  

The window showing the sent/received data is positioned just above the main logging window 
with the relevant band’s activity window next to it. The other way to pounce on stations using a K4 
in this case, the panadapter window is also close by. On the occasions one uses the mouse to grab 
either an activity spot (from activity window or panadapter), or a received data exchange item, 
there is little mouse movement required. Also note that the map has been zoomed to a suitable 
area that I am likely to work in this particular contest. 
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New England QSO Party from UK 

The Log window in these examples from the author of this Guide is generally positioned bottom-
left of the screen; this happens to correspond to eye level the way the large external monitor is 
arranged in his shack. You will want to position things right for your own shack/bench. 

The map has been customized for scale and coverage (UK to NA), and shows both the shading of 
the daylight terminator and the highlight of where the beam antenna is pointed. Having said that, 
in this NEQP contest the terminator / grayline is more important, since the beam doesn’t really 
need to move as all contacts are with the same part of the Eastern USA! 

The three Activity windows opened are the only bands worth looking on at that time of night 
(0017z) and the checklist is customized to show just those three bands and all the NE county/state 
names and codes. The main logging window has the Rover column enabled, which is unique to 
these types of QSO party events. 
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WAE DX CW 

In this example, different color schemes have been chosen for needed QSOs and multipliers etc., 
plus the Panadapter window has labeled spots with callsigns, again reflecting the chosen colors.  

The Log window is front and center and the Status Messages window is larger below it. The Activity 
windows surround the main windows and are sized and arranged according to those bands which 
may be most busy/important. The QTC Series window, unique to the WAE contests, is tucked away 
ready to be brought into focus adjacent to the Log window, should QTCs need to be sent.  

Bill prefers to minimize the width of the Log window by choosing not to display the logged sent 
information and to display just band and mode rather than frequency. 
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IOTA contest with FTdx101MP video 

This panadapter display shows the radio settings, signal strength meters and band scope from the 
radio’s screen without the operator having to look away from the logging screen. The Radios and 
Rotators windows are open; the latter showing the bearing which is also highlighted on the map.  

The map shows the whole globe since IOTA attracts activity across all continents, often from the 
middle of oceans on small land masses! 

The Time Tracker window is also open since this was a 12 hour effort out of the 24 hours of the 
contest. Multipliers are key in this contest, and the Region Checksheet, which lists worked Islands in 
this contest, is displayed to easily and quickly scroll should there be uncertainty about an island 
reference code received, for example. 
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Two Radio CQWW CW Practice Mode 

The first notable thing about this example is that it uses SkookumLogger in Dark Mode on macOS. 
Secondly, this is an example of a two radio configuration; note that the QSO Entry panes have 
been relabelled Radio 1 and Radio 2, instead of Run and Pounce. Thirdly this example shows how 
Katsuhiro arranges the layout for using SkookumLogger’s Practice mode facility.  

Practice mode is most easily used with the Practice window open so that the parameters for 
practice can be tweaked.  

Because there are two radios used in this example, the colored gumdrops are shown in each QSO 
entry pane, to identify when each has transmit/receive focus. At the time of this screenshot, you can 
see that radio 1 has transmit focus (red gumdrop above the call entry field) while listening to both 
radios — each QSO Entry pane has a green gumdrop. The YCCC SO2R window on the left side 
above the map window shows how audio is receive audio is routed in each situation.  

The long green bars in the Rate window at top-right demonstrate Katsuhiro’s amazing performance 
running 2BSIQ simulated on 40 and 20m at 45wpm CW! You can see the interleaving of QSOs on 
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each band by looking at the TX frequency column of the logged QSOs table. And what’s more, 
there are no errors reported in the notes field for this practice session! 
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Files and Databases 
The log file created by SkookumLogger is an sqlite database with extension sl-binary. This file 
contains all logged QSOs, and other information specific to the contest, such as the name of the 
rules for the contest, and message definitions. You can move, copy and rename log files in Finder 
without affecting the content. 

Cabrillo files are central to contesting. They are created from the log file, and in some 
circumstances can be used to create a log file. 

SkookumLogger uses several databases to display information in the QSO entry pane and to pre-
fill QSO received exchange fields. The versions for those databases are shown in the Information 
Messages window when you start SkookumLogger and when you download new versions. 
SkookumLogger includes default databases that are used when you haven’t downloaded more 
recent versions. The default databases for Countries, Super Check Partial, and CWOps Roster are 
updated with each SkookumLogger release. 

Cabrillo files 
Cabrillo is the reporting format expected by contest sponsors. The standard is maintained by the 
World Wide Radio Operators Foundation. SkookumLogger conforms to version 3 of the standard, 
and provides a user interface for everything that you need to supply when submitting your Cabrillo 
file to a contest sponsor. The user interface has two parts. The Cabrillo tab in the New Log settings 
pane initializes settings for new logs. The Cabrillo Setting Sheet (Log > Cabrillo Settings…) 
supports editing the definitions for an existing log. 

Submitting a Cabrillo File 

When you have set up all the values in the settings sheet appropriately, SkookumLogger can create 
and send your Cabrillo file directly to the contest sponsor; you will not need to open and edit the 
exported Cabrillo file outside SkookumLogger. 

File > Submit Log Via Web Browser — Automates the steps for preparing and uploading your 
Cabrillo file to the contest sponsor via the sponsor’s web site. You should use this option if it is 
enabled. SkookumLogger exports your log to a Cabrillo file via a standard Save dialog where you 
can name the file anything you like, and opens your web browser to the appropriate web page 
where you choose the saved file and supply other information requested by the contest sponsor. 
This command is disabled when the contest sponsor does not support web uploads. 

File > Submit Log Via Apple Mail — Automates the steps for preparing your Cabrillo file to be sent 
to the contest sponsor as an email attachment. SkookumLogger quietly exports your log to a 
Cabrillo file, then composes an email with the appropriate to and from email addresses and 
subject, using Apple Mail. The from email address is taken from the Email address that you set in 
your Cabrillo settings. Activate Mail to send the composed message. This command is disabled 
when the contest sponsor does not support emailed logs. 

File > Submit Log For SCP — Performs the same steps as submitting via Apple Mail, but addresses 
the email to the maintainer of the SCP database. 
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When you first run SkookumLogger you may be asked to allow SkookumLogger to control Mail. 
You can toggle permission on and off in the Privacy tab of Security & Privacy system settings for the 
Automation item. 

Generating a Cabrillo File 

Choose File > Export Cabrillo to generate a text file in Cabrillo format. You may want to use this 
command if you want to import the Cabrillo file into another app. 

Log Import 
Before importing, confirm that your current log is compatible with the type of contest exchange 
information in the file you intend to import. 

File > Import Cabrillo… peeks into a Cabrillo file to confirm that the version is at least 3.0, and that 
the contest for the file matches the contest for the current log, based on their Cabrillo Names. If so, 
the log is cleared and the content of the file is used to populate the log’s Cabrillo settings and the 
log’s QSOs. The logger that created the Cabrillo file and the claimed score are displayed in the 
Status Messages window. See Master List of Cabrillo Names. 

File > Merge WSJT-X ADIF… reads a file of Data mode QSOs in ADIF format created by WSJT-X, 
and adds those QSOs to the current log. 

Some mixed-mode contests accept QSOs on Data modes that require WSJT-X for completing 
QSOs. WSJT-X and SkookumLogger provides limited support for these contests as follows. 

✦ For modes that do not require WSJT-X, quit WSJT-X and use SkookumLogger as your logging 
program. 

✦ To complete QSOs with WSJT-X, first disable your radio, then start WSJT-X. 

✦ To return to logging with SkookumLogger, quit WSJT-X and re-enable your radio. 

✦ After the contest, export the WSJT-X log as ADIF, then merge that file into your SkookumLogger 
log using File > Merge WSJT-X ADIF. 

It may not be necessary to quit/start WSJT-X if it provides a convenient way to give up control of 
the radio. Alternatively, use commands in WSJT-X to set band and frequency while leaving radio 
CAT (Computer Aided Transceiver) control disabled. 

The merge command presently supports contests with grid as the exchange, and ARRL Field Day. 
The ADIF exported by WSJT-X for Field Day lacks specification of your sent section, so the merge 
will fill that value with the sent section that you defined in your SkookumLogger log. 

File > Merge RoverLog Cabrillo… reads a Cabrillo file created by the RoverLog app and adds 
those QSOs to the current log. 

Log Export 
File > Export ADIF generates a text file in ADIF format from your log. This facility is used for getting 
your contest QSOs into other software that can read ADIF files. ADIF has a prodigious number of 
fields; most have nothing to do with contesting. SkookumLogger exports basic fields describing 
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each QSO, including some exchange information, but does not attempt to distribute all exchange 
data into specific ADIF fields. The best way to see which ADIF fields are exported is to look at the 
resulting file with any text editor. 

File > Export to Numbers generates a list of your contest QSOs in comma-separated-values format. 
This format is readable by any spreadsheet application. The first line in the CSV file contains 
column titles. Checkmarks in the SkookumLogger log table are represented by the number 1; 
absence of a checkmark is indicated by an empty value. The last column in each record, labeled 
Index, is a simple record counter starting at 1. Drag the icon for the CSV file onto the Numbers 
application to open a new spreadsheet and import the CSV file content into a table. 

Log Reports 
File > Create Statistics Report processes your log to compute rate statistics and other summaries 
information, then open the report in your web browser. Use the browser to save the report. The 
processing is time-consuming for large logs and will block the SkookumLogger user interface until 
it completes. 

File > Rate Breakdown Report prepares a rate sheet for each operator and displays it in your web 
browser. 

File > Per-band Log Files creates separate text files for each band, describing the QSOs in the 
format popularized by the CT by K1EA logging program. The files are written in the folder 
containing your log file. 

Application Support Folder 
Downloaded databases and other files used by SkookumLogger are located in the standard 
macOS place for application support files. The path to that folder within your Library folder is: 

Containers/com.k1gq.SkookumLogger/Data/Library/Application Support/SkookumLogger 

DXCC Countries Database 
The most important database is the one mapping call prefixes to country names, continents, zone 
numbers and other entity information for the derivation of approximate bearing and distances. 
SkookumLogger uses the database maintained regularly by Jim AD1C, downloaded from: 

https://www.country-files.com/cty/cty_wt_mod.dat 

You can download this database in SkookumLogger by choosing File > Download Countries 
Database. Note that old logs may score differently with a newer database version. SkookumLogger 
loads this database at startup from your support folder, where it is named Countries.text. If the file 
doesn’t exist or is older than than the reference version included with each new version of 
SkookumLogger, the reference version is copied to the support folder before loading the 
database. 

The Countries database is a rich source of information. For almost any legal amateur radio call sign, 
the database can be used to establish things like country (ARRL DXCC and WAE), continent, zone 
(CQ and ITU), geographic coordinates, oblast, and more. 
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Super Check Partial (SCP) 
The Super Check Partials database is a list of thousands of calls that have appeared in multiple 
recent Cabrillo files contributed to the database maintainer, Bill Fehring, W9KKN. Use File > 
Download SCP Database to get the latest version. The source URL is http://
www.supercheckpartial.com/MASTER.SCP. SkookumLogger loads this database at startup from 
your support folder, where it is named SuperCheckPartials.text. If the file doesn’t exist or is older 
than than the reference version included with each new version of SkookumLogger, the reference 
version is copied to the support folder before loading the database. 

If a file named BadSCPCalls.txt exists in the support folder at startup, the calls listed in that file are 
removed from the database while loading it. Use this to avoid false partials matches when you 
notice a call that you know to be incorrect. The file is a simple list of call signs, one per line. 

SkookumLogger sends a copy of your Cabrillo file to the maintainer when you submit your log to 
the contest sponsor after a contest. You can disable this feature if you wish, using the Submit to 
SCP when submitting to sponsor option. You can also contribute your logs manually using File > 
Submit Log for SCP.  

Unless Do not use the SCP database in Logging settings is on, SkookumLogger constructs a set of 
known calls at startup by combining calls in the SCP database with exact-match calls in the 
Countries database. This set is consulted when performing the Partials Matching function. 

Phone Band-edge File 
A phone sub-band table is consulted when Change radio mode when changing frequency is 
enabled in OpMode settings. The table is also consulted when activities created from DX Cluster 
spots need to infer mode from frequency. 

 A built-in table is based on the ARRL “US Amateur Radio Bands” chart. You can override the table 
by exporting the file (use File > Export Phone Band Edges…) containing the current table, editing 
the file, then importing that file using File > Import Phone Band Edges…. The imported file is 
stored in your SkookumLogger support directory. 

Be careful not to disturb the structure of the file; SkookumLogger does very little sanity testing on 
the file content. The file extension name must be .txt and the content must follow these simple 
rules: 

✦ Lines beginning with # are ignored. Use them for comments. 

✦ Lines end with DOS (CRLF) or UNIX (LF) line-end symbols. 

✦ A band-edge specification is a band name and a frequency separated by a colon. 

✦ Band names are case-sensitive. 

✦ Frequencies are integers, in Hz. 

Exchange Database 
The Exchange database contains a list of calls and information associated with those calls, such as 
names, states, and other bits of information that may be part of a contest exchange. You construct 
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your personal Exchange database from your own logs — there is no mechanism for importing 
information from other sources. Use File > Update Exchange Database to add information from the 
all the QSOs in your current log. When a received exchange field value already exists in the 
database, the database value is updated; otherwise it is created. There is no editor for changing or 
removing Exchange database entries, so be sure your log is as clean as you can make it before 
doing an update.  

This database provides the same exchange-guessing facility as call history files, with two 
signification differences: 

✦ One file works for all supported contests. 

✦ You provide the content for the file, rather than crowd-sourced data of unknown quality and 
sometimes not publicly available. 

The exchange database is used to pre-fill QSO entry fields with administrative codes, names, IOTA 
references, Maidenhead grids, RSGB Club Name, and RSGB Club Status, age, check, precedence, 
or power and other information, when the database entry for a call contains the requested kind of 
entry. Note that it is important to log what is heard rather than simply believing the database, but in 
the case of a match then it can save typing and improve accuracy by avoiding data entry errors. 

Name prompts 

The Exchange database stores names from received exchanges. Names are shown in the Log 
window information line below the entry fields. 

This is a trick for manually adding names to the database: 

✦ Create a log for the CWOps CW Open Competition contest. The exchange for this contest is 
serial and name. 

✦ Enter any serial number and a name, tap ⏎ to log the QSO. Do not leave the serial number 
field empty. Repeat to define other names. 

✦ Choose File > Update Exchange Database. This will add the names to the database, replacing 
names for calls already in the database that had names. 

About VHF/UHF locators from the exchange database 

Contests on bands above HF often use six character locator grid squares based on the 
Maidenhead system in the exchange, which may be used for distance-based scoring and/or 
multiplier schemes (usually just the first four characters are important for multipliers).  

Regular participants in VHF/UHF contests over time accumulate knowledge of where other 
regularly participating stations are located in relation to their own QTH. Additionally when there is 
a match in the exchange database, accurate rather than approximate beam heading information is 
calculated from the pre-filled locator and displayed in the QSO Information allowing the antenna 
direction to be optimized quickly to receive a better signal and thus copy the rest of the exchange 
more easily. This accurate alignment of antennas is particularly important for higher band contest 
operation.  
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Settings 
SkookumLogger > Settings… opens a window with this title/tool bar: 

The content of the window is one of six settings panels named New Log, Activities, DX Cluster, 
Logging, Messages and OpMode, corresponding the tool bar buttons left to right. A gear icon the 
the New Log window directly opens the New Log panel. A gear icon in any Activity window opens 
the Activities panel and a gear icon in the DX Cluster window directly opens the DX Cluster panel. 
Gear icons in the main window labeled L, M, and O directly open the Logging, Messages, and 
OpMode settings panels. 
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New Log Cabrillo 

The Cabrillo tab of the New Log panel establishes default Cabrillo values for new logs. 

Cabrillo is a text file format standard maintained by the World Wide Radio Operators Foundation, 
used for exporting a contest log to send to the contest sponsor. It can be helpful to review the 
format to understand the meanings of some of the Header and Category items. 

Cabrillo settings provide defaults for all of your Cabrillo items except the Mode and Band items in 
the Category group, and the Operator List — those items are determined from contest rules and 
entries in the Log > Cabrillo Settings… sheet. Item labels have help tags showing the 
corresponding Cabrillo tag. Some of the less obvious items are: 
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My Call — Your personal call sign. Your sent exchange call is set separately by the Contest Call item 
in the Sent Exchange tab. When this field is set to the default call, K1CX, SkookumLogger open the 
Getting Started help topic at startup. 

Location — This item is used to indicate the location where the station was operating from. Not all 
contest sponsors care about this item; presently the standard says: 

ARRL/RAC Sections: For USA and Canada stations LOCATION must be the ARRL section 
abbreviation. For foreign stations LOCATION must be ‘DX’. This information is required for 
IARU-HF and for all ARRL and CQ contests. 

IOTA Island Name:This information is required for RSGB-IOTA contest and includes Island 
Name (not IOTA reference number). 

RDA Number: This information is required for RDXC contest. 

Request mail certificate — When checked, your Cabrillo file will instruct sponsors that recognize the 
tag to mail you a paper certificate (assuming you have earned one of course). Sponsors who do not 
recognize the tag may send you a paper certificate whether or not you want one. 

Mark suspect QSOs as X-QSO — When checked, SkookumLogger reports QSOs that are flagged as 
SQ as X-QSO records instead of normal QSO records. Log-checking software will ignore those 
records in processing your log, but may use those records for cross-checking other logs against 
yours. If you use this feature and the sponsor rejects your Cabrillo file, disable the option, submit 
your Cabrillo file again, and send the sponsor an email asking them to conform to the Cabrillo 
standard. 

Submit to SCP when submitting to sponsor — When checked, SkookumLogger sends a copy of 
your Cabrillo file to the Super Check Partial database maintainer when you use either File > Submit 
Log Via Web Browser or File > Submit Log Via Apple Mail to send your Cabrillo file to the contest 
sponsor. 
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New Log Sent Exchange 

The Sent Exchange tab of the New Log panel has fields used to initialize your sent exchange for 
new logs. Use the Sent Exchange Editor to change your sent exchange for an existing log. 

These items provide default values for your sent exchange. Which items are used depends on the 
rules for the new log. Help tags on each text entry field provide details on what is expected for that 
item. 

The Contest Call may be the same as or different from My Call in the Cabrillo tab. 
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New Log CW Messages 

The CW Messages tab of the New Log panel defines titles and content for morse messages in new 
logs. 

In the Morse Messages box, Menu Title defines the menu titles that appear in the Messages menu 
for each of the 16 basic messages, and Tokenized Message defines the corresponding message 
content. Some messages have fixed menu titles. You should not alter the roles for these message, 
because other messages and your Special Keys create combination messages using those 
messages to create compound messages. You can set different shortcut keys for your messages, 
but you should think carefully about change the default F1 through F8 assignments. 

Menu titles may be anything you like, but SkookumLogger has special processing for messages 
with “CQ” in their title. First, transmitting the message increments the CQ count shown in the Score 
window. Second, depending on your radio configuration options SkookumLogger may change 
keyboard and/or transmit focus before transmitting the message. 

Any message definition may contain one or more message tokens. There are two restrictions on 
using tokens: 
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✦ The received call token must appear no more than once. 

✦ Do not create loops, directly or indirectly, with the message-n tokens. 

In addition to tokens, a message definition may contain any character in the WinKeyer character 
set. Alphabetic characters may be lower case. Unrecognized characters are ignored. 

The V1 Magic Messages box in the CW tab of your Messages settings defines the message content 
for the six states of the Version 1 Magic Message processor. Typically these messages are largely 
defined by reference to the basic CW messages using tokens. 
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New Log Voice Messages 

This tab in New Log settings in new in SkookumLogger 4.6. These default Voice Messages apply for 
the Voice Keyer. 
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Activities 

The Activities panel sets properties related to all Activity tables. 

Activity age limit — Activities with ages greater than the limit are discarded. Activities generated by 
skimmers are separately aged out with a 10 minute limit. 

Table update interval — Determines how often SkookumLogger updates the activity tables from 
queues of incoming activities. 

Frequency tolerance — Determines the matching tolerance when comparing frequencies for 
removing nearby activities, highlighting nearby activities, and autofilling nearby activities. 

Focus activity table special key — Assigns a single key as the shortcut for changing keyboard focus 
from the Log to the Activity table for the log's current band. 

Remove old activities near new activities — Prevents accumulating many activities near the same 
frequency. 

Activity > Create clears QSO Entry — clears the QSO entry pane fields for the pane with keyboard 
focus after creating an activity from the contents of that pane. 

Pounce receive frequency change Fills QSO entry from nearby activity — Fills Pounce QSO entry 
fields from an activity near the pounce receive frequency. If there is no activity within the tolerance, 
the entry fields are cleared. 

Pounce receive frequency change Creates activity from QSO entry and clears entry — Creates an 
activity when tuning by more than the tolerance after entering a call, using the information in the 
Pounce QSO entry pane before clearing the entry fields. 
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Log > Clear Focused QSO Entry Removes nearby activities — removes activities near the same 
frequency as the radio when clearing a QSO entry pane. 

Log > Clear Focused QSO Entry Creates activity from QSO entry — If the QSO entry call field has a 
valid call sign, adds a new activity to the Activity table for the current band using the information in 
the QSO entry fields, then clear the QSO Entry Pane. 

The Buddy Calls list has two roles. First, any call in the list is exempted from filters that you may 
apply to your activity tables. Second, the list may be included in the definition of a DX Cluster spot 
filter command, so that announcements for your buddies will always pass the filter. 
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Logging 
The Logging settings 
panel groups many 
options related to 
logging behavior, 
fonts, and colors. 
Defaults for the option 
show in parentheses. 

Hide sent signal 
report entry field (NO) 
— Conceals the sent 
RST text entry item in 
QSO entry boxes, to 
save you the bother of 
skipping over it when 
you always send the 
same report. 

Hide received signal 
report entry field (NO) 
— Similarly conceals 
the received RST text 
entry item. 

Hide QSO entry status line (NO) — Conceals the status information displayed above the QSO entry 
fields. 

Remap ‘.’ key to ‘?’ key in Call field (NO) — Enables entering the single-character wildcard symbol, 
the question mark, without needing to hold the shift key when typing a call. 

Use fuzzy similarity (NO)— Replace Contains similarity with Fuzzy similarity in Partial Call Matching. 

Underline unmatched characters (NO) — When using Fuzzy similarity, characters in known calls that 
appear in the partial call are underlined. This option instead underlines characters that do not 
appear. 

Refuse to log incomplete QSOs (NO) — Prevents adding a QSO that is incomplete (has empty 
exchange fields); instead displaying the Incomplete QSO status string.Flex 

Refuse to log any QSOs (NO) — Prevents accidentally logging any QSOs, for members of 
SkookumNet that are not making QSOs. 

Beep when call is a duplicate (NO) — Makes a sound when the call entered in the active call entry 
field is a duplicate. 

Position cursor at end of entry field (NO) — When a QSO entry field is focused, position the cursor 
at the end of the content instead of selecting the content. Does not apply to call and report fields. 
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Automatically search (NO) — Typing into a call field filters the log to show only QSOs with calls that 
contain what you have typed. The search begins when you type the third character. 

Automatically set sent grid (NO) — When enabled, SkookumLogger uses the macOS Location 
service to determine your current coordinates and converts them to a Maidenhead locator. That 
locator is used throughout SkookumLogger (except for great circle maps) as “my location.” When 
operating in a contest where your sent exchange contains your grid, the sent exchange is updated 
as needed. The Location service requires WiFi enabled.  

Do not use the SCP database (NO) — Disables partial matching against calls in the SCP database. 
Those calls are still available for defining calls in Practice mode. Some contests may prohibit this 
feature; it is your responsibility to set this option appropriately. 

Do not use the Exchange database (NO) — Disables use of your exchange database for pre-filling 
exchanges. Some contest rules may prohibit this feature; it is your responsibility to set this option 
appropriately. 

Do not test for Suspect zones (YES) — Disables testing whether or not the zone you entered 
matches the zone guessed from the call sign. 

Do not test for Suspect times (NO) — Disables marking QSOs with timestamps outside the contest 
period as suspect QSOs. Use this option as a convenience for testing without fussing with Time 
Tracker. The option is automatically turned off when you choose the Log > Reset Log command. 

Show Information window at startup (YES) — Toggles whether or not you always see the launch 
message when starting SkookumLogger. 

Distribute score (NO) — Periodically sends your current score during a contest to online 
scoreboards using an internet service provided by WA7BNM. 

Enable K4 Panadapter () — Allows SkookumLogger control of K4 external video properties, 
including setting the colors to grayscale. 

Enable audio recording (YES) — Allows SkookumLogger to create audio recordings. 

Post score to BCops (NO) — Periodically sends your score to a private scoreboard. This setting is 
hidden unless you are a member of the Black Cloud Operators group. 

Confirm Quit (NO) — Posts a “Do you really want to do that” dialog when you quit SkookumLogger. 

Correct Last QSO special key (empty) — Single-key shortcut for the Log > Correct Last QSO 
command, which copies the content of non-empty fields into the latest logged QSO. 

Serial number precision (3) — Sets the minimum number of digits used to display serial numbers in 
the sent exchange prompt when sending serials with leading zeros. 

Rate averaging interval (5.0) — Sets the period from now into the past (in minutes) used to compute 
current QSO rate in Rate Tracker. 

Automatically rescore logs smaller than (1000) — QSO count threshold for automatically rescoring 
your log when a logged QSO is changed. 

Fonts and Colors —  See Fonts and Colors. 

Version 5.4	 Page 216



SkookumLogger Guide

Messages 
Messages settings sets properties related to sending messages and contains three tabs with 
additional settings related to messages. 

SSB Messages Settings 

The SSB tab of the Messages panel defines associations between some SkookumLogger messages 
and radio DVR messages. 

Up SSB messages are associated with these SkookumLogger message titles: 

✦ CQ, BeaconCQ, AlternatingCQ, MagicRunBegin  

✦ Exchange, HisCallAndExchange, ExchangeAndLog, EndQSO (Pounce mode), BeginQSO (Run 
mode), MagicRunContinue, MagicPounceContinue  

✦ Acknowledge, EndQSO, (Run mode) AcknowledgeAndLog, MagicRunEnd  

✦ MyCall, BeginQSO (Pounce mode), MagicPounceBegin  

✦ ? (Again) 

✦ ShortAcknowledge, ShortAcknowledgeAndLog  

✦ Defend  

✦ User1  

You should should create DVR messages that correspond to the message names. Set the DVR 
number to 0 to tell SkookumLogger not to play that message. For example, if your radio has three 
DVR channels, you might assign the first channel to CQ, the second to Acknowledge, the third to 
My Call, and assign 0 to the other file messages. 
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QTC CW Messages Settings 

The QTC tab of the Message panel defines messages specific to sending and receiving QTCs in 
the Worked All Europe DX Contest. 

Some QTC messages are sent automatically as described in QTC Series. Others that have a 
function key in their label are sent when you press that key while the QTC Series window is active.  

The Begin series message automatically appends the series number and count so you will should 
include a space at the end the definition for that message. 
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QTC SSB Messages 

This tab in Messages settings defines settings for QTC messages used by the Voice Keyer. 
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Special Keys Messages Settings 

The Special Keys tab of the Messages panel defines single-key shortcuts for messages. 

These keystrokes are recognized only when a QSO data entry text field has keyboard focus. You 
can leave the definitions empty for any of the commands that you do not intend to use via this 
mechanism. The accepted special characters are ` [ ] \ ; ‘ : “ < >§ with the last five being less 
convenient as they may require holding the shift key. 

Hint: Begin QSO and End QSO are the most powerful of these items. Assign them to semicolon 
and apostrophe, respectively. 

Other Messages Settings 

The Beacon CQ Delay values set the interval between the end of a CQ message and the beginning 
of the next CQ when Beacon CQ mode is on. The delay for FSK and PSK messages is fixed at 5 
seconds. 
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Correct mode sends the received call before logging if it was changed after it was sent. 

Typing stops CQ aborts the primary CQ message and pauses Beacon CQ mode when you type 
into a QSO entry field for the entry pane with transmit focus. 

CQ changes focus to Run automatically switch transmit to Run before sending the CQ message. 
This option does not apply for 2T2R. When Pounce has transmit focus and switching to Run causes 
a band change, SkookumLogger waits 1 second before beginning to send the CQ message. 

Send leading zeros in serial numbers prepends zeros as needed to sent serial numbers smaller 
than 100. This is a convention in European DX contests. 

Cutify leading zeros in serial numbers sends T instead of a zero for prepended digits. 

Enable message chaining queues a message when you tap a send key while a message is already 
sending. Turn this off to ignore sent key presses while a message is sending, which can be 
important in keyboard-intensive operating scenarios like 2BSIQ.  

Magic Message Protocol Version chooses which of two protocols is active. 
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Operating Mode Settings 

The OpMode panel chooses your operating mode and sets related properties. 

Operating Mode — Selects one of three operating modes. The tab panes below the radio buttons 
contains settings for the selected mode when you change the mode. You can change the tab 
without affecting the selected mode. 

1T1R Options 

Transmit focus follows keyboard focus — Changing keyboard focus also changes transmit focus so 
that both are always associated with the same QSO entry pane. 

1T2R Options 

Transmit focus follows keyboard focus — Changing keyboard focus also changes transmit focus so 
that both are always associated with the same QSO entry pane. 

2T2R Options 

Grab Spots to transmit/not transmit radio — Normally, double-click on an activity copies the activity 
to the Radio 1 pane and shift-double-click copies to the Radio 2 pane. This option changes the 
target QSO entry boxes to the pane with transmit focus and the pane without transmit focus 
respectively. 
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Contest Rules 
When you create a new log, you choose a contest name, thereby defining the rules that 
SkookumLogger applies as you log QSOs. The rules determine whether or not a QSO is valid, 
whether or not a QSO is a multiplier, and the point value for a QSO. The results of applying the 
rules to a QSO are indicated by checkmarks in columns in the table of QSOs in the Log window: 

✦ D indicates a duplicate QSO 

✦ SQ indicates a suspect QSO 

✦ C indicates a country multiplier 

✦ G indicates a grid multiplier 

✦ O indicates an other multiplier 

✦ P indicates a prefix multiplier 

✦ R indicates a region multiplier 

✦ Z indicates a zone multiplier 

Columns for multipliers that do not apply for the current contest are automatically hidden. The set 
of available multipliers of each kind is usually determined by tables built into SkookumLogger. 
Many tables are contest-specific; for example, there is a table listing all of the Dutch provinces for 
the PACC contest. The Other multiplier type is used in two cases: when the multiplier doesn’t fit 
into one of the other five type (e.g., unique callsigns), or when an event has two multiplier tables of 
the same type. 

The suspect flag indicate that something in the QSO confuses SkookumLogger. You can find out 
why SkookumLogger is confused by selecting the QSO in the table and choosing Log > Explain 
Suspect QSOs. 

Every contest sponsor publishes information describing the format of their event. Use Help > 
WA7BNM Resources > Contest Rules for Current Log to view the relevant WA7BNM web page. 
That page contains a link to the relevant sponsor’s web page. 

All contests involve exchange of specified information in order to complete a valid QSO. Each QSO 
involves a sent exchange and a received exchange; they may have different components. Both 
exchanges always contain a Call component. In SkookumLogger, the remaining components of an 
exchange can be any combination of zero or more of these types: 

✦ Serial is a non-negative number 

✦ Precedence is a single letter, unique to the ARRL Sweepstakes event 

✦ Check is a two-digit number representing either year-first-licensed or age 

✦ Name is what you would expect 

✦ Grid is a Maidenhead locator, 6 or 4 characters 

✦ Info is a contest-specific bit of information, typically a region code such as state or district 
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✦ Power is unique to the ARRL DX event 

✦ Club name is unique to the RSGB Club Calls event 

✦ Club status is also unique to the RSGB Club Calls event 

✦ Zone is either CQ or ITU zone number 

In addition to these exchange components, each QSO may have sent and received signal Report 
fields. 

SkookumLogger has different input text fields for each kind of component, presenting only those 
fields relevant to the selected contest type. Input fields do some testing of key presses, usually 
converting alphabetic characters to uppercase and quietly ignoring characters that make no sense 
for the type of field; for example alphabetic characters typed into a serial number field. 

Some contests specify different exchange content depending on the locations of the QSO 
participants. For example, the LZ DX Contest expects ITU zone or LZ district. SkookumLogger uses 
the info field type in these cases, usually along with intricate code to deduce the meaning of the 
entered value in order to track multipliers. 

Incomplete Rules 
SkookumLogger doesn’t support some of the more esoteric scoring schemes invented by contest 
sponsors, including: 

✦ QSOs with /mm stations 

✦ Fractional point multipliers 

✦ Cabrillo categories not specified in the Cabrillo standard 

✦ DX-to-DX QSOs in the ARRL 160 Meter Contest 

✦ Satellite QSOs 

✦ ARRL Field Day bonuses 

✦ Multi-band over multiple days format (RSGB Xmas Cumulatives) 

✦ District code multipliers which can be worked more than once for multiplier credit (RSGB 144 & 
432 Low Power) 

✦ Mandatory off period of 1 hour between band sessions (RSGB 80/40m QRP) 
Most QSO party names include either “In” or “Outside” indicating their location-dependent 
support. 

Other cases include cases where nobody has asked and I do not or cannot enter myself: 

✦ ES-Open HF Championship does not support entrants in ES 

✦ Hungarian DX Contest does not support entrants in HA 

✦ His Majesty The King of Spain Contest does not support entrants in EA 

✦ LZ DX Contest does not support entrants in LZ 
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✦ North American QSO Party may not support entrants outside North America 

✦ OK-OM DX Contest does not support entrants in OK or in OM 

✦ Dutch PACC Contest does not support entrants in PA 

✦ RDA Contest does not support entrants in UA 

✦ French HF Championship does not support entrants in F or in French territories 

✦ Russian DX Contest does not support entrants in UA 

✦ UBA DX Contest does not support entrants in ON 

✦ UBA Spring Contest does not support entrants in ON 

✦ Ukrainian DX Contest does not support entrants in UR 

✦ YO DX HF Contest does not support entrants in YO 

Ask if you would like support added for one of these cases. 

Generic Rules 
In cases where SkookumLogger doesn’t support a particular contest, you may be able to use one 
of the following generic rules sets. These support logging QSOs, checking for dupes, and 
generating a Cabrillo file. They also track certain kinds of multipliers, but of course do not compute 
a proper score. 

Generic Serial Number Contest 

This contest type provides limited support for logging in contest involving serial numbers.  

✦ The sent and received exchange fields are Call, Report, Serial, and Info. 

✦ The Info field may be used to capture another exchange element; it is not checked by 
SkookumLogger and is pre-filled with two hyphens. 

✦ QSOs count per-band and per-mode. Multipliers count per-band and per-mode. 

✦ Multipliers are DXCC countries. 

Generic Info Contest 

This contest type provides limited support for logging in contest with one arbitrary exchange field.  

✦ The sent and received exchange fields are Call, Report, and Info. 

✦ The Info field may be used to for any text and is not checked by SkookumLogger. 

✦ QSOs count per-band and per-mode.  

✦ There are no multipliers. 

Generic Grid Square Contest 

This contest type provides limited support for logging in contest involving grid squares 
(Maidenhead locators).  
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✦ The sent and received exchange fields are Call, Report, Grid, and Info.  

✦ The Grid field expects six characters.  

✦ The Info field may be used to capture another exchange element; it is not checked by 
SkookumLogger and is pre-filled with two hyphens. 

✦ QSOs count per-band and not per-mode.  

✦ Multipliers count per-band and not per-mode. 

✦ Multipliers are the grid square (the first four characters of the Grid field. 

Generic QSO Party 

This contest type provides limited support for logging in QSO Parties.  

✦ The sent and received exchange fields are Call, Report, and Info.  

✦ The Info field is expected to contain county, US state or Canadian province codes, or “DX”. 

✦ QSOs count per-band, per-mode, per-received-county, and per-sent-county. 

✦ Multipliers are Counties (O column in the log table, Other checksheet), US States and Canadian 
Provinces (R column, Region checksheet), and DXCC countries (C column, Countries 
checksheet). K, KH6, KL, and VE do not count as country multipliers. 

✦ When the received call is a US station, the received Info value is analyzed to determine state 
and county using these rules (otherwise the multiplier is determined from the call): 

❖ If Info has two characters, it is a state abbreviation 

❖ Otherwise if Info has at least three characters: 

❖ If the first two characters are a valid state code, they identify US State 

❖ Otherwise if the last two characters are a valid state code, they identify US State 

❖ Otherwise the QSO is marked SQ (unknown state) 

❖ County and county-state abbreviations are not validated. 

Note: The complexity of these rules is needed to detect both state and county multipliers for the 
same QSO. It has a problem with Info like ‘CARNH’ — it determines that I am in CA instead of NH. If 
you care, you can work around that by flipping the received info to the canonical order: NHCAR, 
but that is likely to disturb the contest sponsor when you submit your log. 

Nontests 
SkookumLogger has a set of rules in the Nontest group. These provide support for events that 
either have no scoring or have no adjudication. These rules support events of possible interest to 
contesters, but which are not really contests. Yes, I know ARRL Field Day should be in this group. 

General Logging 

You may find this module useful if you want to use SkookumLogger for casual operation outside 
contests.  
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✦ The sent exchange includes Report, Info and Power fields. 

✦ The received exchange includes Report, Info, Name, Precedence and Notes fields.  

✦ All SkookumLogger bands are accepted. 

✦ QSOs are per-band and per-mode. 

✦ Multipliers are per-band and per-mode from the CQ country list. 

This module is in no way meant to substitute for an awards-tracking logger.  

Special Event Station 

Use this module for expedition-style logging.  

✦ The sent exchange is signal report. 

✦ The received exchange fields are Report and Notes. 

✦ All SkookumLogger bands are accepted. 

✦ QSOs are per-band and per-mode. 

✦ Multipliers are per-band and per-mode from the CQ country list.  

Changing a Log’s Rules 
This is an advanced feature intended for two specific situations. 

✦ You open an old log and SkookumLogger reports that it does not recognize the log’s contest 
name.  
In order to proceed, SkookumLogger sets the contest name to General Logging to preserve all 
of the other information in the log file. To assign new rules to this log, use File > Change Log’s 
Contest Rules to show a window for to choosing a replacement contest name with rules 
compatible with the old log.  

✦ You operate in two or more QSO parties with overlapping time periods, using one log. Of 
course, you log what you hear, even though you know some of the QSOs won’t count for some 
of the events.  
After the contests are over, you can use File > Change Log’s Contest Rules to see the Score 
breakdown for each contest. For example, I use NEQP Inside during the weekend when DEQP, 
INQP and 7QP are also active. To score the log for the other three contests, I change rules to 
DEQP Outside, INQP Outside, and 7QP Outside respectively. You can do this in any order and 
any number of times. Submit the same log to the contest sponsors; they will ignore QSOs that 
do not apply for their contest. 

Results are undefined if you choose an incompatible rules set. Incompatible means the exchanges 
are different for the existing log and the changed-to log. This is reported with a message in the 
Status Messages window. 

Version 5.4	 Page 227



SkookumLogger Guide

Entry Formatting Rules 
Each kind of entry field has a list of acceptable characters; when you type a character not on the list 
it is removed from the entry field and tested to see if it is a special key. Note that accepted 
characters cannot be special keys. 

The Grid and Report fields have lists that depend on the position of each character, which can 
cause unexpected behavior when you edit an entry. For example, if you try to change a report from 
599 to 499 by moving the cursor to the right of the 5 and pressing delete, the 5 is not deleted. The 
reason is that deleting the 5 would change the entry to 99, and the first character in a report must 
be between 1 and 5. In this example, the 5 is selected when you try to delete it, so just type a 4 to 
complete the edit. Similarly, you cannot delete any character in the Grid field except the last 
character; but the character that you are attempting to replace will be selected instead of deleted 
so that you can overtype it to complete the edit in the same number of keystrokes. 

Formatters for all entry fields convert characters that you define as special keys into commands, 
discarding the typed character. If Keyboard Mode is enabled, all characters are diverted to the 
keyer. Many formatters apply rules for converting characters to other characters, such as changing 
lowercase letters to uppercase letters. 

Call 

✦ Converts to uppercase 

✦ Accepts 0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ*,./?°: 

Check 

✦ Converts to uppercase 

✦ Accepts 0123456789ABCDEF 

✦ Also used for age, ARRL FD entry class 

Club Code 

✦ Converts to uppercase 

✦ Accepts ABCDEFGHIJKLMNOPQRSTUVWXYZ- 

Club Status 

✦ Converts to uppercase 

✦ Accepts HQ CM NC 

Grid 

✦ Converts to uppercase 

✦ For characters 1, 2 accepts ABCDEFGHIJKLMNOPQR 

✦ For characters 3, 4 accepts 0123456789 

✦ For characters 5, 6 accepts ABCDEFGHIJKLMNOPQRSTUVWX 
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Info 

✦ Converts to uppercase 

✦ When the content might be a serial, converts A to 1, E to 5, N to 9, O and T to 0 

✦ Accepts 0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ/- 

Name 

✦ Converts to capitalized string 

✦ Accepts ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz_ 

Notes 

✦ Performs no conversions 

✦ Accepts all alphanumeric, punctuation, symbol characters and the space character 

✦ Special Key definitions are not recognized 

Power 

✦ Converts to uppercase, A to 1, E to 5, N to 9, O and T to 0 

Precedence 

✦ Converts to uppercase 

✦ Accepts ABMSQU 

Report 

✦ Converts to uppercase, E to 5, N to 9 

✦ For character 1 accepts 12345 

✦ For characters 2, 3 accepts 123456789 

Serial 

✦ Converts to uppercase, A to 1, E to 5, N to 9, O and T to 0 

✦ Accepts 0123456789 

Zone 

✦ Converts to uppercase, A to 1, E to 5, N to 9, O and T to 0 

✦ Accepts 01234567890 
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Focus QSO Entry Service 
SkookumLogger creates an item named Focus QSO Entry that shows up in the General category of 
your Services menu when SkookumLogger is running. Choosing the item makes SkookumLogger 
the active application and sets keyboard focus in the most-recently-focused QSO data entry field. 
You can define a keyboard shortcut for the service in System Settings > Keyboard > Keyboard 
Shortcuts… > Services. Sometimes the keyboard shortcut is not recognized after starting 
SkookumLogger until after you choose the service at least once from the Services menu. 
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Focus Ring Animation 
In macOS the text entry field with keyboard focus has a thick blue (or gray) border. When keyboard 
focus changes to another text entry field, the border briefly pulsates, presumably to help you find 
the newly-focused item. If you find this animation annoying you can shut it off by typing this 
command in Terminal: 

defaults write -globalDomain NSUseAnimatedFocusRing -bool NO 

You will need to restart SkookumLogger after changing the default. Type the same command with 
NO replaced by YES to turn animation back on.  
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Shortcut Key Symbols 
Menu items may show a keyboard shortcut, using symbols for special keys. 

⎋ escape key 

⇥ tab key 

↩ return/enter key 

⌘ command key 

⌥ option key 

∧ control key 

⇧ shift key 

⌫ delete key 

← left arrow key 

→ right arrow key 

↑ up arrow key 

↓ down arrow key 

↖ home key (fn ←) 

↘ end key (fn →) 

⇞ page up key (fn ↑) 

⇟ page down key (fn ↓) 

The Apple wireless and laptop keyboards do not have dedicated keys for the last four items; 
instead those four items are accomplished by holding the fn key in combination with an arrow key 
as indicated in parentheses. 
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Default Menu Item Shortcuts 
SkookumLogger > Settings… ⌘, 
SkookumLogger > Hide SkookumLogger ⌘H 
SkookumLogger > Hide Others ⌥⌘H 
SkookumLogger > Quit SkookumLogger ⌘Q 

File > New Log… ⌘N 
File > New Log From Existing… ⌘N 
File > Open Log… ⌘O 
File > Toggle Recent Log ⌘R 
File > Save Log ⌘S 
File > Save Log As… ⌘S 
File > Close Window ⌘W 

Edit > Undo ⌘Z 
Edit > Redo ⌘Z 
Edit > Cut ⌘X 
Edit > Copy ⌘C 
Edit > Paste ⌘V 
Edit > Complete ⌥⎋ 
Edit > Select All ⌘A 

Log > Log QSO ↩ 
Log > Correct Last QSO ⌘\ 
Log > Delete Last QSO ⌘⌫ 
Log > Explain Selected Suspect QSOs ⌘/ 
Log > Focus Log Search Field ⌘F10 
Log > Focus Log Table ⌘F11 
Log > Focus Run QSO Entry ↟ 
Log > Focus Pounce QSO Entry ↡ 
Log > Toggle QSO Entry Focus F12 
Log > Focus Transmit Run ↖ 
Log > Focus Transmit Pounce ↘ 
Log > Toggle Transmit Focus ⇧F12 
Log > Clear Focused QSO Entry F11 
Log > Clear Unfocused QSO Entry ⇧F11 
Log > Copy Run to Pounce ⇧F9 
Log > Copy Pounce to Run ⌥F9 
Log > Copy Focused to Unfocused ⌥⇧F9 
Log > Grab Partner Call F9 

Version 5.4	 Page 233



SkookumLogger Guide

Log > Toggle Gab ⌘G 
Log > Begin QTC Series ⌘L 
Log > His Call + Begin QTC Series ⌘L 

Activity > Announce ⌘= 
Activity > Create ⌘= 
Activity > Grab to Pounce (click) ⌘↩ 
Activity > Set Pounce (⇧-click) ⇧↩ 
Activity > Set SubRX (⌥-click) ⌥↩ 
Activity > Delete (⌘-click) ⌫ 
Activity > Add to Reject List (⇧⌘-click) ⇧⌫ 

Radio 1 > Band > Radio 1 160m ⌘1 
Radio 1 > Band > Radio 1 80m ⌘2 
Radio 1 > Band > Radio 1 40m ⌘3 
Radio 1 > Band > Radio 1 20m ⌘4 
Radio 1 > Band > Radio 1 15m ⌘5 
Radio 1 > Band > Radio 1 10m ⌘6 
Radio 1 > Band > Radio 1 6m ⌘7 
Radio 1 > Band > Radio 1 4m ⌘8 
Radio 1 > Band > Radio 1 2m ⌘9 
Radio 1 > RIT/XIT > Clear ⌘↖ 
Radio 1 > RIT/XIT > Reverse ⌘↘ 
Radio 1 > RIT/XIT > Offset Up ⌘↟ 
Radio 1 > RIT/XIT > Offset Down ⌘↡ 
Radio 1 > RIT/XIT > Toggle RIT On/Off ⌥⌘↖ 
Radio 1 > RIT/XIT > Toggle XIT On/Off ⌥⇧⌘↖ 
Radio 1 > VFOs > Copy A to B ⌥⌘= 
Radio 1 > VFOs > Copy B to A ⌥⇧⌘= 
Radio 1 > VFOs > Toggle Split ⌘F9 
Radio 1 > VFOs > Exchange VFOs ⌘= 
Radio 1 > VFOs > A Up ⇧⌘↟ 
Radio 1 > VFOs > B Up ⌥⌘↟ 
Radio 1 > VFOs > A Down ⇧⌘↡ 
Radio 1 > VFOs > B Down ⌥⌘↡ 
Radio 1 > Increase Bandwidth ⌥↑ 
Radio 1 > Decrease Bandwidth ⌥↓ 
Radio 1 > Increase Attenuation ⌃⇧↑ 
Radio 1 > Decrease Attenuation ⌃⇧↓ 
Radio 1 > Increase RF Gain ⌃↑ 
Radio 1 > Decrease RF Gain ⌃↓ 
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Rotators > Stop All Rotators ⌘⎋ 

Messages > Abort ⎋ 
Messages > CQ F1 
Messages > Beacon CQ ⌘F1 
Messages > Alternating CQ ⇧⌘F1 
Messages > Copy Pounce to Run + CQ ⌥F1 
Messages > Exchange F2 
Messages > Repeat Serial Number ⌘F2 
Messages > Repeat Exchange ⌥F2 
Messages > Acknowledge F3 
Messages > My Call F4 
Messages > His Call F5 
Messages > Call? F6 
Messages > ? F7 
Messages > Again F8 
Messages > Focus Pounce + My Call ⌥F4 
Messages > Morse > Keyboard Mode ⌘K 
Messages > Morse > Step Speed Up ⌘↑ 
Messages > Morse > Step Speed Down ⌘↓ 
Messages > Record Voice Message > Message 1 ⌃⌥⌘F1 
Messages > Record Voice Message > Message 2 ⌃⌥⌘F2 
Messages > Record Voice Message > Message 3 ⌃⌥⌘F3 
Messages > Record Voice Message > Message 4 ⌃⌥⌘F4 
Messages > Record Voice Message > Message 5 ⌃⌥⌘F5 
Messages > Record Voice Message > Message 6 ⌃⌥⌘F6 
Messages > Record Voice Message > Message 7 ⌃⌥⌘F7 
Messages > Record Voice Message > Message 8 ⌃⌥⌘F8 
Messages > Save Recording ⌃⌥⌘F11 
Messages > Cancel Recording ⌃⌥⌘F12 

Window > Activity Tables > Current Band ⌥⌘- 
Window > Activity Tables > 160m ⌥⌘1 
Window > Activity Tables > 80m ⌥⌘2 
Window > Activity Tables > 40m ⌥⌘3 
Window > Activity Tables > 20m ⌥⌘4 
Window > Activity Tables > 15m ⌥⌘5 
Window > Activity Tables > 10m ⌥⌘6 
Window > Activity Tables > 6m ⌥⌘7 
Window > Activity Tables > 4m ⌥⌘8 
Window > Activity Tables > 2m ⌥⌘9 
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Window > Editors > Sent Exchange Editor ⌥⌘E 
Window > Editors > Morse Messages Editor ⌥⌘M 
Window > Editors > Data Messages Editor ⌥⌘M 
Window > Editors > Morse Speed Editor ⌥⌘V 
Window > Editors > Radio Frequency Editor ⌥⌘C 

Window > External Devices > Port Device Name Editor ⌥⌘F 

Window > Tools > Rate Tracker ⌥⌘R 
Window > Tools > Time Tracker ⌥⌘T 
Window > Tools > Score Breakdown ⌥⌘S 
Window > Tools > Grid Information ⌥⌘G 
Window > Tools > Pass Information ⌥⌘P 
Window > Tools > Status Messages ⌥⌘I 

Window > Maps > Zoom Great Circle Map In ⇧⌘= 
Window > Maps > Zoom Great Circle Map Out ⌘- 

Window > QTC Series ⌥⌘L 
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Changing Shortcuts 
You can change the keyboard shortcut for any SkookumLogger command (menu item), or add a 
shortcut for a command that doesn’t have one. 

Using macOS 
Note: When you use this approach, the changes are lost when you move to another computer. If 
you use Keyboard Maestro instead, you can save your macros to a file and load that file into 
Keyboard Maestro on another computer. 

To add a shortcut: 

✦ Open System Settings > Keyboard > Keyboard Shortcuts… > App Shortcuts 

✦ If SkookumLogger is present in the righthand list, select it. 

✦ Click the + button 

✦ Ensure that SkookumLogger is selected in the Application popup menu 

✦ Enter the command name in the Menu Title box, spelled exactly as shown in the 
SkookumLogger menu. Case and special symbols matter.  

✦ Type the keyboard shortcut 

✦ Click Add 

To change a shortcut, edit the command name or shortcut. 

The shortcuts shown in the SkookumLogger menus will update to match your custom definitions. 

Note: MacOS Sonoma (10.14) mysteriously corrupts user-defined shortcuts. In addition, this 
approach requires that all menu items in an application have unique titles, which is no longer the 
case for Panadapter items in SkookumLogger 4.7. 
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Using Keyboard Maestro 
Keyboard Maestro is a macOS application that, among other things, creates keyboard shortcuts 
that you can activate at any time. It is significantly more powerful than defining shortcuts for menu 
items in in macOS Keyboard settings, in particular because it allows using keys aren’t otherwise 
available, such as keys on extended keyboards and the caps lock key. And you can create macros 
that use a single key to perform several commands. 

Introductory Tutorial 

The first step is to add an item in the Groups list that will contain your shortcut macros for 
SkookumLogger: 

✦ Click the + button at the bottom of the Groups list. 

✦ Name the new group in the editor pane to the right of Groups and Macros lists. 

✦ Click the green + button in the editor and choose SkookumLogger in the popup list of 
Applications. 

Shortcut macros that you add to this group will only apply to SkookumLogger, and only when 
SkookumLogger is the active application. 
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To create a shortcut macro: 

✦ Click the + button at the bottom 
of the Macros list. 

✦ Enter a name for the new macro. 

✦ Click the green + button labeled 
“New Trigger” and choose “Hot 
Key Trigger” in the popup list. 

✦ Enter a key combination in the 
“Type” field.  

✦ Click the green + button labeled 
“New Action. The Groups and 
Macros lists are covered an 
Actions pane. Type menu into the 
search field at the top of the pane, then double click the “Select or Show a Menu Item” action. 
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✦ In the “Will execute the following actions:” box, choose SkookumLogger in the list following the 
“Select menu in” label. SkookumLogger must be running in order to appear in this list. 

✦ Now click the Menu popdown list 
and navigate to the menu item in 
SkookumLogger that will be 
triggered by the hot key and click 
that leaf item. The Select menu in 
popup list will change to 
“SkookumLogger”. The Menu Title 
field will contain Log, 
corresponding to the Log menu 
in SkookumLogger. The Menu 
Item field will contain Log QSO, 
the selected leaf item in the Log 
menu. If there are submenus 
between the leaf menu item and 
the SkookumLogger main menu 
bar, Keyboard Maestro will 
include them in the action 
definition. 

Note: To return close the Actions pane, click the x at the top left corner of the pane. 

Begin QSO Example Macro 

Begin QSO sends a message that depends on whether transmit focus is Run or Pounce. Typically it 
is triggered by a “Special Key” in SkookumLogger. This macro uses the same trigger without 
needing the special key definition. I use a similar macro for End QSO. 

Trigger: 

Hot Key ; is pressed. 

Action: 

Messages > Begin QSO 

Focus Pounce and Send My Call Example Macro 

This macro includes a Pause action between changing transmit focus and starting to transmit, to 
accommodate radios that don’t change frequencies or bands rapidly. 

Trigger: 

Hot Key F18 is pressed. 

Actions: 

Log > Focus Transmit Pounce 
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Pause for 0.01 seconds  

Messages > My Call 

Steal Frequency Example Macro 

Sometimes when doing S&P you find a good frequency to begin CQing. You want to copy the 
pounce frequency to the run frequency and change both keyboard focus and transmit focus to run. 
But there is no menu command for doing that. 

Trigger: 

Hot Key ⇧F19 is pressed. 

Actions: 

Log > Copy Pounce to Run 

Log > Focus Run QSO Entry 

I use the “Transmit focus follows keyboard focus” option to cause the transmit focus change. 

Keyboard CW Example Macro 

Quickly toggling into and out of keyboard CW mode is important for those of us who prefer not to 
use a paddle (or would embarrass themselves trying to). The caps lock key is an ideal trigger for 
this action because it is otherwise unused in SkookumLogger, and because some keyboards have a 
indicator light on the key. In this case, instead of a Hot Key Trigger, use a “USB device key”. 

Trigger: 

The Magic Keyboard with Numeric Keypad Caps Lock key is pressed. 

Actions: 

Messages > Morse > Keyboard Mode 

Focus QSO Entry Example Macro 

This macro makes SkookumLogger the active application and sets keyboard focus to the most 
recently focused QSO entry field. SkookumLogger installs an item in the Services menu that does 
the same thing, but a bug in macOS doesn’t recognize the shortcut for that item until after you 
choose it once in the Services menu — for each application, and for every time you start 
SkookumLogger. Add this macro to the Global Macro Group so that it works regardless of which 
application is active. 

Trigger: 

Hot Key F19 is pressed. 

Actions: 

Activate SkookumLogger. 

Log > Focus Recent QSO Entry 

I use F19 because it is at the top right corner of my keyboard where I can tap it without looking. 
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Using Function Keys 
macOS interferes with direct access to function keys, which you want to use for starting message 
transmission by tapping a single key. To avoid holding the fn key along with a function key: 

✦ Open System Settings > Keyboard 

✦ Tap the Keyboard Shortcuts… button 

✦ Choose Function Keys in the sidebar 

✦ Turn on the “Use F1, F2, etc, keys as standard function keys” option 

To prevent system applications from intercepting function keys: 

✦ Navigate to the sidebar as above 

✦ Select Mission Control and uncheck the items that use F11 and F12 

✦ Select Services and uncheck any items that use function keys 
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Using a Mouse 
SkookumLogger is designed to use your keyboard for nearly everything you do while contesting. 
However, there are tasks where it is more direct to grab your mouse (or position the cursor with 
your trackpad) and click on something. There are four important cases of these direct actions in 
SkookumLogger: 

✦ Clicking on a QSO entry field makes that field the item with keyboard focus. 

✦ Clicking on a row in an Activity table applies a command to that activity, with the command 
depending on which modifier keys are depressed when you click. 

✦ Clicking anywhere inside a Great Circle Map applies a command using the click point 
coordinates, with the command depending on which modifier keys are depressed when you 
click. 

✦ Clicking on a row in the Log table selects the row. Then click on cell in that row to select the 
content for editing. 
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Uninstalling or Moving SkookumLogger 
To completely uninstall SkookumLogger or to move it to another computer or user account, you 
need to know where SkookumLogger stores its settings and support files. Because 
SkookumLogger is “sandboxed”, the easiest approach is to erase or copy this folder and all of its 
contents: 

~/Library/Containers/com.k1gq.SkookumLogger 

The settings file path is: 

~/Library/Containers/com.k1gq.SkookumLogger/Data/Library/Preferences/
com.k1gq.SkookumLogger.plist 

and the support files folder path is: 

~/Library/Containers/com.k1gq.SkookumLogger/Data/Library/Application Support/
SkookumLogger 

Scripts recognized by the XK-24 Keyboard are located in: 

~/Library/Application Scripts/com.k1gq.SkoookumLogger/ 
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Ten Features to Improve Contest Operating 
1. Use Practice Mode and use Magic Message in CW contests. 

2. Tailor your own database files for auto-completion of exchange information. 

3. Get slick with using S&P while running a frequency via Activity info and F12. 

4. Use the rate information during the contest to remind you when to adapt strategy. 

5. Use the Numbers export to analyse performance post-contest for next time. 

6. Use appropriate filters on the DX Cluster and RBN facilities to target spots needed. 

7. Keep an eye on the terminator line on the great circle map in appropriate contests. 

8. When applicable, use checklists and activity windows to find obvious missing multipliers and 
search them out. 

9. Use SCP information to narrow down likely call options on a busy/noisy band. 

10.Use the pass information window to identify key stations to try moving to other bands for 
multipliers. 
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Ten Keyboard Shortcuts to Remember 
Note that shortcuts may be redefined. 

1. ⎋ — Messages > Abort 

2. F10 — Log > Focus Recent QSO Entry

3. F11 — Log > Clear Focused QSO Entry

4. F12 — Log > Toggle QSO Entry Focus

5. ⌘\ — Log > Correct Last QSO

6. ⌘- — Maps > Zoom Great Circle Map Out

7. ⇧⌘= — Maps > Zoom Great Circle Map In

8. ⌘↩︎ — Activity > Grab to Pounce

9. ⌥F9 — Log > Copy Pounce to Run (sets your run frequency to the pounce frequency) This can 
be useful if during tuning for S&P you find a clear run frequency, or if you want to quickly QSY 
to an apparent gap near someone you’ve clicked in the activity table to call QRL? and then CQ 
if clear. Alternatively, Log > Steal Frequency replaces Run frequency, mode, received exchange 
with Pounce frequency, mode, received exchange; clears pounce received exchange; transfers 
keyboard and transmit focus to Run; and positions cursor at end of call field content. 

10.⇧F9 — Log > Copy Run to Pounce 
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Ten Useful Mouse Click Gestures 
Ok so during a contest we don’t want to resort to the mouse or trackpad very often, but there are 
cases where it is the best user interface. Here is a list of ten ways to use it if needed. 

1. Hover the pointer over a label, text entry field, menu item, map, etc., to see a tooltip. 

2. Click an entry in an Activity window: 
Loads activity to pounce and changes transmit focus to pounce. 

3. Shift-click an entry in an Activity window: 
Loads activity to pounce but does not change transmit focus. 

4. ⌘-click an entry in an Activity window: 
Deletes the activity from the table. 

5. ⌥-click an entry in an Activity window: 
Sets the radio subreceiver (if supported) frequency to the activity’s frequency. 

6. Double-click in the notes field in a row of the main log table to enter note text for the QSO. 

7. Click in any QSO Entry pane text field to transfer keyboard focus into that QSO Entry pane. 

8. Click in any row of the QTC Series window table to focus that row for editing. 

9. ⌘-click the great circle map to turn rotator 1 to the bearing of the clicked. Also hold the shift 
key to turn to the long path bearing. 

10.Hold the shift key while dragging either GCM or Grid map to move it within the window. 
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Useful Web URLs 
This section provides some web references relevant to the material in this guide: 

SkookumLogger:	 http://www.k1gq.net/SkookumLogger/index.html  

Maps downloads:	 https://www.k1gq.net/Maps/index.html  

SCP Database:	 http://www.supercheckpartial.com 

Country Database:	http://www.country-files.com 

Spot Filtering:	 http://www.nc7j.com/arcluster/arusermanual-6/AR-Cluster%20DX.html 
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FAQ: Problems 
Reporting a Crash 
First choice 

Use Console to find and send me the crash report: 

✦ Open the Console app, from Applications > Utilities. 

✦ Select Crash Reports in the sidebar. 

✦ Select a crash report for SkookumLogger in the Process Name list. 

✦ Click the Share button in the toolbar and choose the Mail option. 

✦ Address the email to k1gq@hey.com. 

✦ Set the subject to [SkookumLogger Crash] <contest name>. 

✦ Add any details you can about what you were doing when the crash occurred and how to 
reproduce the crash. 

✦ Send the email. 

Second choice 

If you can’t find a crash report, send me an email with details about what you were doing when the 
crash occurred and how to reproduce the crash. List your macOS and SkookumLogger versions, 
which contest you were operating, and describe your hardware configuration including your 
computer model. 

Messages Don’t Play 
Sometimes message transmission gets stalled waiting for notification that something has been 
sent. A clue for this condition is that the color of the mode text is red, orange, or blue. The solution 
is to tap escape to clear out the message queue. 

Frequency is Zero 
The frequency displays are zero when SkookumLogger is unable to communicate with a radio. In 
this case you can use text commands with the Phantom radio type to provide frequency and mode 
for logging QSOs. 

Radio 2 Doesn’t Work 
When you enable Radio 2, you won’t see the radio frequency and mode or be able to control the 
radio unless you turn on 2T2R operating mode. 

Score is Zero 
SkookumLogger ignores QSOs in your log that are marked as suspect when checking for 
duplicates and filling the Score table. See Suspect QSOs for more information about suspects. 
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A common cause of a suspect is logging a QSO at a time which is outside the contest period. 
Sometimes SkookumLogger guesses wrong for the start date or start time. You can use Time 
Tracker to edit these items if necessary. Or, use the Do not test for Suspect times option in Logging 
settings. 

Window Layout is Forgotten 
If you use multiple monitors with SkookumLogger and want to preserve window positions on all 
screens, turn off the Displays have separate Spaces option in System Settings > Desktop & Dock. 
Otherwise, macOS gathers all open SkookumLogger windows onto the same screen as the main 
window; that is a macOS feature. You may need to log out or reboot for the change in this 
preference to take effect. 

Missing Log Column 
First, confirm that the name of the missing column is checked in the visibility popup menu (right-
click on the table headings row). Then, make the window wider to reveal columns that may be 
outside the right edge of the window. 

Intermittent Hangs 
If the spinning beachball cursor appears intermittently, try these steps to isolate the cause: 

✦ Disconnect all serial devices. 

✦ If the hangs stop happening, reconnect devices one at a time until you know which is causing 
the problem. 

✦ Confirm that you have selected the correct port for the problem device. 

✦ Confirm that the device serial comm parameters, especially the speed, are set to the values that 
SkookumLogger expects for the type of device you have selected. 

Some functions normally can take long to complete that the beachball will appear, including: 

✦ Rescoring a large log 

✦ Creating a statistics report 

✦ Merging large logs with SkookumNet 

Missing Serial Ports 
If the popup menus do not list some (or any) of you serial ports, you will need to reboot your 
computer. Sometimes unplugging a USB-serial cable while the device is in use causes the driver to 
fail, affecting all devices that use that driver. 

Log Doesn’t Reopen  
If the most recent log does not open when you start SkookumLogger, and if that is not the behavior 
that you want, uncheck the Close windows when quitting an app option in the Desktop & Dock 
panel of System Settings. 
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Radio Stuck in Transmit 
Some radios can be configured to use the DTR or RTS lines in the serial connection to switch into 
transmit mode. SkookumLogger does not use these lines, but their default state might cause the 
radio to become stuck in transmit. You will need to find the appropriate setting in your radio and 
disable it. For example, the USB SEND setting in an IC-7610 needs to be OFF. Thanks NØEHX. 

Dupe Checking Doesn’t Work 
This can happen when one or more QSOs are marked SQ in the log table. See Score is zero. 

Sent Serial Numbers are Messed Up 
If you delete a logged QSO containing a sent serial number, that serial number will not appear in 
the Cabrillo file. Ignore contest rules that demand serial numbers must increment by 1. 

SkookumLogger reserves the sent serial number as soon as you send it, instead of waiting until you 
log the QSO. This is necessary to log what you sent when interleaving QSOs, with the consequence 
that serial numbers may not increase chronologically in the Cabrillo file. Ignore contest rules that 
demand otherwise. 

Serial numbers are generated separately for each station in SkookumNet. Some contests require 
that multi-station logs contain one serial number sequence for all stations; SkookumLogger does 
not support that rule. 

Sent serial numbers do not affect your score breakdown in any way. Trust SkookumLogger to log 
what you sent, using the sent exchange message on CW and the sent exchange prompt on phone.  
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FAQ: Terminology 
Assisted versus unassisted 
Contest sponsors group entrants into numerous categories, based on various things such as 
transmit power level. One common category is based on whether or not the entrant makes use of 
information from internet spotting networks; those that do are “assisted” while those that do not 
are “unassisted.” In SkookumLogger, if you use the DX Cluster preference pane to connect to either 
a DX Spider Node (DX Cluster) or the Reverse Beacon Network (RBN), or if you utilize other sources 
of information (as defined by each individual contest’s sponsor) originating beyond your own 
station, you are in the assisted category. 

Pounce frequency 
Contest operating involves two modes. In the Run mode, you CQ and exchange information with 
stations who answer your CQs. In the Search-and-Pounce mode, you find others who are CQ-ing 
and exchange information with them. Pounce frequency refers to the transmit frequency of a 
station that you have found in the Search-and-Pounce mode. 

Focus 
“Focus” is a term used in computing that identifies which user interface element in an application 
handles keyboard entries. So “focus log” means “I want to type into the log (QSO Entry pane 
fields)". “Focus activity table” means “I want keystrokes to be handled by the Activity table for the 
current band.” In the latter case, keystrokes affect the selected row in the table. 

Pass information? 
In multi-band contests, a common strategy is to ask high-point-value stations that you are working 
to QSY to another band where they are needed by you (usually as a previously unworked band-
multiplier). That strategy is called  “passing”. The Pass Information window shows you the bands 
where you need the station being worked, so you know whether or not to ask for a QSY and where 
to go. 

Menu item shortcut key symbols 
The symbols on the menu items are Apple-defined standards. A quick way to discover the 
association between the symbols and the keys on your particular keyboard is to open the 
Keyboard Viewer. That tool is available in the Keyboard menu near the right end of your menu bar 
at the top of the screen. If “Show Keyboard Viewer” doesn’t appear in that menu, then visit the 
Keyboard pane in Keyboard System Settings and check the Show Keyboard & Character Viewer 
box. 
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FAQ: Users Coming From Another Logger 
We all get used to the things that we are familiar with. Sometimes this is fine, while other times it 
restricts thinking as to whether we could improve or do something differently. This section tries to 
answer frequent questions that arise from users new to SkookumLogger but familiar with other 
contest loggers. In answering such questions, some of the philosophy of the author and 
contributors to SkookumLogger becomes apparent.  

Enter Sends Message 
When designing SkookumLogger, it wasn’t simply a case of copying over features from other 
contest loggers without consideration of whether they are necessary or could be improved. ESM is 
either loathed or loved and has to be switched on or off to please each type of user since it 
changes the behavior of the Enter key for everyone when switched on. GØDVJ designed Magic 
Message to improve upon this by providing a similar capability but which can exist alongside 
normal operation and used or ignored by users as they see fit. Magic Message can, optionally, use 
the return key for triggering sending of context-dependent messages. 

Call history files 
The prime authors of SkookumLogger hold a view that apart from the de-facto standard country 
and SCP databases, pre-fills from databases should be used by the people that created them 
through their own effort, rather than effectively relying on crowdsourcing to save the operator any 
effort at all. The Exchange Archive feature in SkookumLogger effectively allows each user to build 
up his or her own database over time and various contests to pre-fill exchange information, without 
simply loading possibly unreliable lists of data passed around by others.  

Band maps 
SkookumLogger’s Activity windows are the equivalent of band maps, providing similar 
functionality. However, they allow additional sources of data to populate them compared to those 
of band maps, and the entries can be sorted in many ways (e.g., bearing). If you are used to 
graphical rather than textual formats of band maps, Activity windows do not provide this.  

Why not use the Radio’s CW keyer? 
Call type-ahead allows you to to start sending your response to a caller when CQing without 
needing to enter the full call before you start the message. All you need to do is type the next 
character in the call before it is about to be sent. If you listen to expert CW operators, you will 
notice there is no delay between when a caller finishes sending their call and when the expert 
begins sending it in response. This is important not only because delays waste time, but because 
delays often stimulate callers — including other callers — to start sending their calls again, wasting 
more time. 

To implement type-ahead, SkookumLogger needs cooperation from the keyer: 

❖ The computer sends a character to the computer and returns to other tasks like handling call 
typing input.  
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❖ The keyer notifies the computer when it is beginning to “send” the space following the 
character. 

❖ The computer determines the next character and sends it to the keyer before the space 
ends. 

Radio keyers (CW encoders) don’t provide this feedback. 

My IC-7610 isn’t working with SkookumLogger  
NØEHX did a lot of testing of the various setting in the CIV menu: 

CI-V Baud Rate — Auto (Any setting works, but Auto works as well. This setting has nothing to 
do with CI-V over USB anyway.) 

CI-V Address — 98h 

CI-V Transceive — Either ON or OFF works with SkookumLogger 

CI-V USB/LAN -> REMOTE Transceive Address — 00h (I honestly don't know what this one is 
for.) 

CI-V Output (for ANT) — OFF 

CI-V USB Port — Unlink from [REMOTE] 

CI-V USB Baud Rate — Auto (This is important for SkookumLogger. Applications that use the 
pan adapter send feature must set CI-V USB Baud Rate to 115,200 but that setting will not 
work with SkookumLogger.) 

CI-V USB Echo Bak — ON (This is needed for other apps and SkookumLogger works with it ON 
as well.) 

Can I use my MicroHAM device? 
Most of the radios supported by SkookumLogger — if attached to a microHAM USB radio interface 
— should function the same as if directly connected to a serial/USB port. Other types of microHAM 
devices are not supported. 
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Version History 

Version Date SkookumLogger Version

0.1 18 Jan 2011 Initial draft for SkookumLogger version 0.11.4

0.2 21 Jan 2011 For SL v 0.11.6 after initial review by Bill K1GQ

0.3 27 Jan 2011 For SL v.0.11.8 & after review by G4FTP

0.4 1 Feb 2011 For SL v1.0.0 & after review by JH5GHM/1

0.5 7 Feb 2011 For SL v1.0.1

0.6 16 Feb 2011 For SL v1.0.2

1.1 10 Apr 2011 For SL v1.1.0 (version number harmonised with SL)

1.2 29 July 2011 For SL v1.2.0 (added WAEDC support etc)

1.2.3 7 Aug 2011 For SL v1.2.3 (added Mode/IOTA databases, FAQs, etc)

1.3 20 Sep 2011 For SL v1.3 (UI changes, guess-file update, serial refs)

1.4 15 Apr 2012 For SL v1.4 (Exchange db, partial support table, switch)

2.3 Jan 2019 For SL v.2.3 (complete rewrite to update to latest SL)

2.6 August 2020 For SL v.2.6 (external devices UI, fuzzy SCP, etc)

3.0 October 
2020

For SL v3.0 (remove obsolete QTC, spot grab offset, and time search 
text comm discussions, update terminology and figures.)

3.5 June 2022 For SL v.3.5

4.0 August 2023 Merge content of Help Book and hint pages into the Guide to make it 
the single authoritative document.

4.1 2023-09-01 Remove mention of WRTC 2022 QSO broadcasting and update 
Logging settings image. 
Clarify discussion of SQ and X-QSO. 
Replace Audio Recording chapter content to describe new feature. 
Improve the discussion of WinKeyers and emulations. 
Update the Log Window Components discussion in the Log Window 
chapter of the Advanced Operating section. 
Add list of all default menu item shortcuts.
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4.2 Repair typos, fix missing links, clarify prose; pages 25 - 30. 
As above, pages 36 - 43. 
Revise Magic Message discussion for version 1, version 2 logic and 
use of return as trigger key. 
Add Problem FAQs for Radio 2 and Serial Numbers. 
Note that a Voice Over hotspot can be set for the QSO Status 
Information text items.

4.3 2023-11-14 Update Magic Message and Audio Recording topics 
Add note for MacOS 14.1 issue when showing Statistic and Rate 
Breakdown documents. 
Update Special Keys topic. 
Additional repairs for typos, missing links and clarity, pages 64 - 78.

4.4 2024-01-10 Repair typos, fix missing links, clarify prose; pages 87 - 99. AI6W 
Repair typos, fix missing links, clarify prose; Advanced Operating 
section. AI6W 
Add description of Repeat Exchange message. 
Delete the Unstack QSO Messages menu item.

4.5 2024-03-13 Revise discussion of CW encoders in Text Encode/Decode.  
NEQP exchange format changed from county-state to state-county.

4.6 2024-04-26 Fix link on page 2 to shortcut key symbols. 
Add documentation for Voice Keyer. 
Clarify K4 Mini-Pans discussion. Cover both mini-pan streams.

Version Date SkookumLogger Version
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4.7 2024-06-12 Document voice synthesis for digits. 
Elaborate on 2T2R behavior and examples. 
Describe loading behavior for Countries and SuperCheckPartials 
databases. 
Document BadSCPCalls.txt in SuperCheckPartials topic. 
Elaborate on the {n message token in the Messages Editor topic. 
Clarify query messages (F6, F7 and F8) in Basic Messages topic, 
adopting changed default titles and content. 
Update graphics for Messages settings and editors. 
Revise all of the Panadapter chapter.  
Remove the Panadapters chapter in Advanced Operating section.

4.8 2024-07-08 Revise Advanced Operating > Panadapters.  
Revise Advanced Operating > Activities. 
Describe KPA1500 virtual antenna support in External Devices and 
Networking > Antenna Switching. 
Add User Articles section for contributions by users. 
Describe behavior of tuning near an activity in Pounce mode when 
Fills QSO entry from nearby activity is on.

4.9 2024-08-06 Update the Hint in Matching a Caller’s CW Speed. Thanks CT1DRB. 
Update Logging settings image and discussion of database options. 
Replace description of Magic Message Version 2 (ESM).

5.0 2024-10-30 Remove contact information for K1JSM. 
Add Default Antenna Configuration in Antenna Switching chapter. 
Add note about italic face for worked-before and zero-point call 
adornment. 
Document new Enable message chaining Messages setting. 
Revamp Practice Mode chapter to reflect new Practice 2 
implementation. 
Improve discussion of KPA1500 antenna tuner setting feature.

Version Date SkookumLogger Version
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Guide ToDos 

Scrub the Example Window Layouts chapter. 

List supported radios and supported contests in Reference. 

Improve use of links to bookmarks to reduce repetitive and possibly inconsistent content. 

5.1 2024-12-27 Clarify discussion of SO2R behavior. W6FB. 
Update list of Pan window Grab cursor behaviors. 
Document new UI for Radios. 
Update Voice Keyer documentation.

5.2 2025-02-17 Note change to default start date and duration for new logs with 
unknown calendar data. Add list of contests with unknown calendar 
data. 
Remove the “send to Apple” choice in the FAQ about reporting 
crashes. 
Update the SkookumNet chapter to discuss finding and dealing with 
inconsistencies between net members. 
Document the new practice behavior setting 
PracticeClosestPouncerAlwaysReplies. 
Update the Using Keyboard Maestro chapter. 
Update the Practice window image. 
Update the list of contests supported by Practice mode.

5.3 2025-06-06 Clean up discussion in the Being a Rover section of the QSO Parties 
chapter. 
Update list of contests supported in Practice mode. 
Update Time Tracker, to describe 8-day calendar. 
Update relevant Help menu items to refer to WA7BNM sub-menu 
items. 
Add ICOM Radios section to the Radios chapter. 
Document new Logging option Beep when call is a duplicate. 
Document Log > Speak… VoiceOver menu items. 
Redo the DX Cluster chapter for change to DXSpider nodes. 
Update Connecting Your Radio in the First Time Setup chapter.

5.4 Improve Spot Filtering discussion and link to reference 
documentation.

Version Date SkookumLogger Version
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Watch for wrong font, spelling, punctuation errors. 

Test links. 

Scan each chapter for image layout issues; chapters always start on a new page so layout issues do 
not propagate beyond the end of a chapter. 
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